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MPLAB® REAL ICE™ IN-CIRCUIT
EMULATOR USER’S GUIDE FOR
MPLAB X IDE

Preface
INTRODUCTION
This chapter contains general information that will be helpful to know before using the 
MPLAB® REAL ICE™ in-circuit emulator. 
Items discussed here include:
• Document Layout
• Conventions Used in this Guide
• Recommended Reading

NOTICE TO CUSTOMERS

All documentation becomes dated, and this manual is no exception. Microchip tools and 
documentation are constantly evolving to meet customer needs, so some actual dialogs 
and/or tool descriptions may differ from those in this document. Please refer to our web site 
(www.microchip.com) to obtain the latest documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each 
page, in front of the page number. The numbering convention for the DS number is 
“DSXXXXXXXXA”, where “XXXXXXXX” is the document number and “A” is the revision level 
of the document.

For the most up-to-date information on development tools, see the MPLAB® X IDE help. Select 
the Help menu, and then Topics to open a list of available help files.
 2013-2014 Microchip Technology Inc. DS50002085B-page 9
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DOCUMENT LAYOUT
This document describes how to use the MPLAB REAL ICE in-circuit emulator as a 
development tool to emulate and debug firmware on a target board, as well as how to 
program devices. The document is organized as follows:
Part 1 – Overview & Operation
• Chapter 1: About the Emulator – What the MPLAB REAL ICE in-circuit emulator 

is, and how it can help you develop your application.
• Chapter 2: Device and Feature Support – Tables of supported features by 

device families.
• Chapter 3: Operation – The theory of MPLAB REAL ICE in-circuit emulator 

operation and descriptions of configuration options.
Part 2 – Features
• Chapter 4: General Setup – How to set up MPLAB X IDE to use the emulator.
• Chapter 5: Common Debug Functions – A description of basic emulator 

features available in MPLAB X IDE when the MPLAB REAL ICE in-circuit 
emulator is chosen as the debug tool. This includes debug features such as 
breakpoints, stopwatch, and external triggering.

• Chapter 6: Specific Debug Functions: 8- and 16-Bit Devices – A description of 
data capture, runtime watches, trace for 8- and 16-bit (data memory) devices, PC 
sampling, Application in/out and other debug features.

• Chapter 7: Specific Debug Functions: 32-Bit Devices – A description of data 
capture, runtime watches, trace for 32-bit (data memory) devices, PC sampling, 
Application in/out and other debug features.

Part 3 – Troubleshooting
• Chapter 8: Troubleshooting First Steps – The first things you should try if you 

are having issues with emulator operation.
• Chapter 9: Frequently Asked Questions (FAQ) – A list of frequently asked 

questions about emulator operation and issues.
• Chapter 10: Messages – A list of error messages and suggested resolutions.
• Chapter 11: Engineering Technical Notes (ETNs) - Any resolvable hardware 

issues are listed.
Part 4 – Software & Hardware Reference
• Chapter 12: Emulator Function Summary – A summary of emulator functions 

available in MPLAB IDE when the MPLAB REAL ICE emulator is chosen as the 
debug or program tool.

• Chapter 13: Hardware Specification – The hardware and electrical 
specifications of the emulator system. Includes a description of how to use the 
loop-back test board.

Part 5 – Emulator Accessories
Describes additional items for sale that do not come with the basic emulator system, 
such as the Performance Pak for High-Speed/LVDS Communications.
DS50002085B-page 10  2013-2014 Microchip Technology Inc.



Preface
CONVENTIONS USED IN THIS GUIDE
The following conventions may appear in this documentation:
TABLE 1: DOCUMENTATION CONVENTIONS

Description Represents Examples

Arial font:
Italic Referenced books MPLAB® X IDE User’s Guide

Emphasized text ...is the only compiler...

Initial caps A window the Output window

A dialog the Settings dialog

A menu selection select Enable Programmer

Quotes A field name in a window or 
dialog

“Save project before build”

Underlined, italic text with 
right angle bracket

A menu path File>Save

Bold A dialog button Click OK
A tab Click the Power tab

Text in angle brackets < > A key on the keyboard Press <Enter>, <F1>

Courier font:
Plain Sample source code #define START

Filenames autoexec.bat

File paths c:\mcc18\h

Keywords _asm, _endasm, static

Command-line options -Opa+, -Opa-

Bit values 0, 1

Constants 0xFF, ’A’

Italic A variable argument file.o, where file can be 
any valid filename

Square brackets [ ] Optional arguments mpasmwin [options] 
file [options]

Curly brackets and pipe 
character: { | }

Choice of mutually exclusive 
arguments; an OR selection

errorlevel {0|1}

Ellipses... Replaces repeated text var_name [, 
var_name...]

Represents code supplied by 
user

void main (void)
{ ...
}

 2013-2014 Microchip Technology Inc. DS50002085B-page 11
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RECOMMENDED READING

Emulator Recommended Reading
This document describes how to use the MPLAB REAL ICE in-circuit emulator. Other 
useful documents are listed below. 
The following Microchip documents are available and recommended as supplemental 
reference resources.
Multi-Tool Design Advisory (DS51764)
A small document on guidelines and implementation considerations to ensure proper 
interfacing to the various development tools.

Release Notes for MPLAB REAL ICE In-Circuit Emulator
For the latest information on using the MPLAB REAL ICE in-circuit emulator, read the 
“Readme for MPLAB REAL ICE Emulator.htm” file (an HTML file) by clicking on 
“Release Notes and Support Documentation” on the Start Page. The release notes 
(Readme) contain update information and known issues that may not be included in 
this document.

Using the MPLAB REAL ICE In-Circuit Emulator (DS51997)
This poster shows you how to hook up the hardware and install the software for the 
MPLAB REAL ICE in-circuit emulator.

MPLAB REAL ICE In-Circuit Emulator Help
An on-line version of the comprehensive emulator user’s guide in MPLAB X IDE. 
Usage, troubleshooting and hardware specifications are included.

Processor Extension Pak and Header Specification (DS51292)
These booklets describe how to install and use MPLAB REAL ICE in-circuit emulator 
headers. Headers are used to better debug selected devices using special 
-ME2/-ICE/-ICD device versions, without the loss of pins or resources. Extension Paks 
contain headers. See also the help files.

Transition Socket Specification (DS51194)
Consult this document for information on transition sockets available for use with head-
ers.

Accessories Recommended Reading
Accessories for the emulator as discussed in detail in this document. However, instruc-
tion sheets exist to help you quickly set up these additional tools.
MPLAB REAL ICE Isolation Unit Instruction Sheet (DS51858)
This poster shows you how to hook up the opto-isolation unit hardware for high power 
applications.

MPLAB REAL ICE JTAG Adapter Instruction Sheet (DS52094)
This poster shows you how to hook up the JTAG adapter board for JTAG functionality. 
Be aware you will not have the full suite of debug features when using this board.

MPLAB REAL ICE In-Circuit Emulator Power Monitor Instruction Sheet 
(DS50002156)
This poster shows you how to hook up the power monitor board for viewing power 
usage on your target board.
DS50002085B-page 12  2013-2014 Microchip Technology Inc.
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Chapter 1.  About the Emulator
1.1 INTRODUCTION
The MPLAB REAL ICE in-circuit emulator is a modern emulator that supports hardware 
and software development for selected Microchip PIC® microcontrollers (MCUs) and 
dsPIC® Digital Signal Controllers (DSCs).
An overview of the emulator is provided in this chapter:
• Emulator Features
• How the Emulator Helps You
• Emulator System
• Emulator Kit Components

1.2 EMULATOR FEATURES
The MPLAB REAL ICE emulation concept provides these features:
• Processors run at maximum speeds
• Debugging can be done with the device in-circuit
• No emulation load on the processor bus
• Simple interconnection
• Capability to incorporate I/O data
• Instrumented Trace (MPLAB IDE and Compiler Assisted)
• PIC32 Instruction Trace (Hardware trace)
In addition to emulator functions, the MPLAB REAL ICE in-circuit emulator system can 
also be used as a production programmer.

1.3 HOW THE EMULATOR HELPS YOU
The MPLAB REAL ICE in-circuit emulator is an integral part of the development engi-
neer's toolsuite. Application usage can vary from software development to hardware 
integration, manufacturing test, or field service.
The MPLAB REAL ICE in-circuit emulator system enables you to:
• Debug an application on hardware in real time
• Debug with hardware breakpoints
• Debug with software breakpoints (device-dependent)
• Halt, based on internal events and/or external signals
• Monitor internal file registers
• Emulate full speed
• Program devices as a production programmer
• Trace lines of code or log variable/expression values
 2013-2014 Microchip Technology Inc. DS50002085B-page 15
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1.4 EMULATOR SYSTEM
The MPLAB REAL ICE in-circuit emulator is an in-circuit emulator that is controlled by 
a PC running MPLAB X IDE cross-platform software. The emulator communicates with 
a device or debug header that has on-board debug/emulation circuitry. A device is usu-
ally connected directly to a target board, whereas a header may be connected directly 
to or through a transition socket.
An example emulator system configuration is shown in Figure 1-1. For other possible 
configurations, see Section 3.4.1 “Standard Communication” and 
Section 3.4.2 “High-Speed/LVDS Communication (Performance Pak)”.

FIGURE 1-1: EXAMPLE EMULATOR SYSTEM SETUP

1.5 EMULATOR KIT COMPONENTS
The components of the MPLAB REAL ICE in-circuit emulator system kit are listed 
below.
1. Emulator pod – main unit.
2. USB cable – provides communications between the emulator and a PC, and 

provides power to the emulator.
3. Standard driver board and cable – connects the emulator pod to a header module 

or target board.
4. Logic probes – used for external triggers and I/O port trace.
5. Loop-back test board – verifies emulator operation.

Additional hardware may be ordered separately. See the Microchip website 
(www.microchip.com) for available items. Some popular items are:
• Processor Extension Pak – provides a debug header for standard communica-

tions. Contains an ICE header/receiver board and a standard adapter board for 
debug headers with 8-pin connectors, instead of 6-pin connectors.

• Performance Pak – provides high-speed/LVDS communications. Useful for man-
aging high data rates, noisy environments and long distances between the emula-
tor and the target. Also supports SPI trace.
Contains a high-speed driver board, a high-speed receiver board, a high-speed to 
standard converter board, and cables to connect the emulator pod to a target 
board.

• Transition socket – connects the debug header to the target.
• MPLAB REAL ICE Isolator unit – optically isolates the emulator from the target. It 

is useful for high-power applications.

Emulator Pod

SIDE VIEW

Target Board

To PC
Processor Extension Pak

Transition
Socket

Adapter

Header

Standard
Communications
DS50002085B-page 16  2013-2014 Microchip Technology Inc.
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Chapter 2.  Device and Feature Support
Information on feature support by device and tool has moved to the Development Tool 
Selector (DTS) on the Development Tools section of the Microchip web site:
http://www.microchip.com/dts
On the DTS web page, select a device from the list on the left or search for a device. 
Once your device has been selected, click on the “Emulators and Debuggers” tab for a 
list of supported features by tool (and header).
Caveat
For devices and tools that support Date Capture, Runtime Watches, and Native Trace 
(at speeds higher than 15 MIPS), the Performance Pak may be needed.

FIGURE 2-1: DEVELOPMENT TOOLS SELECTOR (DTS) WEB PAGE
 2013-2014 Microchip Technology Inc. DS50002085B-page 17
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Chapter 3.  Operation
3.1 INTRODUCTION
A simplified description of how the MPLAB REAL ICE in-circuit emulator system works 
is provided here. It is intended to provide enough information so that a target board can 
be designed that is compatible with the emulator for both emulation and programming 
operations. The basic theory of in-circuit emulation and programming is described so 
that problems, if encountered, are quickly resolved.
• Tools Comparison
• Operational Overview
• Emulator Communications with the PC and Target
• Target Communication Connections
• Trace Connections
• Debugging with the Emulator
• Requirements For Debugging
• Programming with the Emulator
• Resources Used by the Emulator
 2013-2014 Microchip Technology Inc. DS50002085B-page 19
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3.2 TOOLS COMPARISON
The MPLAB REAL ICE in-circuit emulator system differs physically and operationally 
from the other Microchip debug tools shown below. Specific features may vary by 
device (see the online help file for “Device and Feature Support”.)
TABLE 3-1: DEBUG TOOLS COMPARISON

Features MPLAB® REAL ICE™ 
In-Circuit Emulator

MPLAB ICD 3 
In-Circuit Debugger

PICkit™ 3 
In-Circuit Debugger

USB Speed High and Full High and Full Full Only

USB Driver Microchip Microchip HID

USB Powered

Power to Target

Programmable Vpp and 
Vdd

Vdd Drain from Target < 1 mA < 1 mA 20 mA

Max current to Target None(1) 100 mA 30 mA

Overvoltage/Overcur-
rent Protection

(Hardware) (Hardware) (Software)

HW Breakpoints Complex Complex Simple

Stopwatch

SW Breakpoints

Non-Volatile Program 
Image

(512K bytes)

Serialized USB

Trace

Data Capture

Logic Probe Triggers

High Speed/LVDS 
Connection

Production Programmer

Note 1: Target can be powered if Power Monitor accessory used.

(1)
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Operation
3.3 OPERATIONAL OVERVIEW
The emulator is connected to the PC via a USB port for communication and emulator 
power (but not target power). 
The emulator is connected to the target application for communication and data 
collection, such as trace. 
Below is a summary of possible connection configurations.
TABLE 3-2: CONNECTIONS FOR EMULATING 8-BIT AND 16-BIT DEVICES

Connection Debug Support (1,2) Trace Support (1,3) Support Speed

Standard 
Communications

Data Capture,
Runtime Watch

Native Trace 15 MIPS or less

High-Speed 
Communications

Data Capture,
Runtime Watch

Native Trace,
SPI Trace

Greater than 15 MIPS

Logic Port Probes (4) N/A I/O Port Trace Device Dependent

Note 1: Support is device dependent. See online help.
 2: For details, see Section 6.2 “Data Capture and Runtime Watches”.
 3: For details, see.Section 5.5.3 “Types of Trace”
 4: For details, see Section 3.6.3 “I/O Port Trace Connections”.

TABLE 3-3: CONNECTIONS FOR EMULATING 32-BIT DEVICES
Connection Debug Support (1,2) Trace Support (1,3) Support Speed

Standard Communications or 
High-Speed Communications

Data Capture,
Runtime Watch

N/A Device Dependent

MPLAB REAL ICE Trace 
Interface Kit (Logic Port)

N/A PIC32 Instruction 
Trace

Device Dependent

Note 1: Support is device dependent. See online help.
 2: For details, see Section 7.2 “Data Capture and Runtime Watches” and 

Section 7.6 “Application In/Out”.
 3: For details, see Section 7.3 “PIC32 Instruction Trace”.
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3.4 EMULATOR COMMUNICATIONS WITH THE PC AND TARGET
The MPLAB REAL ICE in-circuit emulator system consists of these items:
1. Emulator pod with indicator lights, push buttons and a logic probe connector
2. USB cable to connect a PC to the emulator pod and power the pod
3. Driver board and modular cable(s) to connect the emulator pod to a header or 

target board

FIGURE 3-1: BASIC EMULATOR POD

The emulator communicates with the PC and is powered through the USB cable.

The emulator communicates with the target via configurations in the following sections. 

STATUS

ACTIVE

M

In-Circuit Emulator

FUNCTION RESET

Emulator Pod

Indicator
Lights

USB/Power

Push Buttons

Logic Probes
Connector

Driver Board

(Top)

Slot
Emulator Pod

(Side)

CAUTION

Communication Failure.
Do not connect the hardware before installing the software and 
USB drivers.

CAUTION

Emulator or Target Damage.
Do not change hardware connections while the pod or target is 
powered.

DANGER
Potential Electrical Hazard.
If your application uses AC line or high voltage power not 
referenced to ground, you should use an isolation circuit. 
See Chapter 18. “MPLAB REAL ICE Isolator Unit”.

STATUS

ACTIVE

M

In-Circuit Emulator

FUNCTION RESET
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Operation
3.4.1 Standard Communication
The emulator system can be configured to use the standard connection for communi-
cating debug and programming instructions to the target. This 6-pin connection is the 
same one used by other Microchip in-circuit debuggers.
The standard driver board is plugged into the emulator pod to configure the system for 
communication with the target. The modular cable can be either (1) inserted into a 
matching socket at the target, where the target device is on the target board, as shown 
in Figure 3-2, or (2) inserted into a standard adapter/debug header combo – available 
as an Extension Pak – which is then plugged into the target board, as shown in 
Figure 3-3.
A debug header is a small circuit board with an -ME2/-ICE/-ICD device mounted onto 
it. These devices provide debug functionality for production devices that (1) do not have 
on-board debug circuitry or (2) cannot afford to lose I/O pins for debugging. For more 
on debug headers, see the Processor Extension Pak and Debug Header Specification 
(in “Recommended Reading”).

To see the debug features of a device versus those of a debug header, see the 
Development Tools Selector on the Development Tools home page on the Microchip 
website (http://www.microchip.com/dts).
For more on the hardware, see Section 13.5 “Standard Communication Hardware”.

FIGURE 3-2: STANDARD CONNECTION – DEVICE WITH ON-BOARD ICE 
CIRCUITRY

Note: Older debug headers used a 6-pin (RJ-11) connector instead of an 8-pin 
connector, so these headers may be connected directly to the emulator.

Emulator Pod

Target Board

Target Device
ACTIVE

STATUS

RESETFUNCTION

Standard
Driver Board

or PIM

Modular
Cable
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FIGURE 3-3: STANDARD CONNECTION – ICE DEVICE

3.4.2 High-Speed/LVDS Communication (Performance Pak)
The emulator system can be configured to use the high-speed/LVDS connection for 
communicating debug and programming instructions to the target. Compared to 
standard communication, this form of communication provides the following features.
• Noise cancellation from the low-voltage differential signal (LVDS) technology, 

which allows:
- Communication speeds greater than 15 MIPS for data capture, runtime 

watches, and Native trace
- Longer distances between the emulator and the target
- Operation in noisy environments

• Two additional pins used for SPI trace
The high-speed driver board (from the Performance Pak) is plugged into the emulator 
pod to configure the system for this type of communication with the target. The modular 
cables can be inserted into matching connectors at the high-speed receiver board. The 
high-speed receiver board is attached via an 8-pin connector into either (1) the target 
board, with an on-board target device as shown in Figure 3-4, or (2) the debug header 
(from the Extension Pak), which is then plugged into the target board (Figure 3-5).
If your application is high-voltage, you will also need to replace the high-speed receiver 
board with an AC isolator unit to isolate the target. See Chapter 18. “MPLAB REAL 
ICE Isolator Unit”.
For more on the hardware, see Chapter 14. “High-Speed/LVDS Communication 
Hardware”.

Emulator Pod
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Transition Socket

ACTIVE

STATUS

RESETFUNCTION

Device-ICE

Extension Pak

Standard
Adapter Header

Standard
Driver Board

Modular
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FIGURE 3-4: HIGH-SPEED/LVDS CONNECTION – DEVICE WITH 
ON-BOARD ICE CIRCUITRY

FIGURE 3-5: HIGH-SPEED/LVDS CONNECTION – ICE DEVICE
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3.5 TARGET COMMUNICATION CONNECTIONS
There are two driver boards available that closely match most application 
requirements. 
• The standard driver board can be used to connect to the myriad of demo boards 

and applications that contain the RJ-11 connector. 
• The high-speed driver/receiver board combination can be used for high-speed 

communications, for additional trace features, for large (over a distance of several 
feet) emulator-to-target distances, and for noisy environments.

3.5.1 Standard Connector
To use the standard driver board, the MPLAB REAL ICE in-circuit emulator is con-
nected to the target device with the modular interface (six-conductor) cable. The pin 
numbering for the connector is shown from the perspective of the bottom of the target 
PC board in Figure 3-6. 

FIGURE 3-6: STANDARD CONNECTION AT TARGET

3.5.2 High-Speed/LVDS Connector
To use the high-speed driver/receiver board combination, the MPLAB REAL ICE 
in-circuit emulator is connected to the target device with an 8-pin interface. The pin 
numbering for the connector is shown from the perspective of the top of the target PC 
board in Figure 3-7.

FIGURE 3-7: HIGH-SPEED CONNECTION AT TARGET

Note: Cable connections at the emulator and the target are mirror images of each 
other; i.e., pin 1 on one end of the cable is connected to pin 6 on the other 
end of the cable. See Section 13.5.2.1 “Modular Cable Specification”.

1
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5

6

Bottom of
Target Board

VPP/MCLR VSS

PGC
VDD

PGD
No Connection

Note: Connections from the emulator to the target are shown in 
Chapter 14. “High-Speed/LVDS Communication Hardware”.

1
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4
5
6
7
8

J1

Top of Target Board

VPP/MCLR

VSS

PGC

VDD

PGD

DAT*
CLK*

Used for optional SPI trace capability. 
See Section 3.6.2 “SPI Trace Connections 
(High-Speed/LVDS Connection)”.

*

No Connection
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3.5.3 Target Connection Circuitry
Figure 3-8 shows the interconnections of the MPLAB REAL ICE in-circuit emulator to 
the connector on the target board. The diagram also shows the wiring from the connec-
tor to a device on the target PC board. A pull-up resistor (minimum 49 k) should be 
connected from the VPP/MCLR line to VDD so that the line may be strobed low to reset 
the device.

FIGURE 3-8: STANDARD CONNECTION TO TARGET CIRCUITRY

In the following descriptions, only three lines are active and relevant to core emulator 
operation: pins 1 (VPP/MCLR), 5 (PGC) and 4 (PGD). Pins 2 (VDD) and 3 (VSS) are 
shown on the above diagram for completeness, but are only sensed, not provided or 
controlled, by the emulator.
Be aware that the target VDD is sensed by the emulator to allow level translation for tar-
get low-voltage operation and to detect a device. If the emulator does not sense voltage 
on its VDD line (pin 2 of the interface connector), it will not connect with the device.
Not all devices have the AVDD and AVSS lines, but if they are present on the target 
device, all must be connected to the appropriate levels in order for the emulator to oper-
ate. This also applies to voltage regulator pins (e.g., ENVREG/DISVREG on PIC24FJ 
MCUs).
In general, it is recommended per device data sheet that all VDD/AVDD and VSS/AVSS 
lines be connected to the appropriate levels. For devices with a VCAP pin (e.g., 
PIC18FXXJ devices), the appropriately-valued capacitor should be placed as close to 
the VCAP pin as possible.

VDD

VPP/MCLR
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VSS AVDD**

AVSS**

2

1
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Application
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Emulator Pod

XTAL*
(Minimum)

* Target device must be running with an oscillator for the emulator to function 
as a debugger.

** If the device has AVDD and AVSS lines, they must be connected for 
the emulator to operate.

Note: The interconnection is very simple. Any problems experienced are often 
caused by other connections or components on these critical lines that 
interfere with the operation of the MPLAB REAL ICE in-circuit emulator 
system, as discussed in the next section.
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3.5.4 Circuits That Will Prevent the Emulator From Functioning
Figure 3-9 shows the active emulator lines with some example components that will 
prevent the MPLAB REAL ICE in-circuit emulator system from functioning.

FIGURE 3-9: IMPROPER CIRCUIT COMPONENTS

Vpp/MCLR pin: do not use capacitors on MCLR – they will prevent fast transitions of 
VPP. A simple pull-up resistor is generally sufficient.

PGC/PGD pins: no components should be connected. Specifically, do not use these 
components on the programming pins:
• Do not use pull-ups or pull-downs on PGC/PGD – they will affect the voltage 

levels, since these lines already have 4.7 k pull-down resistors in the emulator.
• Do not use capacitors on PGC/PGD – they will prevent fast transitions on data 

and clock lines during programming and debug communications, and may cause 
debugging or programming failures

• Do not use diodes on PGC/PGD – they will prevent bidirectional communication 
between the emulator and the target device.

Additional design information is available in the “Development Tools Design Advisory” 
(DS51764).
For other operational issues, see these locations in this document:
• Chapter 10. “Messages”
• Chapter 9. “Frequently Asked Questions (FAQ)”
• Section 10.3.6 “Debug Failure Actions” (Top Reasons Why You Can’t Debug)
• Section 13.6 “Loop-Back Test Board”
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3.6 TRACE CONNECTIONS
Depending on your selected device, one or more trace capabilities may be available 
when the emulator is selected as the debug tool.

3.6.1 Native Trace Connections
No additional connections are necessary to use Native trace. The communications 
connection will carry the trace information using the PGD/PGC/EMUC/EMUD pins. 
However, the selected device must have this feature. If it does not, one of the other 
trace methods may be used.
For more on this type of trace, see Section 5.5.3.1 “Native Trace”.

3.6.2 SPI Trace Connections (High-Speed/LVDS Connection)
Serial trace is an optional trace that is available through using the device SPI and pins 
7 (DAT) and 8 (CLK). The device is connected to the target using high-speed/LVDS 
communication hardware (Performance Pak) which provides the extra lines for clock 
and data. The device does not have to be operating at high speeds to use this feature.
Figure 3-10 shows the proper connections. As with pins 4 (PGD) and 5 (PGC), do not 
use pull-up or pull-down resistors, capacitors or diodes (Section 3.5.4 “Circuits That 
Will Prevent the Emulator From Functioning”).

FIGURE 3-10: SERIAL TRACE CONNECTIONS

The DAT and CLK lines are intended for use with devices that do not have built-in 
debug logic that allows tracing (Native trace) to use the PGD/PGC/EMUC/EMUD pins. 
The DAT line connects to either the target device SPI port SDO1 or SDO2. The CLK 
line connects to SCK1 or SCK2.
When you dedicate these pins to tracing, then any multiplexed function on these pins 
cannot be used by the application.
For more on this type of trace, see Section 5.5.3.2 “SPI Trace”.
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3.6.3 I/O Port Trace Connections
Parallel trace is possible using a device 8-pin I/O port and the emulator logic probes. 
This provides greater trace speed and data quantity, but limits emulator-to-target dis-
tance by the length of the logic probes. Figure 3-11 shows these additional 
connections.

FIGURE 3-11: PARALLEL TRACE CONNECTIONS

For this trace configuration, seven (7) lines of data and one (1) line for clock are trans-
mitted. PORTx must be a port with 8 pins that has all 8 pins available for trace. The port 
does not have to be one physical port but can be made up of pins from more than one 
port The port pins must not be multiplexed with the currently-used PGC and PGD pins.
For allowable PORTx configurations:
1. Right click on your project in the Projects window and select “Properties”.
2. In the Project Properties window, click on the “REAL ICE” category
3. Select the “Trace and Profiling” option category from the drop down list.
4. Under “Data Collection Selection”, select the trace that is supported for your 

device, e.g., “User Instrumented Trace”.
5. Under “Communications Medium”, select “I/O Port”.
6. Under “I/O Port Selection”, select your port configuration from the list.
A basic configuration is shown in the following table.
TABLE 3-4: I/O PORT TRACE CONNECTION EXAMPLE

PORTx pin Logic Probe pin(1) Content

0 EXT0 Data

1 EXT1 Data

2 EXT2 Data

3 EXT3 Data

4 EXT4 Data

5 EXT5 Data

6 EXT6 Data

7 EXT7(2) Clock

Note 1: For pin descriptions, see Section 13.4.4 “Logic Probe/External Trigger 
Interface”.

 2: Use a 10K pull-down resistor for noise reduction.
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As in Section 3.5.4 “Circuits That Will Prevent the Emulator From Functioning”, 
do not use pull-up or pull-down resistors, capacitors or diodes on port pins, except as 
specified.
For more on this type of trace, see Section 5.5.3.3 “I/O Port Trace”.

3.6.4 PIC32 Instruction Trace Connections
PIC32 Instruction Trace is only available for PIC32 MCU devices. Also, only some 
PIC32 MCU devices have the trace feature. Consult your device data sheet for details.
To use this trace, you will need the following hardware:
• PIC32 Plug-In Module (PIM) that contains a device that supports trace and has a 

trace port
• PIC32 Trace Interface Kit that contains a 12-inch trace cable and a trace adapter 

board
If you do not have a trace cable, you can use the logic probes. Connect them as 
indicated below.

To use the PIC32 Instruction Trace feature, see Section 7.3 “PIC32 Instruction 
Trace”.

FIGURE 3-12: PIC32 TRACE CONNECTION WITH PIM

TABLE 3-5: LOGIC PROBE CONNECTIONS
Logic Probe Port Pins(1) PIM Trace Pins(2)

No. Name No. Name

4 TCLK 1 TRCLK

12 EXT0 (TRIG1) 3 TRD0

11 EXT1 (TRIG2) 5 TRD1

10 EXT2 (TRIG3) 7 TRD2

9 EXT3 (TRIG4) 9 TRD3

Note 1: For more information, see Section 13.4.4 “Logic Probe/External Trigger 
Interface”.

 2: For more information, see Section 7.3.4 “Trace Hardware Specifications”.
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3.7 DEBUGGING WITH THE EMULATOR
There are two steps to using the MPLAB REAL ICE in-circuit emulator system as a 
debugger. 
1. The first requires that an application be programmed into the target device. 
2. The second uses the internal in-circuit debug hardware of the target Flash device 

to run and test the application program. 
Those two steps are directly related to the following MPLAB IDE operations:
• Programming the code into the target and activating special debug functions (see 

the next section for details).
• Debugging the code using features such as breakpoints.
If the target device cannot be programmed correctly, the MPLAB REAL ICE in-circuit 
emulator will not be able to debug.
Figure 3-13 shows the basic interconnections required for programming and debug-
ging. Note that this is the same as Figure 3-8, but for the sake of clarity, the VDD and 
VSS lines from the emulator are not shown.

FIGURE 3-13: PROPER CONNECTIONS FOR PROGRAMMING 

A simplified diagram of some of the internal interface circuitry of the MPLAB REAL ICE 
in-circuit emulator pod is shown. For programming, no clock is needed on the target 
device, but power must be supplied. When programming, the emulator puts program-
ming levels on VPP, sends clock pulses on PGC and serial data via PGD. To verify that 
the part has been programmed correctly, clocks are sent to PGC and data is read back 
from PGD. This conforms to the ICSP protocol of the device under development. See 
the device programming specification for details. 
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3.8 REQUIREMENTS FOR DEBUGGING
To debug (set breakpoints, see registers, etc.) with the MPLAB REAL ICE in-circuit 
emulator system, there are critical elements that must be working correctly:
• The emulator must be connected to a PC. It must be powered by the PC via the 

USB cable, and it must be communicating with MPLAB IDE software via the USB 
cable. See Chapter 5. “Common Debug Functions” for details.

• The emulator must be connected (as shown) to the VPP, PGC and PGD pins of 
the target device with the modular interface cable (or equivalent). VSS and VDD 
are also required to be connected between the emulator and target device.

• The target device must have power and a functional, running oscillator – either 
internal or external. If the target device will not run (for whatever reason), the 
MPLAB REAL ICE in-circuit emulator cannot debug.

• The target device must have its Configuration words programmed correctly:
- The oscillator Configuration bits should correspond to RC, XT, etc., depending 

on the target design.
- On some devices, the Watchdog Timer is enabled by default and needs to be 

disabled.
- The target device must not have code protection enabled.
- The target device must not have table read protection enabled.
- For some devices with more than one PGC/PGD pair, the correct pair needs 

to be configured. This is only needed for debugging since programming will 
work over any PGC/PGD pair.

3.8.1 Sequence of Operations Leading to Debugging
Given that the Requirements For Debugging (from the section above) are met, the 
following actions can be performed when the MPLAB REAL ICE in-circuit emulator is 
set as the current tool (File>Project Properties, “Hardware Tool” category):
• When Debug>Debug Project is selected, the application code is programmed into 

the device’s memory via the ICSP protocol, as described earlier.
• A small “debug executive” program is loaded into high program memory of the tar-

get device. Because the debug executive must reside in program memory, the 
application program must not use this reserved space. Some devices have spe-
cial memory areas dedicated to the debug executive. Check your device data 
sheet for details.

• Special “in-circuit debug” registers in the target device are enabled by MPLAB 
IDE. These allow the debug executive to be activated by the emulator. For more 
on device reserved resources, see the online help file.

• The target device is run in Debug mode.
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3.8.2 Debugging Details
Figure 3-14 illustrates the MPLAB REAL ICE in-circuit emulator system when it is ready 
for debugging.

FIGURE 3-14: MPLAB® REAL ICE™ IN-CIRCUIT EMULATOR

Typically, in order to find out if an application program will run correctly, a breakpoint is 
set early in the program code. When a breakpoint is set from the user interface of 
MPLAB IDE, the address of the breakpoint is stored in the special internal debug reg-
isters of the target device. Commands on PGC and PGD communicate directly to these 
registers to set the breakpoint address.
Next, the Debug>Debug Project function is usually selected in MPLAB IDE. The emu-
lator then tells the debug executive to run. The target starts from the Reset vector and 
executes until the Program Counter reaches the breakpoint address that was stored 
previously in the internal debug registers.
After the instruction at the breakpoint address is executed, the in-circuit debug mech-
anism of the target device “fires” and transfers control to the debug executive (much 
like an interrupt) and the user’s application is effectively halted. The emulator commu-
nicates with the debug executive via PGC and PGD, gets the breakpoint status 
information and sends it back to MPLAB IDE. MPLAB IDE then sends a series of que-
ries to the emulator to get information about the target device, such as file register con-
tents and the state of the CPU. These queries are ultimately performed by the debug 
executive.
The debug executive runs just like an application in program memory. It uses some 
locations on the stack for its temporary variables. If the device does not run, for 
whatever reason, such as no oscillator, a faulty power supply connection, shorts on the 
target board, etc., then the debug executive cannot communicate to the MPLAB REAL 
ICE in-circuit emulator and MPLAB IDE will issue an error message.
Another way to stop execution is to select Debug>Pause. This toggles the PGC and 
PGD lines so that the in-circuit debug mechanism of the target device switches execu-
tion from the user’s code in program memory to the debug executive. Again, the target 
application program is effectively halted, and MPLAB IDE uses the emulator 
communications with the debug executive to interrogate the state of the target device.
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3.9 PROGRAMMING WITH THE EMULATOR
Use the MPLAB REAL ICE in-circuit emulator as a programmer to program a produc-
tion device, i.e., a device that is not on a debug header. Set the MPLAB REAL ICE 
in-circuit emulator as the current tool (File>Project Properties, Hardware Tool) to 
perform these actions:
• When Run>Run Project is selected, the application code is programmed into the 

device’s memory via the ICSP protocol as described above. No target oscillator 
clock is required while programming, and all modes of the processor can be pro-
grammed, including code protect, Watchdog Timer enabled and table read pro-
tect.

• A small “program executive” program may be loaded into the high area of 
program memory for some target device. This increases programming speeds for 
devices with large memories.

• Special “in-circuit debug” registers in the target device are disabled by MPLAB 
IDE, along with all debug features. This means that a breakpoint cannot be set, 
and register contents cannot be seen or altered.

• The target device is run in release mode. As a programmer, the emulator can only 
toggle the MCLR line to reset and start the target.

3.10 RESOURCES USED BY THE EMULATOR
For a complete list of resources used by the emulator for your device, please see the 
online help file in MPLAB IDE for the MPLAB REAL ICE in-circuit emulator.
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Chapter 4.  Working with the Emulator
4.1 INTRODUCTION
How to get started using the MPLAB REAL ICE in-circuit emulator is discussed.
• Installation and Setup
• Firmware Upgrades
• Emulator Functions
• Quick Debug/Program Reference
• Debugger/Programmer Limitations

4.2 INSTALLATION AND SETUP
Refer to the Help file “Getting Started with MPLAB X IDE” for details on installing the 
IDE and setting up the emulator to work with it.
In summary:
1. Install MPLAB X IDE.
2. Install the USB drivers as specified.
3. Connect to the PC. For information on target and trace connections, see 

Chapter 3. “Operation”.

4. Install the language toolsuite/compiler you want to use for development.
5. Launch MPLAB X IDE.
6. Use the New Project wizard (File>New Project) to add your “Real ICE” emulator 

to your project.
7. Use the project Properties dialog (File>Project Properties) to set up emulator 

options.
8. Run the project (build and run) from Run>Run Project.
Items of note are:
1. Specific instructions apply for installing USB drivers on a Windows® system. See 

MPLAB X IDE documentation for details.
2. Each emulator contains a unique identifier which, when first installed, will be 

recognized by the OS, regardless of which computer USB port is used.
3. MPLAB X IDE operation connects to the hardware tool at runtime (Run or Debug 

Run). To always be connected to the hardware tool (like MPLAB IDE v8), click in 
the Tools>Options, Embedded button, Generic Settings tab, “Keep hardware 
tool connected” checkbox.

4. Configuration bits must now be set in code. You can set up Configuration bits in 
the Configuration window (Window>PIC Memory Views>Configuration Bits) and 
then click “Generate Code”.

Note: The emulator CANNOT power a target board.
However, you can use the Power Monitor accessory with the emulator 
to power your target. See Chapter 20. “MPLAB REAL ICE Power 
Monitor”.
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4.3 FIRMWARE UPGRADES
IN GENERAL, YOU DO NOT NEED TO PERFORM MANUAL FIRMWARE UPDATES
When you install the latest version of MPLAB X IDE, the latest version of the MPLAB 
REAL ICE in-circuit emulator firmware (operating system) will also be installed on your 
system. The next time you use the emulator, MPLAB X IDE will automatically upgrade 
the firmware on the emulator. You can see the progress in the Output window.
If, however, you install a PREVIOUS version of MPLAB X IDE on your system, the emu-
lator will continue to use the latest version of firmware. In this case, you will have to 
manually install the firmware that comes with the version you wish to use.

4.3.1 Firmware File Location
Firmware files are signified by the .jam extension (for the initials of the developers). 
They are stored in a Java archive (JAR) file.
The default location of the firmware is:
<install path>MPLABX/mplab_ide/mplablibs/modules/ext/REALICE.jar

4.3.2 Manual Firmware Installation
For an active project that uses the emulator:
1. Select File>Project Properties to open the Properties window.
2. Click on the “Real ICE” category and select “Firmware” from the drop-down 

Option Categories.
3. Uncheck “Use Latest Firmware”.
4. Click in the “Firmware File” field that says, “Press to browse for a specific 

firmware file”. A long button will appear. Click it.
5. In the dialog under “Directories”, browse to the location of the file containing the 

firmware file you want (REALICE.jar). Select this file.
6. In the dialog under “Firmware Files”, select the firmware file (.jam) and click OK.
7. In the Project Properties window, click Reset.

4.3.3 Communication Interruption when Installing Firmware
If the emulator becomes disconnected from the PC when firmware is being installed, 
reconnect the emulator. It will begin to erase what had been written so it can restart. 
This erasing will take about 75 seconds (1:15 min.). Please be patient. 
You will see:
• the orange busy light turn on for approximately 25 seconds
• the light turn red for another 25 seconds
• the light turn orange again for another 25 seconds, or so
When it turns back to red again, MPLAB X IDE will recognize the device and start the 
recovery process, i.e., begin the firmware download.
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4.4 EMULATOR FUNCTIONS
Information about using those emulator functions that are common to all devices is 
provided in Chapter 5. “Common Debug Functions”.
Information about using emulator functions that are specific to particular device families 
is provided in Chapter 6. “Specific Debug Functions: 8- and 16-Bit Devices” and 
Chapter 7. “Specific Debug Functions: 32-Bit Devices”.

4.5 QUICK DEBUG/PROGRAM REFERENCE
The following table is a quick reference for using the MPLAB REAL ICE in-circuit emu-
lator as a debug or as a program tool. See previous chapters for information about 
proper emulator setup and configuration.

4.6 DEBUGGER/PROGRAMMER LIMITATIONS
For a complete list of emulator limitations for your device, see the online help file in 
MPLAB X IDE for the MPLAB REAL ICE in-circuit emulator.

TABLE 4-1: DEBUG VS. PROGRAM OPERATION
Item Debug Program

Needed Hardware A PC and target application (Microchip demo board or your own design.)

Emulator pod, USB cable, communication driver board(s) and cable(s).

Device with on-board debug circuitry or debug 
header with special -ME2/-ICE/-ICD device.

Device (with or without on-board debug cir-
cuitry.)

MPLAB X IDE 
selection

Project Properties, REAL ICE as Hardware Tool

Debug>Debug Run Program Target Project toolbar button

Program operation Programs application code into the device. 
Depending on the selections on the Project 
Properties dialog, this can be any range of pro-
gram memory.
In addition, other debug resources are reserved. 
On the MPLAB X IDE Start Page, click “Release 
Notes and Support Documentation” to find the 
reserved resources for the emulator.

Programs application code into the device. 
Depending on the selections on the Project 
Properties dialog, this can be any range of 
program memory.

Debug features 
available

All debug features available for the target device 
- breakpoints, trace, etc.

N/A.

Command-line 
operation

N/A Use REALICECMD, found by default in: 
C:\Program Files (x86)\Microchip 
\MPLABX\mplab_ipe

Serial Quick-Time 
Programming 
(SQTP)

N/A Right click on a debugged project and select 
“Export Hex”. Import the hex file into MPLAB 
IPE and use MPLAB PM3 to SQTP the 
device.
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Chapter 5.  Common Debug Functions
5.1 INTRODUCTION
Debug functions of the MPLAB REAL ICE in-circuit emulator that are common across 
all devices are discussed below. 
• Starting and Stopping Emulation
• Viewing Processor Memory and Files
• Breakpoints and Stopwatch
• Instrumented Trace
• External Triggers (Logic Probes)
(Debug functions that are only available on some device types are discussed later, in 
Chapter 6. "Specific Debug Functions: 8- and 16-Bit Devices” and in Chapter 7. 
"Specific Debug Functions: 32-Bit Devices”.)

5.2 STARTING AND STOPPING EMULATION 
To debug an application in MPLAB X IDE, you must create a project containing your 
source code so that the code may be built, programmed into your device, and executed 
as specified below:
• To run your code, select either Debug>Debug Project or Debug Project from the 

Run toolbar.
• To halt your code, select either Debug>Pause or Pause from the Debug toolbar.
• To run your code again, select either Debug>Continue or Continue from the 

Debug toolbar.
• To step through your code, select either Debug>Step Into or Step Into from the 

Debug toolbar. Be careful not to step into a Sleep instruction or you will have to 
perform a processor Reset to resume emulation.

• To step over a line of code, select either Debug>Step Over or Step Over from the 
Debug toolbar.

• To end code execution, select either Debug>Finish Debugger Session or Finish 
Debugger Session from the Debug toolbar.

• To perform a processor Reset on your code, select either Debug>Reset or Reset 
from the Debug toolbar. Additional Resets, such as POR/BOR, MCLR and 
System, may be available, depending on device.
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5.3 VIEWING PROCESSOR MEMORY AND FILES 
MPLAB X IDE provides several windows for viewing debug and various processor 
memory information. These are selectable from the Window menu. See MPLAB X IDE 
online help for assistance on using these windows.
• Window>PIC Memory Views - view the different types of device memory

Depending on the selected device, memory types include Program Memory, SFRs, 
Configuration Memory, etc.

• Window>Debugging - view debug information
Select from variables, watches, call stack, breakpoints, stopwatch, and trace. 
(Trace is discussed more thoroughly in upcoming chapters.)

To view your source code, find the source-code file you wish to view in the Projects win-
dow and double click it to open it in a Files window. Code in this window is color-coded 
according to the processor and build tool selected. To change the style of color-coding, 
select Tools>Options, Fonts & Colors, Syntax tab.
For more on the Editor, see MPLAB X IDE online help, Editor section.

5.4 BREAKPOINTS AND STOPWATCH
Use breakpoints to halt code execution at specified lines in your code. Use the 
stopwatch with breakpoints to time code execution.
• Breakpoint Resources
• Hardware or Software Breakpoint Selection
• Breakpoint and Stopwatch Usage

5.4.1 Breakpoint Resources
For 16-bit devices, breakpoints, data captures, and runtime watches use the same 
resources. So, the available number of breakpoints is actually the available number of 
combined breakpoints/triggers.
For 32-bit devices, breakpoints use different resources than data captures and runtime 
watches. So, the available number of breakpoints is independent of the available 
number of triggers.
The number of hardware and software breakpoints available and/or used is displayed 
in the Dashboard window (Window>Dashboard). See the MPLAB IDE documentation 
for more on this feature. Not all devices have software breakpoints.
For limitations on breakpoint operation, including the general number of hardware 
breakpoints per device and hardware breakpoint skidding amounts, see “Limitations” 
in the online help file.
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5.4.2 Hardware or Software Breakpoint Selection
To select hardware or software breakpoints:
1. Select your project in the Projects window. Then, select either File>Project 

Properties or right click and select “Properties”.
2. In the Project Properties dialog, select “REAL ICE” under “Categories”.
3. Under “Option Categories” select “Debug Options”.
4. Check “Use software breakpoints” to use software breakpoints. Uncheck to use 

hardware breakpoints.

To help you decide which type of breakpoints to use (hardware or software) the follow-
ing table compares the features of each.

TABLE 5-1: HARDWARE VS. SOFTWARE BREAKPOINTS

5.4.3 Breakpoint and Stopwatch Usage
Breakpoints halt execution of code. To determine the time between the breakpoints, 
use the stopwatch.
Refer to the MPLAB X IDE Help for how to set up and use breakpoints and the stop-
watch.

Note: Using software breakpoints for debug impacts device endurance. 
Therefore, it is recommended that devices used in this manner not be 
used as production parts.

Feature Hardware Breakpoints Software Breakpoints

Number of breakpoints Limited Unlimited
Breakpoints written to* Internal debug registers Flash Program Memory
Breakpoints applied to** Program Memory/Data Memory Program Memory only
Time to set breakpoints Minimal Dependent on oscillator 

speed, time to program Flash 
Memory and page size

Breakpoint skidding Most devices. See the online help, 
Limitations section, for details.

No

* Where information about the breakpoint is written in the device.
** What kind of device feature applies to the breakpoint. This is where the breakpoint is set.
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5.5 INSTRUMENTED TRACE
This section discusses the available types of instrumented trace and how to use them.

5.5.1 Requirements for Trace
The following is required to use trace:
Devices that support trace – see the Development Tool Selector (DTS) on the 
Development Tools section of the Microchip web site. 
The following are limitations of trace:
• For 8- and 16-bit devices, in-line assembly code (assembly code within C code) 

cannot be traced.
• For additional limitations, see the Limitations section of MPLAB REAL ICE 

In-Circuit Emulator Help in MPLAB X IDE.

5.5.2 How Trace Works
Trace for the MPLAB REAL ICE in-circuit emulator (Instrumented Trace) is a solution 
for providing basic trace information. Through the use of TRACE() and LOG() macros, 
you can report program locations or variable values to MPLAB IDE while the applica-
tion is running and examine them via the Trace window once the application halts. You 
may type these macro names in manually or right click in the editor and select the 
macro to be inserted from the context menu. To log a variable value, the variable should 
be highlighted before selecting from the context menu.

FIGURE 5-1: EXAMPLE OF INSERTED LOG MACRO

There are three trace methods available at this time (see Section 5.5.3 “Types of 
Trace”). The methods are located on the Project Properties dialog, “REAL ICE” Cate-
gory, “Trace and Profiling” Options Category page. The choices found under “Commu-
nications Medium” include “Native Trace” (utilizes PGC/PGD communication lines), 
“SPI Trace”, and “I/O Port Trace”. Not every method is available on every part; i.e., the 
options are device specific. The Instrumented Trace library supports C and assembly 
projects on PIC18F MCU devices; but, only C projects on 16-bit devices.
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FIGURE 5-2: PROJECT PROPERTIES – NATIVE TRACE SELECTION

The trace and log information transmitted is identical regardless of the trace method 
used. For TRACE(), a single value in the range of 64-127 is sent. A label generated 
using this number is automatically inserted into the code, so MPLAB IDE can identify 
in the trace buffer the location that sent the value. For LOG(), a two-byte header is 
sent, followed by the value of the variable being logged. The first byte indicates the vari-
able type, and is a value between 0 and 63. The second byte indicates the location that 
sent the variable. Here, the location is represented by a value between 0 and 127. (See 
Section 5.5.9 “More on Trace/Log ID Numbers”.)
Interrupts are disabled during every TRACE() and LOG() call. This is to ensure that 
trace or log statements at an interrupt level do not interfere with a trace or log statement 
that may already be in progress at the application level. A similar argument holds for 
protecting statements within a low priority interrupt from being corrupted by those from 
a high priority interrupt.
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5.5.3 Types of Trace
Currently there are three types of trace. All types are language-tool-version dependent, 
and stream data in real time to MPLAB IDE.
The pluses and minuses of using each trace type, as well as the type of communication 
available (standard and/or high-speed), are summarized below.

5.5.3.1 NATIVE TRACE

Native trace can be used with either standard or high-speed communications, with no 
additional connections - the information is conveyed via the PGD/PGC/EMUC/EMUD 
pins. This two-wire interface uses the trace macro format (see Section 5.5.4 “Setting 
Up Trace in MPLAB X IDE”).
Native trace requires that you enter the clock speed (on the Project Properties dialog, 
REAL ICE category, and Clock options category.)
If Native trace is used, then data captures cannot be used as these features use the 
same device resource. Breakpoints are still available; but, be aware that Native trace 
will use one breakpoint for tracing. This will NOT be reflected on the Device Debug 
Resource toolbar.
To use data capture triggers, you must disable Native trace (see Section 5.5.7 
“Disabling Trace”).

5.5.3.2 SPI TRACE

SPI trace can be used only with high-speed communication hardware (LVDS cables). 
Trace clock and data are provided through pins 7 (DAT) and 8 (CLK) on the receiver 
board of the LVDS connection. The device does not have to be operating at high 
speeds to use this feature.
For devices with remappable peripheral pins, be aware that the SPI trace macro does 
not touch any PPS register and does not need to know how the peripheral is mapped 
to a certain pin - it will write to the SPI1 or SPI2 selected in MPLAB IDE.
SPI trace does require that you enter the clock speed (on the Properties dialog, REAL 
ICE category, and the Clock options category.)
For hardware connections, see Section 3.6.2 “SPI Trace Connections 
(High-Speed/LVDS Connection)”.
The SPI interface uses the trace macro format (see Section 5.5.4 “Setting Up Trace 
in MPLAB X IDE”).

Type of 
Trace Speed

Code 
Size 

Impact

Real 
Time 
Op

Pin 
Usage

Device 
Feature 
Needed

Communication

Std HS

Native Trace Fast(1) Large Close None Built-in 
debug

15 MIPS 
or less

Greater than 
15 MIPS

SPI Trace Faster(1) Medium Closer SPI 
pins

SPI No Yes

I/O Port Trace Fastest Small Closest 8-pin 
port

None Yes(2) Yes(2)

Note 1: For Native trace running at speeds higher than 15 MIPS and for SPI Trace capabil-
ity, the Performance Pak may be needed. The actual cutoff speed may vary 
depending on layout, noise, and similar considerations.

 2: Also requires connection from device port to emulator logic probe port.
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5.5.3.3 I/O PORT TRACE

I/O Port trace can be used with either standard or high-speed communications. Trace 
clock and data are provided from a device 8-pin I/O port through the MPLAB REAL ICE 
in-circuit emulator logic probe connector.
The I/O port must have all 8 pins available for trace. The port must not be multiplexed 
with the currently-used PGC and PGD pins. Therefore, review the data sheet of the 
selected device to determine the uninitialized/default port pin states and change them 
as necessary.
For hardware connections, see Section 3.6.3 “I/O Port Trace Connections”.
The port interface uses the trace macro format (see Section 5.5.4 “Setting Up Trace 
in MPLAB X IDE”).

5.5.4 Setting Up Trace in MPLAB X IDE
To set up MPLAB X IDE to use trace for the MPLAB REAL ICE in-circuit emulator:
1. Right click on the project name and select “Properties”. In the Project Properties 

dialog click on “Real ICE” under “Categories”.
2. Under “Option categories”, select “Clock”. For data capture and trace, the 

emulator needs to know the instruction cycle speed.
3. Under “Option categories”, select “Trace and Profiling”.
4. Under “Data Collection Selection”, choose “User Instrumented Trace”.
5. Under “Communications Medium” choose either “Native”, “I/O PORT” or “SPI” 

trace.
6. Set up any other trace-related options. (See Section 12.3.5 “Trace and 

Profiling”.)
7. Click OK.

Next, enter trace macros into your application code.
• To record a PC location, click on or highlight a line of code and then right click to 

select “Insert Language Line Trace” from the pop-up menu, where Language can 
be either C or ASM. This causes the following macro line to be inserted above the 
selected line:
__TRACE(id);

where id is a line trace number auto-generated during the build. For more 
information, see Section 5.5.9 “More on Trace/Log ID Numbers”.

• The recording of a variable value is performed similarly. First, highlight the vari-
able name, or expression. Then, right click to select “Log Selected Language 
Value” from the pop-up menu, where Language can be either C or ASM. This 
causes the following macro line to be inserted above the line containing the 
variable:
__LOG(id,selected variable);
where id is a log number that was auto-generated during build and selected 
variable is the highlighted variable. For more information, see Section 5.5.9 
“More on Trace/Log ID Numbers”.

• To remove a trace point, simply highlight and then delete the Trace/Log macro.

Note: Inserting a macro into code may modify the logic flow of the program. 
Check that braces are present wherever they are necessary.
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5.5.5 Running Trace
1. Debug Run (Debug>Debug Project) your application.
2. Pause the application.
3. View the trace data in the Trace window (Window>Debugging>Trace). For each 

__TRACE macro, the line of code following the macro will appear in the trace win-
dow each time it is passed. For each __LOG macro, the selected variable in the 
line of code following the macro will appear in the trace window each time it is 
passed.

Repeat these steps each time you change a trace point.

5.5.6 Tracing Tips
When using __TRACE and __LOG macros in your code, consider the following:
• Focus on one area of an application and place __TRACE and __LOG macros so 

that they form a “flow” in the Trace window. That way, you can follow the execution 
flow and debug the application based on missing/incorrect trace points or an 
abrupt end to the trace flow. 

• Use __TRACE and __LOG macros with conditional statements in your code to aid 
in debugging. Example: When a variable reaches a certain value, start logging it.

   If(var > 5)
   {
      __LOG(ID, var)
   }

• Leave __TRACE and __LOG macros in your code for future debugging, if this is 
allowable. (For Project Properties dialog, REAL ICE Category, Trace Options Cat-
egory page, select “Disable Trace Macros“.)

5.5.7 Disabling Trace
To temporarily turn off trace data collection:
1. Select File>Project Properties dialog, Categories: REAL ICE, Options 

categories: Trace and Profiling.
2. Check “Disable Trace Macros”.
3. Click OK.
To disable the full trace capability:
1. Remove all trace and log macros from code.
2. Select File>Project Properties dialog, Categories: REAL ICE, Options 

categories: Trace and Profiling.
3. Under “Data Collection Selection”, choose “Off”.
4. Click OK.

Note: To trace multiple lines of code or variables, you must place a macro 
before each line/variable that you wish to trace.
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5.5.8 Resource Usage Examples
The following examples are for illustration only. Your results may vary based upon 
compiler/assembler version, command line options, MPLAB IDE version, size of data 
variable being logged, interrupt state, and device in use. All examples include 
argument setup, function call, and return time in their cycle counts.
The PIC18FXXJ MCU examples are compiled/assembled for non-priority interrupt 
usage (30 instructions). For priority interrupt usage, the value is 57; and for no interrupt 
usage, the value is 15.
The dsPIC33F DSC examples show 9 instructions specified in the 16-bit library size for 
memcpy().

EXAMPLE 5-1: PIC18FXXJ DEVICE RUNNING AT 4MHZ (1 MIPS) WITH 
ASSEMBLY PROJECT

EXAMPLE 5-2: PIC18FXXJ DEVICE RUNNING AT 40MHZ (10 MIPS) WITH C 
PROJECT

EXAMPLE 5-3: dsPIC33F DEVICE RUNNING AT 10 MIPS WITH C PROJECT

EXAMPLE 5-4: dsPIC33F DEVICE RUNNING AT 16 MIPS WITH C PROJECT

EXAMPLE 5-5: dsPIC33F DEVICE RUNNING AT 34 MIPS WITH C PROJECT

Native SPI I/O Port

Library Size (in instructions) 23 + 30 37 + 30 25 + 30

GPRs Used (in bytes) 8 6 6

__TRACE(id) instruction cycles 80 54 42

__LOG(id, BYTE) instruction cycles 168 90 57

Native SPI I/O Port

Library Size (in instructions) 75 + 30 87 + 30 112 + 30

GPRs Used (in bytes) 10 8 8

__TRACE(id) instruction cycles 79 71 55

__LOG(id, INT) instruction cycles 225 169 162

Native SPI I/O Port

Library Size (in instructions) 87 + 9 92 + 9 93 + 9

GPRs Used (in bytes) 18 14 0

__TRACE(id) instruction cycles 80 53 32

__LOG(id, INT) instruction cycles 212 124 106

Native SPI I/O Port

__TRACE(id) instruction cycles 88 53 32

__LOG(id, INT) instruction cycles 227 138 106

Native SPI I/O Port

__TRACE(id) instruction cycles 100 53 32

__LOG(id, INT) instruction cycles 251 152 106
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5.5.9 More on Trace/Log ID Numbers
MPLAB IDE will automatically generate the ID numbers required for a trace or log 
macro. However, to understand the method behind the numbering, read further.
You can have 64 trace points and 64 log points. These limits are determined by port 
trace (8 bits). Bit 7 is used as a clock and Bit 6 is used as a flag which indicates either 
a trace record (1) or a log record (0).
For a trace record, the low order bits represent the trace number (nnnnnn). You could 
say 0-63 are the legal trace numbers and require the trace flag be set, but it was just 
easier to combine the flag with the number and say the valid numbers are 64-127.

For a log record, the low order bits represent the log number (nnnnnnn).

5.5.10 Quick Trace Reference
If you are new to using the MPLAB REAL ICE in-circuit emulator trace feature, it is 
recommended that you read through the entire trace section for a full understanding.
Use this section as a quick reference for trace.
1. Select File>Project Properties dialog, Categories: REAL ICE, Options catego-

ries: Trace. Enable trace, choose the type of trace and set other trace options.
2. Select Window>Debugging>Trace to open the trace window in which to view 

trace data.
3. Right click in your code to enter trace macros (__TRACE, __LOG) as desired.
4. Debug Run your project.

clock 1
bit 7 bit 0

n n n n n n
bit 6

clock 0
bit 7 bit 0

n n n n n n
bit 6
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5.6 EXTERNAL TRIGGERS (LOGIC PROBES)
Use external triggers to set up hardware triggers using the logic probes. All pins, used 
or unused, should be pulled up or be grounded. Floating pins may produce false 
triggers.
External triggers can be used as input to halt program execution when an external 
event occurs. They can also be used as output to control external devices.
To use probe pins as inputs, you must provide the circuitry to drive them (see Table 
13-3: “Logic Probe Electrical Specifications”, for drive levels.)
You will not be able to use external triggers if you are using the logic probe port for 
another debug feature such as:
• I/O Port trace (see Section 5.5.3.3 “I/O Port Trace”.)
• PIC32 Instruction trace (see Section 7.3 “PIC32 Instruction Trace”.)
For more on external trigger hardware, see Section 13.4.4 “Logic Probe/External 
Trigger Interface”.
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Chapter 6.  Specific Debug Functions: 8- and 16-Bit Devices
6.1 INTRODUCTION
The following debug functions or the implementations of the debug functions are spe-
cific to 8- and 16-bit devices. Some debug functions are dependent on other debug 
functions. For information on common (non-device specific) debug functions, see 
Chapter 5. “Common Debug Functions”.
• Data Capture and Runtime Watches
• Instrumented Trace
• Jump Trace
• PC Sampling
• Function Level Profiling
• Application In/Out
• Additional Debug Features

6.2 DATA CAPTURE AND RUNTIME WATCHES
Data capture is an on-board debug feature of the device. When a value in the Capture 
Data Address register matches an SFR register address, a trigger and data capture 
occurs. You cannot access data capture directly; you must select an application that 
uses data capture, such as the DMCI plug-in.
Runtime Watches are selected symbols in a Watches window that change as the pro-
gram runs. You can select a symbol to be runtime in a Watches window. See MPLAB 
X IDE documentation for details.
When watching symbols, an 8-bit PIC can only watch 8-bit variables and a 16-bit PIC 
can only watch 16-bit variable.
Not all 8- and 16-bit devices support data capture and/or runtime watches. A list of 
supported features by device is available in online help or the Development Tools 
Selector (DTS) at http://www.microchip.com/developmenttools/.
For 8- and 16-bit devices, data captures, runtime watches and hardware breakpoints 
use the same registers/resources. For example, if you use a data capture resource for 
a symbol, you will not be able to use a hardware breakpoint or runtime watch resource 
for that symbol.
For data captures and runtime watches at speeds higher than 15 MIPS, the Perfor-
mance Pak may be needed. The actual speed may vary depending on layout, noise, 
and similar considerations.
• Data Capture and DMCI
• Runtime Watches and the Watches Window
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6.2.1 Data Capture and DMCI
Data capture provides streaming data from a device to the following:
• Data Monitoring and Control Interface (DMCI) – Plug-in
To install the DMCI plug-in:
1. Select Tools>Plugins. The Plugins window will open.
2. Click on the Available Plugins tab.
3. Find DMCI and check the checkbox next to it.
4. Click Install and follow the screens.
See also the “Add Plug-in Tools” in the “Additional Tasks” section of the MPLAB X IDE 
help file.
To set up data capture:
1. Build the project (In the Projects window, right click on the project name and 

select “Build”). The project must be built to see the available symbols.
2. Select Window>Debugging>Watches to open the Watches window.
3. Right click in the window and select “New Watch”. Select the symbol or SFR wish 

to watch in the New Watch window. Click OK.
4. Select Tools>Embedded>DMCI>DMCI Window to open the DMCI dialog.
5. Set up the DMCI for this data capture. See the DMCI help file for details 

(Help>Help Contents, “Plug-In Tools” section). 
6. Begin a debug session (Debug>Debug Project). Input data using DMCI controls 

or view data in a DMCI graphical window.

6.2.2 Runtime Watches and the Watches Window
A runtime watch provides updating of a variable in the following windows during 
program execution instead of on halt:
• Watches – Window > Debugging menu
• Memory – Window > PIC Memory Views menu
To set up runtime watches:
1. Build the project (In the Projects window, right click on the project name and 

select “Build”). The project must be built to see the available symbols.
2. Select Window>Debugging>Watches to open the Watches window.
3. Right click in the window and select “New Runtime Watch”. Select the symbol or 

SFR you wish to watch in the New Run Time Watches window. Click OK.
4. Begin a debug session (Debug>Debug Project). Watch variable values change 

in the Watches window.
5. To see the watched variable change in a Memory window, Pause (halt) and open 

a Memory window containing the watched variable. Continue the program and 
watch the values change in this window.

6.3 INSTRUMENTED TRACE
For some 8- and 16-bit devices, instrumented trace is available (see Chapter 2. 
“Device and Feature Support”).
For information on this trace, see Section 5.5 “Instrumented Trace”.
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6.4 JUMP TRACE
Jump trace is a feature on some (EP) devices that records up to the last four instruction 
flow changes in the code, allowing you to navigate back up a call chain. Branch/jump 
addresses are displayed in the Trace window (up to four entries).
This feature is selected in the Project Properties window, Real ICE category, “Trace 
and Profiling” option category, under “Data Collection Selection”.

FIGURE 6-1: JUMP TRACE IN TRACE WINDOW
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6.5 PC SAMPLING
PC sampling is a method of examining C code to determine how much time is spent in 
each function. This information can show you where your program time is being spent 
so you can work to optimize your code.
For PC sampling, a device timer is set up to take samples of program execution and 
display the results in the PC profiling window.
PC profiling is similar to PC sampling. For details see Section 7.5 “PC Profiling”.
Currently, to use PC sampling your project must be set up for:
• a 16-bit device
• the MPLAB XC16 C Compiler version 1.10 or above
To perform sampling:
1. Open the Project properties window (File>Project Properties).
2. Click on “REAL ICE” under “Categories” and select “Trace and Profiling” from the 

“Options categories” drop-down box.
3. Under “Data Collection Selection”, select “PC Sampling”.
4. Set up your data file and timer in this window. For reference, see 

Section 12.3.5 “Trace and Profiling”. Then, click OK.
5. Select Window>Debugging>PC Profiling. This will open the PC Profiling window.
6. Run your code and then halt.
7. View the sampling data in the window. Data is only displayed on halt.
8. Right click in the window to pop up a menu to either clear the data or reload the 

data.

FIGURE 6-2: PC SAMPLING SELECTION AND SETUP
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6.6 FUNCTION LEVEL PROFILING
Function level profiling is a method of examining C code to determine timing informa-
tion (summary on halt or streaming data) about each function. This information can 
show you where your program time is being spent so you can work to optimize your 
code.
Currently, to use function level profiling your project must be set up for:
• a 16-bit device that supports data capture – see Chapter 2. “Device and Feature 

Support”.
• the MPLAB XC16 C Compiler version 1.20 or above
• the Function Level Profiling Plug-in (future feature)
To perform sampling:
1. Open the Project properties window (File>Project Properties).
2. Click on “REAL ICE” under “Categories” and select “Trace and Profiling” from the 

“Options categories” drop-down box.
3. Under “Data Collection Selection”, select “Function Level Profiling”.
4. Set up your data file information in this window. For reference, see 

Section 12.3.5 “Trace and Profiling”. Then, click OK.
Install the Function Level Profiling Plug-in by following the instructions in MPLAB X IDE 
Help, “Additional Tasks”, “Add Plug-In Tools”. The Function profiling window then may 
be accessed under Tools>Embedded>Function Level Profiling.

FIGURE 6-3: FUNCTION PROFILING SELECTION AND SETUP
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6.7 APPLICATION IN/OUT

The Application In/Out window allows you to interact with a running application using 
the Application Input/Output (App I/O) feature supported on some devices. Using this 
feature, data may be sent serially to and from the target application and, during runtime, 
over the same PGC/PGD lines used for debugging. Data written to the APPOUT reg-
ister will be displayed to the window, while user input will be sent to the target 
application and available in the APPIN register.
To use the Application In/Out window:
• To directly write to App I/O, use the device-specific header file when building your 

application (per Example 6-1.)
• In the future, the 16-bit device library will have printf() and scanf() functions 

for use with the Application In/Out feature.

EXAMPLE 6-1: APPLICATION IN/OUT REGISTER USAGE

The following application code reads the application input register and writes out a 
padded value of the input to the application output register.
// include file
#include <p33Exxxx.h>

// set up config bits
_FWDT( FWDTEN_OFF )

// initialize variables
unsigned int val;
int i;
unsigned int oval;

int main(void)
{
   while(1)
   {
    if(APPSbits.APIFUL) // APPI is full?
      {
       val = _APPIN;         // Read User Input
       for(i=0; i<4; i++)
         {
          while(APPSbits.AROFUL); // APPO is full?
          oval =  val&0xFF;
          if(oval < 0x20)
             oval = 0x20;
          oval |= 0x20202000;
          _APPO = oval;               // Send to MPLAB X IDE
          val >>= 8;
         }
      }
   }
}

Note: This window is only available for devices that support the application in/out 
function used with the MPLAB REAL ICE in-circuit emulator or MPLAB ICD 
3 in-circuit debugger. For details, see online help, “Device and Feature 
Support”.
DS50002085B-page 60  2013-2014 Microchip Technology Inc.



Specific Debug Functions: 8- and 16-Bit Devices
To run this application perform the following actions:
1. Create a project using the Project wizard:

a) Select a supported device.
b) Select REAL ICE or ICD 3 as the hardware tool.
c) Use the “MPLAB C Compiler for PIC24 MCUs and dsPIC DSCs” or the 

“MPLAB XC16 C Compiler” as the language toolsuite.
2. Select File>New File to create and name a new C Source File. In the Editor 

window that opens, add the previous code and save.
3. Right click on the project name in the Projects window and select “Properties”. In 

the Project Properties window, click on “pic32-gcc” under “Categories”. Under 
“Option Categories”, select “General” and check the “Enable App IO” checkbox.

4. Build the project (Right click on the project name and select “Build”).
5. Select Window>Debugging>PIC App IO to open the Application In/Out window.
6. Click on the “Properties” button (on the left of the window) to launch the Set App 

IO Properties dialog. Under “Capture” click “On”.

FIGURE 6-4: SET APP I/O PROPERTIES

7. Debug Run or Run the project.
8. Enter a text value in the Input text box. Press Enter.
9. View the output in the Output text box.

FIGURE 6-5: APP IN/OUT WINDOW

Change Input and Output Formats by opening Set App IO Properties dialog and 
running the program again to see what outputs result for different inputs.
For more on options available in this window, see Section 12.4.2 “Application In/Out 
Window and Related Dialogs”.
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6.8 ADDITIONAL DEBUG FEATURES
In addition to the debug features covered previously, 8- and 16-bit devices have the 
other debug features, such as “Freeze on Halt”, which allows you to freeze selected 
peripherals on a halt. For a complete list of debug functions, windows and dialogs, see 
Chapter 12. “Emulator Function Summary”.
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Chapter 7.  Specific Debug Functions: 32-Bit Devices
7.1 INTRODUCTION
The following debug functions or the implementations of the debug functions are 
specific to 32-bit devices:

For information on common (non-device specific) debug functions, see Chapter 5.  
“Common Debug Functions”
• Data Capture and Runtime Watches
• PIC32 Instruction Trace
• Instrumented Trace
• PC Profiling
• Application In/Out
• Additional Debug Features

7.2 DATA CAPTURE AND RUNTIME WATCHES
Data capture is an on-board debug feature of the device. When a value in the Capture 
Data Address register matches an SFR register address, a trigger and data capture 
occurs. You cannot access data capture directly; you must select an application that 
uses data capture, such as the DMCI plug-in.
Runtime Watches are selected symbols in a Watches window that change as the pro-
gram runs. You can select a symbol to be runtime in a Watches window. See MPLAB 
X IDE documentation for details.
Not all 32-bit devices support data capture and/or runtime watches. A list of supported 
features by device is available in online help.
For PIC32 devices, hardware breakpoints do not use data capture or runtime watch 
resources. However data captures and runtime watches do use the same resources. 
Therefore, if you use a data capture resource for a symbol, you will not be able to use 
a runtime watch resource for that symbol, and vice versa.

• Data Capture and DMCI
• Runtime Watches and DMCI
• Runtime Watches and the Watches Window

Note: For PIC32 devices, the JTAG port may need to be disabled to prevent 
conflicts when using trace and other ICE features where pin conflicts can 
result.

Note: The Performance Pak is not required for debugging at maximum speeds as 
the capture clock speed is independent of the target system clock.
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7.2.1 Data Capture and DMCI
Data capture provides streaming data from a device to the following:
• Data Monitoring and Control Interface (DMCI) – Plug-in
To install the DMCI plug-in:
1. Select Tools>Plugins. The Plugins window will open.
2. Click on the Available Plugins tab.
3. Find DMCI and check the checkbox next to it.
4. Click Install and follow the screens.
See also the “Add Plug-in Tools” in the “Additional Tasks” section of the MPLAB X IDE 
help file.
To set up data capture:
1. Build the project (In the Projects window, right click on the project name and 

select “Build”). The project must be built to see the available symbols.
2. Select Window>Debugging>Watches to open the Watches window.
3. Right click in the window and select “New Watch”. Select the symbol or SFR wish 

to watch in the New Watch window. Click OK.
4. Select Tools>Embedded>DMCI>DMCI Window to open the DMCI dialog.
5. Set up the DMCI for this data capture. See the DMCI help file for details 

(Help>Help Contents, “Plug-In Tools” section).
6. Begin a debug session (Debug>Debug Project). Input data using DMCI controls 

or view data in a DMCI graphical window.

7.2.2 Runtime Watches and DMCI
For devices without data capture, the runtime watch can provide data polling to the 
following:
• Data Monitoring and Control Interface (DMCI) – Plug-in
To install the DMCI plug-in:
1. Select Tools>Plugins. The Plugins window will open.
2. Click on the Available Plugins tab.
3. Find DMCI and check the checkbox next to it.
4. Click Install and follow the screens.
See also the “Add Plug-in Tools” in the “Additional Tasks” section of the MPLAB X IDE 
help file.
To set up runtime watches:
1. Build the project (In the Projects window, right click on the project name and 

select “Build”). The project must be built to see the available symbols.
2. Select Window>Debugging>Watches to open the Watches window.
3. Right click in the window and select “New Runtime Watch”. Select the symbol or 

SFR wish to watch in the New Run Time Watches window. Click OK.
4. Select Tools>Embedded>DMCI>DMCI Window to open the DMCI dialog.
5. Set up the DMCI for this runtime watch. See the DMCI help file for details 

(Help>Help Contents, “Plug-In Tools” section).
6. Begin a debug session (Debug>Debug Project). Input data using DMCI controls 

or view data in a DMCI graphical window.
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7.2.3 Runtime Watches and the Watches Window
A runtime watch provides updating of a variable in the following windows during 
program execution instead of on halt:
• Watches – Window > Debugging menu
• Memory – Window > PIC Memory Views menu
To set up runtime watches:
1. Build the project (In the Projects window, right click on the project name and 

select “Build”). The project must be built to see the available symbols.
2. Select Window>Debugging>Watches to open the Watches window.
3. Right click in the window and select “New Runtime Watch”. Select the symbol or 

SFR wish to watch in the New Run Time Watches window. Click OK.
4. Begin a debug session (Debug>Debug Project). Watch variable values change 

in the Watches window.
5. Pause (halt) and open another window (e.g., SFR) containing the watched 

variable. Continue the program again and watch the values change in this 
window.
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7.3 PIC32 INSTRUCTION TRACE
This section will discuss trace for 32-bit devices and how to use it. Not all PIC32 
devices have instruction trace so refer to your device data sheet.
• Requirements for Trace
• How Instruction Trace Works
• Setting Up and Using Trace
• Trace Hardware Specifications

7.3.1 Requirements for Trace
The following is required to use trace for 32-bit (PIC32) devices:
• MPLAB X IDE and a compatible 32-bit toolchain
• PIC32MX Plug-In Module (PIM) containing a device that supports trace and a 

trace port
• MPLAB REAL ICE Trace Interface Kit containing a 12-inch trace cable and a trace 

adapter board

7.3.2 How Instruction Trace Works
PIC32 instruction trace uses a MIPS32 iFlowtrace™ mechanism, which is a 
non-intrusive hardware instruction trace. You can use this trace to capture every 
instruction executed by the device. The trace data is sent from the device using the pins 
TRCLK and TRD3:0 to the emulator. The emulator streams this data to a trace buffer 
on the PC that acts like a rolling FIFO.
The amount of trace data is limited only by the size of the trace buffer. This buffer can 
fill quickly even when set to the maximum size, so it is wise to determine exactly what 
you need to capture.
Enable and set trace options in the Project Properties dialog, Categories: REAL ICE, 
Option categories: Trace and Profiling. Here you may set:
• Data selection – enable/disable trace and select the type of trace.
• Data file path and name – the location of trace file
• Data file maximum size – the size of trace file
• Data Buffer maximum size – the size of the trace buffer
The maximum off-chip (PC) trace buffer size is 22MB. Execution will not halt when this 
external buffer is full.
See also Section 12.3.5 “Trace and Profiling”.
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FIGURE 7-1: PIC32 INSTRUCTION TRACE OPTIONS
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7.3.3 Setting Up and Using Trace
PIC32 Instruction Trace requires hardware and software setup before you can trace.

7.3.3.1 HARDWARE SETUP – PIC32 MCU ON PIM

To use the PIC32 Instruction Trace feature with the PIM do the following:
1. Plug the PIM into an unpowered target board.
2. Install communication cable(s) between the emulator and your target board. See 

Section 3.5 “Target Communication Connections”.
3. Connect the trace cable from the trace port on the PIM to the trace adapter 

board. Orient the cable as show in Figure 5. For hardware details, see 
Chapter 17.  “MPLAB REAL ICE Trace Interface Kit”.

4. Plug the trace adapter board into the MPLAB REAL ICE in-circuit emulator logic 
probe port. The top of the adapter board contains the connectors and should be 
oriented upwards when plugging the board into the logic probe port (Figure 5).

5. Power the target.

FIGURE 7-2: TRACE CONNECTION WITH PIM 

Note: When using trace, pins TRCLK and TRD3:0 are used. Therefore, you 
cannot use the other functions multiplexed on these pins. 
For PIC32MX360F512L, multiplexed functions are RG14:12 and RA7:6. 
Check your device data sheet for details.
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7.3.3.2 HARDWARE SETUP – PIC32 MCU ON TARGET

When designing instruction trace capability onto your own board, the following 
provisions will need to be made.
• Termination series resistors will need to be added as depicted in Chapter 16.  

“PIC32 PIMs with Trace”.
• Depending on your board routing and loading of the signals used for trace; it is a 

good idea to place 0 ohm resistors that can be unpopulated to isolate the trace 
signals TRCLK and TRD3:0.

To use the PIC32 Instruction Trace feature with your own board do the following:
1. The target board should initially be unpowered.
2. Install communication cable(s) between the emulator and your target board. See 

Section 3.5 “Target Communication Connections”.
3. Connect the trace cable from the target board to the trace adapter board. Make 

sure the PIC32 MCU on your target board is connected to accommodate trace, 
as per Figure 7-3. For hardware details, see Chapter 17.  “MPLAB REAL ICE 
Trace Interface Kit”.

4. Plug the trace adapter board into the MPLAB REAL ICE in-circuit emulator logic 
probe port. The top of the adapter board contains the connectors and should be 
oriented upwards when plugging the board into the logic probe port (Figure 7-3).

5. Power the target.

FIGURE 7-3: TRACE CONNECTION WITH DEVICE ON TARGET

Note: When using trace, pins TRCLK and TRD3:0 are used. So, you cannot use 
the other functions multiplexed on these pins. For PIC32MX360F512L, 
multiplexed functions are RG14:12 and RA7:6.
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7.3.3.3 MPLAB X IDE SETUP

To set up MPLAB X IDE to use trace for the MPLAB REAL ICE in-circuit emulator:
1. Right click on the project name and select “Properties”. In the Project Properties 

dialog, click on “Real ICE” (under “Categories”).
2. Under “Option categories”, select “Clock”. For data capture and trace, the 

emulator needs to know the instruction cycle speed.
3. Under “Option categories”, select “Trace and Profiling”.
4. Under “Data Collection Selection”, choose “Instruction Trace/Profiling”.
5. Set up any other trace-related options. (See Section 12.3.5 “Trace and 

Profiling”.)
6. Click OK.
On a Debug Run, trace will continue to fill the trace buffer with data, rolling over when 
the buffer is full, until a program Halt.

7.3.3.4 VIEWING TRACE DATA

When trace is enabled and code is run, trace data will be collected by the emulator. 
Once the device is halted, trace data will be decoded and displayed in the Trace 
window (Window>Debugging>Trace).

7.3.4 Trace Hardware Specifications
Specifications for hardware that supports PIC32 Instruction Trace may be found under 
Chapter 16.  “PIC32 PIMs with Trace”.

7.4 INSTRUMENTED TRACE
For some 32-bit devices, instrumented trace is available (see Chapter 2.  “Device and 
Feature Support”).
For information on this trace, see Section 5.5 “Instrumented Trace”.
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7.5 PC PROFILING
PC profiling is a method for examining C code to determine how much time is spent in 
each function. This information can show you where your program time is being spent 
so you can work to optimize your code.
For PC profiling, every program counter (PC) trace sample is taken from the trace 
(data) buffer and profiled. This data is displayed in the PC Profiling window, as shown 
in Figure 7-4. In this example, the trace buffer contains 21,000 PC sample data points. 
Of these, 7859 (or 37.42%) were associated with the main() function, 6023 (or 
28.68%) with the subrA() function, etc.
PC profiling is similar to PC sampling. For details see Section 6.5 “PC Sampling”.
To perform profiling:
1. Set up your hardware for PIC32 Instruction trace (see Section 7.3 “PIC32 

Instruction Trace”.)
1. Open the Project properties window (File>Project Properties).
2. Click on “REAL ICE” under “Categories” and select “Trace and Profiling” from the 

“Options categories” drop-down box.
3. Under “Data Collection Selection”, select “Instruction Trace/Profiling”.
4. Set up your data file in this window. For reference, see Section 12.3.5 “Trace 

and Profiling”. Then click OK.
5. Select Window>Debugging>PC Profiling. This will open the PC Profiling window.
6. Run your code and then pause/halt.
7. View the profiling data in the window. Data is only displayed on halt.
8. Right click in the window to pop up a menu to either clear the data or reload the 

data.

FIGURE 7-4: PC SAMPLING WINDOW
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7.6 APPLICATION IN/OUT

The Application In/Out window allows you to interact with a running application using 
the Application Input/Output feature supported on some devices. Using this feature, 
data may be sent serially to and from the target application and, during runtime, over 
the same PGC/PGD lines used for debugging. Data written to the APPOUT register will 
be displayed to the window, while user input will be sent to the target application and 
available in the APPIN register.
To use the Application In/Out window:
• Use the device-specific header file when building your application to use the 

macros assigned in the header (per Example 7-1.)
• Alternatively, the PIC32 MCU library has printf() and scanf() functions for 

use with the Application In/Out feature. Refer to the “PIC32 Debug-Support 
Library” chapter in 32-Bit Language Tools Libraries (DS51685).

EXAMPLE 7-1: APPLICATION IN/OUT MACRO USAGE

The following application code reads the application input register and writes out a 
padded value of the input to the application output register.
// include file
#include <p32xxxx.h>

// set up config bits
#pragma config FWDTEN = OFF

// initialize variables
unsigned int val;
int i;
unsigned int oval;

int main(void)
{
   while(1)
   {
    if(_DDPSTATbits.APIFUL) // APPI is full?
      {
       val = _APPI;         // Read User Input
       for(i=0; i<4; i++)
         {
          while(_DDPSTATbits.APOFUL); // APPO is full?
          oval =  val&0xFF;
          if(oval < 0x20)
             oval = 0x20;
          oval |= 0x20202000;
          _APPO = oval;               // Send to MPLAB X IDE
          val >>= 8;
         }
      }
   }
}

Note: This window is only available for devices that support the application in/out 
function used with the MPLAB REAL ICE In-circuit Emulator or MPLAB ICD 
3 In-circuit Debugger. For details, see online help, “Device and Feature 
Support”.
The application In/Out function cannot be used with PIC32 instruction trace.
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To run this application:
1. Create a project using the Project wizard:

a) Select a supported device.
b) Select REAL ICE or ICD 3 as the hardware tool.
c) Use the “MPLAB C Compiler for PIC32 MCUs” or the “MPLAB XC32 C 

Compiler” as the language toolsuite.
2. Select File>New File to create and name a new C Source File. In the Editor 

window that opens, add the previous code and save.
3. Right click on the project name in the Projects window and select “Properties”. In 

the Project Properties window, click on “pic32-gcc” under “Categories”. Under 
“Option Categories”, select “General” and check the “Enable App IO” checkbox.

4. Build the project (Right click on the project name and select “Build”).
5. Select Window>Debugging>PIC App IO to open the Application In/Out window.
6. Click on the “Properties” button (on the left of the window) to launch the Set App 

IO Properties dialog. Under “Capture”, click “On”.
7. Debug Run or Run the project.
8. Enter an text value in the Input text box. Press Enter.
9. View the output in the Output text box.

FIGURE 7-5: SET APP I/O PROPERTIES

FIGURE 7-6: APP IN/OUT WINDOW

Change Input and Output Formats by opening Set App IO Properties dialog and 
running the program again to see what outputs result for different inputs.
For more on options available in this window, see Section 12.4.2 “Application In/Out 
Window and Related Dialogs”.
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7.7 ADDITIONAL DEBUG FEATURES
In addition to the debug features covered previously, 32-bit devices have the other 
debug features, such as “Freeze on Halt”, which allows you to freeze selected periph-
erals on a halt. For a complete list of debug functions, windows and dialogs, see 
Chapter 12.  “Emulator Function Summary”.
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Chapter 8.  Troubleshooting First Steps
8.1 INTRODUCTION
If you are having problems with MPLAB REAL ICE in-circuit emulator operation, start 
here.
• The 5 Questions to Answer First
• Top Reasons Why You Can’t Debug
• Other Things to Consider

8.2 THE 5 QUESTIONS TO ANSWER FIRST
1. What device are you working with? Often an upgrade to a newer version of 

MPLAB IDE is required to support newer devices.
2. Are you using a Microchip demo board or one of your own design? Have you fol-

lowed the guidelines for resistors/capacitors for communications connections? 
See Chapter 3. “Operation”.

3. Have you powered the target? The emulator cannot power the target.
4. Are you using a USB hub in your set up? Is it powered? If you continue to have 

problems, try using the emulator without the hub (plugged directly into the PC.)
5. Are you using the standard communication cable (RJ-11) shipped with emulator? 

If you have made a longer cable, it may have communications errors. If longer 
cables are required, you should consider using high-speed communications. See 
Section 3.4.2 “High-Speed/LVDS Communication (Performance Pak)”.

8.3 TOP REASONS WHY YOU CAN’T DEBUG
1. The oscillator is not working. Check your Configuration bits setting for the 

oscillator. If you are using an external oscillator, try using an internal oscillator. If 
you are using an internal a PLL, make sure your PLL settings are correct.

2. The target board is not powered. Check the power cable connection.
3. The Vdd voltage is outside the specifications for this device. See the device 

programming specification for details.
4. The emulator has somehow become physically disconnected from the PC and/or 

the target board. Check the communications cables’ connections.
5. Emulator to PC communications has somehow been interrupted. Reconnect to 

the emulator in MPLAB IDE.
6. The device is not properly seated on the target board. If the emulator is properly 

connected and the target board is powered, but the device is absent or not 
plugged in completely, you may get the message:
Target Device ID (0x0) does not match expected Device ID (0x%x)
where %x is the expected device ID.

7. The device is code-protected. Check your Configuration bits setting for code 
protection.
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8. You are trying to debug a production device that doesn't have debugging capa-
bilities. Use a debug header instead. (See the “Processor Extension Pak and 
Debug Header Specification” (DS51292) in “Recommended Reading”.)

9. The target application has somehow become corrupted or contains errors. Try 
rebuilding and reprogramming the target application. Then initiate a 
Power-On-Reset of the target.

10. You do not have the correct PGC/PGD pin pairs programmed in your 
Configuration bits (for devices with multiple PGC/PGD pin pairs).

11. Other configuration settings are interfering with debugging. Any configuration 
setting that would prevent the target from executing code will also prevent the 
emulator from putting the code into debug mode.

12. Brown-out Detect voltage is greater than the operating voltage VDD. This means 
the device is in Reset and cannot be debugged.

13. You have not followed the guidelines in Chapter 3.  for communication 
connections.

8.4 OTHER THINGS TO CONSIDER
1. Use the Loop-Back Test board to verify that the emulator itself is functioning 

correctly (Section 13.6 “Loop-Back Test Board”.)
2. There may be a problem programming in general. As a test, switch to Run mode 

(Run>Run Project) and program the target with the simplest application possible 
(e.g., a program to blink an LED). If the program will not run, then you know that 
something is wrong with the target setup.

3. It is possible that the target device has been damaged in some way (e.g., over 
current). Development environments are notoriously hostile to components. 
Consider trying another target device.

4. Review emulator debug operation to ensure proper application setup (see 
Chapter 3. “Operation”.)

5. If the problem persists contact Microchip.
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Chapter 9.  Frequently Asked Questions (FAQ)
9.1 INTRODUCTION
Look here for answers to frequently asked questions about the MPLAB REAL ICE 
in-circuit emulator system.
• Emulator Operation
• Instrumented Trace Operation
• General Issues

9.2 EMULATOR OPERATION
The questions below concern emulator operation.

9.2.1 What's in the silicon that allows it to communicate with the 
MPLAB REAL ICE in-circuit emulator?

Most silicon contains a debug module that can communicate with the emulator. A small 
debug executive program also needs to be programmed in the high area of memory 
(sometimes in a separate area of memory called test memory). On some small devices 
without on-chip debugging capability, a Processor Extension Pak or an Emulation 
Extension Pak may be purchased to allow debugging.

9.2.2 How is the throughput of the processor affected by having to 
run the debug executive?

The debug executive doesn't run while code is running, so there is no throughput 
reduction, i.e., the emulator doesn’t ‘steal’ any cycles from the target device.

9.2.3 How does the MPLAB REAL ICE in-circuit emulator compare 
with other in-circuit emulators/debuggers?

Please refer to Section 3.2 “Tools Comparison”.

9.2.4 How does MPLAB X IDE interface with the MPLAB REAL ICE 
in-circuit emulator to allow more features than in-circuit 
debuggers?

For some devices, the MPLAB REAL ICE in-circuit emulator communicates using the 
debug executive located in a special area of memory that does not use application pro-
gram memory. Also, the debug exec is streamlined for more efficient communication. 
The emulator contains an FPGA, large SRAM Buffers (1Mx8), and a high speed USB 
interface. The program memory image is downloaded and is contained in the SRAM to 
allow faster programming. The FPGA in the emulator serves as an accelerator for 
interfacing with the device in-circuit debugger modules.
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9.2.5 Does the MPLAB REAL ICE in-circuit emulator have complex 
breakpoints?

Yes. You can break based on pass counts, program memory execution at a specific 
address or data memory reads/writes at a specific address. You can also do event 
breakpoints (break on an event) sequenced breakpoints (break after events occur in a 
specific order), or ANDed breakpoint (break when events occur all together).

9.2.6 One of the probe pins is labeled 5V. How much drive capability 
does this probe have?

This pin provides a monitoring function (allows you to see what VDD is actually being 
applied and used on the driver buffers). Attaching any circuitry to this pin can affect 
emulator operation.
The MPLAB REAL ICE in-circuit emulator cannot provide power to the target, unless 
you are using the Power Monitor (see Chapter 20. “MPLAB REAL ICE Power 
Monitor”).

9.2.7 Are any of the driver boards optoisolated or electrically 
isolated?

They are DC optoisolated. To isolate against AC voltage (120V), see Chapter 18. 
“MPLAB REAL ICE Isolator Unit”.

9.2.8 What precautions are there with the programming clock (PGC) 
or programming data (PGD) pins?

The following are precautions for programming:
• The standard modular (ICSP) RJ-11 cable does not allow for communications 

clock speeds greater than about 15 Mb/sec. For these high-speed applications, 
the Performance Pak (high-speed/LVDS) cable interface is required.

• Some circuitry should not be used on these pins. See Section 3.5.4 “Circuits 
That Will Prevent the Emulator From Functioning”. Also refer to “Development 
Tools Design Advisory” (DS51764).

9.2.9 How do I connect the Performance Pak pins CLK and DAT?
These connections are optional and used for SPI trace. For more information, see 
Section 3.6.2 “SPI Trace Connections (High-Speed/LVDS Connection)”.

9.2.10 What is meant by, “The data rate is limited to 15 MIPS, when 
using the Standard Board?” Is this caused by the core 
processor or transfer rate?

The Standard Board uses the RJ-11 cable and that cable has a limitation on how fast 
data can reliably be transmitted when using trace, runtime watches, and data capture. 
The top end is when the processor has an operational speed of 15 MIPS. The trace 
clock is derived from the main system clock of the device.
The 15 MIPS limit is a worst case limit. For well designed boards with less signal 
integrity problems, the limit may be higher.

9.2.11 Does the 15 MIPS limit apply to PIC32 devices?
No. The PIC32 MCU uses a fixed rate clock that doesn't derive from the target system 
clock. It also uses a more robust communication protocol.
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9.2.12 To debug a dsPIC® DSC running at 30 MIPS, is high-speed 
communications necessary to do even basic debugging?

Basic debugging at any device frequency can be accomplished with either standard or 
high-speed (Performance Pak) communications.

9.2.13 My target board connector is for standard communications but I 
want to use high-speed communications. Can I use the 
high-speed/LVDS communications (Performance Pak) cables, 
high-speed-to-standard converter board, and standard 
communication (ICSP) cable?

No. You cannot use the standard/ICSP cable for high-speed communications, i.e., high 
device operational frequencies. This introduces signal integrity issues, due to the lower 
quality of cable transmission, when using the RJ-11 converter board.

9.2.14 If high-speed/LVDS communications is used, do pins 7-8 on the 
receiver board have to be connected, or can they just be left 
open?

They can be left open. The high-speed receiver board weakly pulls them down.

9.2.15 What is the function of pin 6, the auxiliary pin, on the 
high-speed receiver board?

This pin is reserved for use by the emulator. Do not use pin 6.
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9.3 INSTRUMENTED TRACE OPERATION
Instrumented trace has three types: Native trace, SPI trace and I/O Port trace. For 
details, see Section 5.5.3 “Types of Trace”. Not all devices support each type of 
instrumented trace.
The following questions relate to these trace types.

9.3.1 When using instrumented trace, is the connection electrically 
isolated in any way?

If you are using Native trace, you can use the opto-isolator (Chapter 18. “MPLAB 
REAL ICE Isolator Unit”) to isolate from high-voltage AC. There is no equivalent for 
SPI trace or I/O Port trace.

9.3.2 Can we do trace by using the 5 or 6 ICSP pins only?
Native trace is possible using the standard ICSP interface. SPI trace and I/O Port trace 
require additional hardware. See Section 3.6 “Trace Connections”.

9.3.3 Does inputting execution speed in the Project Properties dialog 
(File>Project Properties, REAL ICE category, Clock option 
category) actually set communication clock?

No. The input box in this tab merely reports the speed to the emulator so that it can 
accurately control timing. Reporting the clock is needed only for Native trace, data cap-
ture, and runtime watches. If you are using clock switching, this can cause issues these 
features.

9.3.4 When would SPI trace be used? What extra advantage does this 
have?

SPI trace can be used on devices that do not have Native trace. Also, SPI trace is faster 
than Native trace and impacts code size less. See Section 5.5.3 “Types of Trace” for 
comparison details.

9.3.5 In order to use the SPI trace, what is the hardware connection?
For serial SPI port trace, the device SPI SDO (serial data output) and SCK (serial clock) 
are required. These pins must be connected, respectively, to the DAT and CLK pin 
interface on the Performance Pak receiver board. 
See Section 3.6.2 “SPI Trace Connections (High-Speed/LVDS Connection)” for 
more information.

9.3.6 For SPI trace, which two pins are used?
The pins are:
• SDO (Serial Data Output)  DAT (pin 7)
• SCK (Serial Clock Output)  CLK (pin 8)
See Section 3.6.2 “SPI Trace Connections (High-Speed/LVDS Connection)” for 
more information.

9.3.7 What are the correct port settings to use SPI trace, i.e., mode, 
sync/async, etc.?

The setup is taken care of by MPLAB X IDE, so you will not need to be concerned about 
the code required for setting this. Trace will support 64 trace points and 64 log points. 
For details, see Section 5.5.9 “More on Trace/Log ID Numbers”.

SPI – Comm Protocol MODE1, clock high, sampled falling edge.
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9.3.8 What is the correct connection for using I/O Port trace?
The connection varies depending on the PORT used. There are port assignments in 
MPLAB X IDE that are displayed when the PORT is selected in the property sheet. See 
Section 3.6.3 “I/O Port Trace Connections” for more information.

9.3.9 Can I use any port?
The port must be available on the device and not multiplexed with the currently used 
PGC and PGD pins.

9.3.10 Of the eight (8) port pins, which one is the clock?
For details, see Section 5.5.9 “More on Trace/Log ID Numbers”.

9.3.11 Are these I/O ports used for trace available as general I/O 
during debugging?

For 8-bit devices, once the ports are defined to be used for trace, you should not 
access them in your code.
For 16-bit devices, you may write to the opposing 8-bit part of the port provided byte 
write operations are used. The following example will write to the high side of the port 
only.
#define high(num)  (((BYTE *)&num)[1])
#define low(num)   (((BYTE *)&num)[0])
high(PORTA) = 0x12;

9.3.12 I cannot get trace to work. What’s wrong?
Consider the following:
• Certain tool versions are required to use trace. Refer to Chapter 6. “Specific 

Debug Functions: 8- and 16-Bit Devices” or Chapter 7. “Specific Debug 
Functions: 32-Bit Devices”.

• Only C code can be used with trace, not assembly.
• In-line assembly code (assembly code within C code) cannot be traced.
• Code must be rebuilt and reprogrammed when trace macros are added.
• Ensure you do not have trace disabled, i.e., Project Properties window, REAL ICE 

category, “Trace and Profiling” options category, “Data Collection Selection” 
should not be “Off”.

• Native trace, data captures and runtime watches cannot be used together.
• The target clock frequency must be reported for Native and SPI trace in the Proj-

ect Properties window, REAL ICE category, “Clock” options category.
• For Port I/O Trace:

- All 8 pins must be dedicated to trace (i.e., not multiplexed with the currently 
used PGC and PGD pins.)

- Ensure that the chosen port is able to output 0x00 and 0xFF. As a test, set the 
port TRIS to 0 (all outputs) and set the LAT to a value in the Watches window. 
The value written to LAT should appear on the port pins.

• Ensure pins are set as digital I/O and not analog.
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9.4 GENERAL ISSUES
The following questions cover general emulator functions.

9.4.1 My device keeps failing to program. What is wrong?
If you have code that changes flash memory, using Run (Run>Run Project) will run 
your code immediately after programming and the verify operation could fail. To prevent 
the code from running after programming:
1. Keep the debug tool connected - Tools>Options, Embedded button, Generic 

Settings tab, check “Maintain active connection to hardware tool”.
2. Select 'Hold in Reset'.

9.4.2 I have set a breakpoint, but my program doesn't stop there. 
Why?

Consider the following:
1. Are you executing code in Run mode, i.e., selecting Run>Run Project? Break-

points are ineffective in this mode.
2. Are these breakpoints part of a sequence? Remember, sequence breakpoints 

will only halt execution if they are followed in the exact sequence.
3. Are you seeing breakpoint skid? See the MPLAB X IDE Help file for the emulator, 

Limitations section.
4. Are you using compiler optimizations? If so, your program may not have exe-

cuted the instruction at which you wish to break. Try setting a breakpoint earlier 
in your code and single step from there to see the actual code flow executed by 
the device.

9.4.3 I can't set a breakpoint on a particular line of code. Why?
There may be many reasons why you cannot set a breakpoint:
1. The line you are trying to break on in not executable code. MPLAB X IDE will 

allow setting breakpoints only on executable code.
2. The line you are trying to break on may have been optimized out by the compiler. 

In that case, try turning optimizations off.
3. The line you are trying to break on may be a compiler directive, and not actual 

code.
4. You may have used up all resources available for breakpoints.
5. You may be in the wrong file. If you have multiple projects open that contain files 

with similar names, ensure you used the file you were expecting.
6. If you are using ifdef code, ensure the code was preprocessed to appear in 

executable code.
You can use the Breakpoints window to help determine the state of all your breakpoints.

9.4.4 I didn’t set a breakpoint, yet I have one in my code. What’s 
going on?

What you are seeing is a phantom breakpoint. Occasionally, a breakpoint can become 
enabled when it shouldn’t be. Simply disable or delete the breakpoint. You may need 
to go to the disassembly window to do so, or simply right click and choose delete all 
breakpoints. If this does not work, try closing and reopening the disassembly window.
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9.4.5 Can I use the debugger with optimized code?
It is strongly recommended that C compiler optimization is turned off during debugging 
(see the Project Properties window). Optimization will greatly alter how the executable 
code corresponds to the source files and hence the debugger may appear to behave 
strangely with some code.

9.4.6 Data capture is not working correctly. What is going on?
The speed of data capture may be too high for USB communications or target 
environment (noise). There are several things you can do:
1. Reduce the clock speed. Refer to Section 12.3.6 “Clock”.
2. Reduce the number of runtime watches in the Watches window.
3. Check for device errata to ensure that there are not issues with data capture.

9.4.7 I cannot get PIC32 Instruction trace to work. What’s wrong?
Consider the following:
• Certain tool versions are required to use trace. Please refer to Chapter 7. 

“Specific Debug Functions: 32-Bit Devices”.
• Ensure you do not have trace disabled, i.e., Project Properties window, REAL ICE 

category, “Trace and Profiling” options category, “Data Collection Selection” 
should not be “Off”.

• Ensure pins are set as digital I/O and not analog.

9.4.8 My program halts while I am tracing, corrupting my trace data. 
What’s happening?

The Watchdog timer can cause this behavior. Ensure it is disabled by properly setting 
the configuration bits.

9.4.9 My PC went into power-down/hibernate mode, and now my 
emulator won’t work. What happened?

When using the emulator for prolonged periods of time, and especially as a debugger, 
be sure to disable the Hibernate mode in the Power Options Dialog window of your 
PC’s operating system. Go to the Hibernate tab and clear or uncheck the “Enable hiber-
nation” check box. This will ensure that all communication is maintained across all the 
USB subsystem components.

9.4.10 I set my peripheral to NOT freeze on halt, but it is suddenly 
freezing. What's going on?

For 16- and 32-bit devices, a reserved bit in the peripheral control register (usually 
either bit 14 or 5) is used as a Freeze bit by the debugger. If you have performed a write 
to the entire register, you may have overwritten this bit. (The bit is user accessible in 
Debug mode.)
To avoid this problem, write only to the bits you wish to change for your application 
(BTS, BTC) instead of to the entire register (MOV).
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9.4.11 An unexpected Reset occurred. How do I determine what 
caused it?

Consider the following actions:
• Ensure the Watchdog Timer is disabled in the configuration bits.
• To determine a Reset source, check the RCON register.
• Handle traps/interrupts in an interrupt service routine (ISR). See below.

16-Bit Devices: You should include trap.c style code:
   void __attribute__((__interrupt__)) _OscillatorFail(void);
          :
   void __attribute__((__interrupt__)) _AltOscillatorFail(void);
          :
   void __attribute__((__interrupt__)) _OscillatorFail(void)
   {
        INTCON1bits.OSCFAIL = 0;        //Clear the trap flag
        while (1);
   }
          :
   void __attribute__((__interrupt__)) _AltOscillatorFail(void)
   {
        INTCON1bits.OSCFAIL = 0;
        while (1);
   }
          :

9.4.12 How can I manually download the firmware?
In general, you do not need to manually download the firmware; MPLAB X IDE will do 
this automatically. For details, see Section 4.3 “Firmware Upgrades”.

9.4.13 I accidentally disconnected my emulator while firmware was 
downloading. What do I do now?

See Section 4.3.3 “Communication Interruption when Installing Firmware”.

9.4.14 My code updates Flash memory; why I don’t I see changes in 
the memory window?

In order to see these changes, you must do a read of the memory.

9.4.15 I don’t see my problem here. Now what?
Try the following resources:
• Section 3.10 “Resources Used by the Emulator”
• Section 10.2 “Error Messages”
• Section 10.3 “General Corrective Actions”
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Chapter 10.  Messages
10.1 INTRODUCTION
The MPLAB REAL ICE in-circuit emulator produces many different output messages. 
Some are error messages, many of which can often be resolved with general corrective 
actions. And, some are informational only.
• Error Messages
• General Corrective Actions
• Informational Messages

10.2 ERROR MESSAGES
MPLAB REAL ICE in-circuit emulator error messages are listed below. Text in error 
messages listed below of the form %x (a variable) will display as text relevant to your 
particular situation in the actual error message.
• Read/Write Errors
• Emulator-to-Target Communication Errors
• Emulator-to-PC Communication Errors
• Corrupted/Outdated Installation Errors
• Debug Failure Errors
• Hardware/Firmware Errors
• Miscellaneous Errors
• Internal Errors

10.2.1 Read/Write Errors
For the errors below, read any instructions under your error message. If these fail to fix 
the problem or if there are no instructions, see Section 10.3.1 “Read/Write Error 
Actions”.
Failed while writing to %s
Failed while reading %s
Failed to program device

See Section 9.4.1 “My device keeps failing to program. What is wrong?”.
Failed to read device
Failed to write to %s memory
Failed to erase the device
Unable to read target register(s).
Unable to write target register(s).
Programming debug executive failed
Programming program executive failed
Failed to get Device ID
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10.2.2 Emulator-to-Target Communication Errors
For the errors below, read any instructions under your error message. If these fail to fix 
the problem or if there are no instructions, see Section 10.3.2 “Emulator-to-Target 
Communication Error Actions”.
Failed to reset the device
Failed while sending cmd_INITCOMM command
Failed while sending cmd_SETPROBES command
Failed while sending cmd_SETBRACKET
Failed to get status
Failed to send database

If you receive this error, perform the following steps:
1. Try downloading again. It may be a one-time error.
2. Try manually downloading the highest-number .jam file.

Invalid command response (sent 0x%x, received 0x%x)
Failed while trying to enter ICE test mode
Failed while trying to start DMA test
Failed to properly receive DMA test data
Timed out while waiting to process data from endpoint 0x%x
Transmission failure while receiving streaming data
Interrupted Exception occurred %s
Unable to start streaming data reception
Unable to start run time data reception
Failed getting PC

10.2.3 Emulator-to-PC Communication Errors
For the errors below, read any instructions under your error message. If these fail to fix 
the problem or if there are no instructions, see Section 10.3.3 “Emulator-to-PC 
Communication Error Actions”.
Failed to set debug options
Failed while stepping the target
Failed while halting the target
Cannot communicate with %s

10.2.4 Corrupted/Outdated Installation Errors
For the errors below, read any instructions under your error message. If these fail to fix 
the problem or if there are no instructions, see Section 10.3.4 “Corrupted Installation 
Actions”.
Failed to download firmware.

If the Hex file does exist:
- Reconnect and try again.
- If this does not work, the file may be corrupted. Reinstall MPLAB X IDE.

If the Hex file does not exist, reinstall MPLAB X IDE.
The MPLAB REAL ICE is missing its Program Executive. Please reconnect to the 
PC and try again.
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The MPLAB REAL ICE is missing its Debug Executive. Please reconnect to the 
PC and try again.
The MPLAB REAL ICE is missing its Device Database. Please reconnect to the 
PC and try again.
The MPLAB REAL ICE is missing a Memory Object.
The current memory object in the MPLAB REAL ICE is corrupted. Please retry the 
operation.
Unable to download debug executive.

If you receive this error while attempting to debug, perform the following steps:
1. Deselect the emulator as the debug tool.
2. Close your project, and then close MPLAB X IDE.
3. Restart MPLAB X IDE, and re-open your project.
4. Reselect the emulator as your debug tool, and attempt to program your target 
device again.

Unable to download program executive.
If you receive this error while attempting to program, perform the following steps:
1. Deselect the emulator as the programmer.
2. Close your project, and then close MPLAB X IDE.
3. Restart MPLAB X IDE, and re-open your project.
4. Reselect the emulator as your programmer, and attempt to program your 
target device again.

10.2.5 Debug Failure Errors
For the errors below, read any instructions under your error message. If these fail to fix 
the problem or if there are no instructions, see Section 10.3.6 “Debug Failure 
Actions”.
Unable to open debug executive file %s
The target device is not ready for debugging. Please check your configuration bit 
settings and program the device before proceeding.

You will receive this message when you have not programmed your device for 
the first time and try to Run. If you receive this message after this, or immediately 
after programming your device, please refer to Section 10.3.6 “Debug Failure 
Actions”.

An unknown exception has occurred. Please unplug the MPLAB REAL ICE and 
reconnect.
The Target is held in Reset. Please ensure the MCLR line is pulled up or High-Z'd.
The Debug Executive is found but can't be communicated with. Please ensure 
your oscillator settings are correct. If the device supports internal RC try to 
connect via that mode first.

See also Section 10.3.2 “Emulator-to-Target Communication Error 
Actions”.

REAL ICE was unloaded while still busy. Please unplug and reconnect the USB 
cable before using REAL ICE again.
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Target device was not found. You must connect to a target device to use MPLAB 
REAL ICE.

See also Section 10.3.2 “Emulator-to-Target Communication Error 
Actions”.

Invalid streaming data was been detected. Run time watch or trace data may no 
longer be valid. Is recommended that you restart your debug session.

See the FAQ, “Data capture has become flaky. What is going on?”.

10.2.6 Hardware/Firmware Errors
For the errors below, read any instructions within your error message.
The 17.5 rail is unable to turn on. Please unplug the MPLAB REAL ICE and 
reconnect. If the problem persists contact Microchip for assistance.
The SRAM has failed its self test. Please unplug the MPLAB REAL ICE and 
reconnect. If the problem persists contact Microchip for assistance.
The FPGA has failed its self test. MPLAB X IDE will attempt to download the latest 
firmware.
Please do not disconnect the REAL ICE during the download process. If the 
problem persists contact Microchip for assistance.
The Driver board is missing. Please unplug the MPLAB REAL ICE, make sure the 
driver board is properly seated and reconnect. If the problem persists contact 
Microchip for assistance.
The Main board serial EEPROM is missing. Please unplug the MPLAB REAL ICE 
and reconnect. If the problem persists contact Microchip for assistance.
The Driver board serial EEPROM is missing. Please unplug the MPLAB REAL ICE 
and reconnect. If the problem persists contact Microchip for assistance.
The DAC is missing. Please unplug the MPLAB REAL ICE and reconnect. If the 
problem persists contact Microchip for assistance.
The Main boards' trigger IO expander is missing. Please unplug the MPLAB 
REAL ICE and reconnect. If the problem persists contact Microchip for 
assistance.
The Data pin I/O test failed. Please unplug the MPLAB REAL ICE and reconnect. 
If the problem persists contact Microchip for assistance.
The Driver I/O expander is missing. Please unplug the MPLAB REAL ICE and 
reconnect. If the problem persists contact Microchip for assistance.
The VPP generator could not set the proper voltage. Please unplug the MPLAB 
REAL ICE and then reconnect. If problem persists, contact Microchip for 
assistance.
The VDD generator could not set the proper voltage. Please unplug the MPLAB 
REAL ICE and then reconnect. If problem persists, contact Microchip for 
assistance.
The Clock or Data line has clamped the external voltage! Please remove your 
target, probe the voltage levels and then reconnect.
Too much current has been drawn on VPP. Please disconnect your circuit, check 
the MCLR line for shorts and then reconnect.
Too much current has been drawn on VDD. Please disconnect your circuit, check 
the CLK and DATA lines for shorts and then reconnect.
Target Vdd not detected. Please ensure the target device is connect
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10.2.7 Miscellaneous Errors
For the errors below, read any instructions under your error message.
could not open file
There was a problem reading file
Failed to set firmware suite.
Database initialization failure.
Connection failed (timed out waiting to REAL ICE to respond)
MPLAB has lost communication with REAL ICE.
Unable to connect to REAL ICE (MPLABComm connect failure)
REAL ICE is busy. Please wait for the current operation to finish.

If you receive this error when attempting to deselect the emulator as a debugger 
or programmer:
1. Wait - give the emulator time to finish any application tasks. Then try to 

deselect the emulator again.
2. Select Halt to stop any running applications. Then try to deselect the emulator 

again.
3. Unplug the emulator from the PC. Then try to deselect the emulator again.
4. Shut down MPLAB X IDE.

REAL ICE failed to request DMA reads.
Unable to initialize REAL ICE database.
An Error occurred while running
Address: %x Expected Value: %x Received Value: %x
Target Device ID (0x%x) does not match expected Device ID (0x%x).

If the Target Device ID is 0x0, your device may not be properly connected to, or 
may be absent from, the target board.

Unable to properly create REAL ICE database.

10.2.8 Internal Errors
See Section 10.3.7 “Internal Error Actions”.
Initialization failed: Unable to create ControlPointMediator
Initialization failed: Unable to create com object
Initialization failed: Unable to retrieve device information for device %s
Initialization failed: Family class is unrecognized
Initialization failed: Failed while retrieving device database (.pic) information
Initialization failed: Failed while retrieving tool database (.rice) information
Initialization failed: Unable to load debug executive
Initialization failed: Unable to acquire emulation memory object
Initialization failed: Unable to acquire ToolExecMediator
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10.3 GENERAL CORRECTIVE ACTIONS
These general corrective actions may solve your problem:
• Read/Write Error Actions
• Emulator-to-Target Communication Error Actions
• Emulator-to-PC Communication Error Actions
• Corrupted Installation Actions
• USB Port Communication Error Actions
• Debug Failure Actions
• Internal Error Actions

10.3.1 Read/Write Error Actions
If you receive a read or write error:
1. Did you hit Abort? This may produce read/write errors.
2. Try the action again. It may be a one-time error.
3. Ensure that the target is powered and at the correct voltage levels for the device. 

See the device data sheet for required device voltage levels.
4. Ensure that the emulator-to-target connection is correct (PGC and PGD are 

connected.)
5. For write failures, ensure that “Erase all before Program” is checked on the 

Program Memory tab of the Settings dialog.
6. Ensure that the cable(s) used are of the correct length - maximum 6” for standard 

communications and 10’ for high-speed communications.

10.3.2 Emulator-to-Target Communication Error Actions
The MPLAB REAL ICE in-circuit emulator and the target device are out-of-sync with 
each other.
1. Select Reset and then try the action again.
2. Ensure that the cable(s) used are of the correct length - maximum 6” for standard 

communications and 10’ for high-speed communications.

10.3.3 Emulator-to-PC Communication Error Actions
The MPLAB REAL ICE in-circuit emulator and MPLAB X IDE are out of sync with each 
other.
1. Unplug and then plug in the emulator.
2. Reconnect to the emulator.
3. Try the operation again. It is possible that the error was a one time glitch.
4. The version of MPLAB X IDE installed may be incorrect for the version of firm-

ware loaded on the MPLAB REAL ICE in-circuit emulator. Follow the steps 
outlined in Section 10.3.4 “Corrupted Installation Actions”.

5. There may be an issue with the PC USB port. See Section 10.3.5 “USB Port 
Communication Error Actions”.

10.3.4 Corrupted Installation Actions
The problem is most likely caused by a incomplete or corrupted installation of MPLAB 
X IDE.
1. Uninstall all versions of MPLAB X IDE from the PC.
2. Reinstall the desired MPLAB X IDE version.
3. If the problem persists, contact Microchip.
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10.3.5 USB Port Communication Error Actions
The problem is most likely caused by a faulty or non-existent communications port.
1. Reconnect to the MPLAB REAL ICE in-circuit emulator
2. Make sure the emulator is physically connected to the PC on the appropriate 

USB port.
3. Make sure the appropriate USB port has been selected in the emulator Settings.
4. Make sure the USB port is not in use by another device.
5. If using a USB hub, make sure it is powered.
6. Make sure the USB drivers are loaded.

10.3.6 Debug Failure Actions
The MPLAB REAL ICE in-circuit emulator was unable to perform a debugging 
operation. There are numerous reasons why this could occur. See Chapter 8. 
“Troubleshooting First Steps”.

10.3.7 Internal Error Actions
Internal errors are unexpected and should not happen. They are primarily used for 
internal Microchip development.
The most likely cause is a corrupted installation (Section 10.3.4 “Corrupted 
Installation Actions”).
Another likely cause is exhausted system resources.
1. Try rebooting your system to free up memory.
2. Make sure you have a reasonable amount of free space on your hard drive (and 

that it is not overly fragmented).
If the problem persists, contact Microchip.

10.4 INFORMATIONAL MESSAGES
MPLAB REAL ICE in-circuit emulator informational messages are listed below in 
numeric order.

Loopback test completed successfully. Your REAL ICE is functioning properly. If 
you are still having problems with your target circuit please check the Target 
Board Considerations section of the online help. 
See Section 13.7 “Target Board Considerations”.

Note: Numbers may not yet appear in displayed messages. Use the Search tab 
on the Help viewer to find your message and highlight it below.
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Chapter 11.  Engineering Technical Notes (ETNs)
The following ETNs are related to the MPLAB REAL ICE in-circuit emulator. Please see 
the product web page for details.
ETN-30: Applies to Assembly #10-00401-R1 or below.
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Chapter 12.  Emulator Function Summary
12.1 INTRODUCTION
A summary of the MPLAB REAL ICE in-circuit emulator functions is listed here.
• Emulator Selection and Switching
• Emulator Options Selection
• Emulator Windows & Dialogs

12.2 EMULATOR SELECTION AND SWITCHING
Use the Project Properties dialog to select or switch emulators for a project. To switch 
you must have more than one MPLAB REAL ICE in-circuit emulator connected to your 
computer. MPLAB X IDE will differentiate between the two by displaying two different 
serial numbers.
To select or change the emulator used for a project:
1. Open the Project Properties dialog by doing one of the following:

a) Click on the project name in the Projects window and select File>Project 
Properties.

b) Right click on the project name in the Projects window and select 
“Properties”.

2. Under “Categories”, click on “Conf: [default]”
3. Under “Hardware Tools”, find “REAL ICE” and click on a serial number (SN) to 

select an emulator for use in the project.

12.3 EMULATOR OPTIONS SELECTION
Set up emulator options on the emulator property pages of the Project Properties 
dialog.
1. Open the Project Properties dialog by doing one of the following:

a) Click the project name in the Projects window, select File>Project Properties.
b) Right click the project name in the Projects window, select “Properties”.

2. Under “Categories”, click on “REAL ICE”
3. Select property pages from “Options categories”. Click on an option to see its 

description in the text box below it. Click to the right of an option to change it.
Available option categories are:
• Memories to Program
• Debug Options
• Program Options
• Freeze Peripherals
• Trace and Profiling
• Clock
• Firmware
• External Triggers
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12.3.1 Memories to Program
Select the memories to be programmed into the target.

12.3.2 Debug Options
Use software breakpoints, if available for the project device.

TABLE 12-1: MEMORIES TO PROGRAM OPTION CATEGORY
Auto select memories and ranges Allow REAL ICE to Select Memories - The emula-

tor uses your selected device and default settings to 
determine what to program.
Manually select memories and ranges - You select 
the type and range of memory to program (see 
below.)

Memory Check to program Memory, where Memory is the 
type of memory. Types include: EEPROM, ID, Boot 
Flash, Auxiliary.

Program Memory Check to program the target program memory range 
specified below.

Program Memory Start (hex)
Program Memory End (hex)

The starting and ending hex address range in 
program memory for programming, reading, or 
verification.
If you receive a programming error due to an 
incorrect end address, correct the end address and 
program again.
Note: The address range does not apply to the 
Erase function. The Erase function will erase all data 
on the device.

Preserve Program Memory Check to not program the target program memory 
range specified below.
Ensure code is NOT code protected.

Preserve Program Memory Start (hex)
Preserve Program Memory End (hex)

The starting and ending hex address range in target 
program memory to preserve when programming, 
reading, or verifying.
This memory is read from the target and overlayed 
with existing MPLAB X IDE memory.

Preserve Memory Check to not erase Memory when programming, 
where Memory is the type of memory. Types include: 
EEPROM, ID, Boot Flash, Auxiliary.
Ensure code is NOT code protected.

TABLE 12-2: DEBUG OPTIONS OPTION CATEGORY
Use Software Breakpoints Check to use software breakpoints. 

Uncheck to use hardware breakpoints. See the discussion below 
to determine which type is best for your application.

TABLE 12-3: SOFTWARE VS HARDWARE BREAKPOINTS
Features Software Breakpoints Hardware Breakpoints

Number of breakpoints unlimited limited

Breakpoints are written to program memory debug registers

Time to set breakpoints oscillator speed dependent, it 
can take minutes

minimal

Skidding no yes

Note: Using software breakpoints for debug impacts device endurance. So, it is 
recommended that devices used in this manner should not be used as production parts.
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12.3.3 Program Options
Choose to erase all memory before programming, or to merge code.

12.3.4 Freeze Peripherals
Select peripherals to freeze, or not freeze, on program halt.

PIC12/16/18 MCU Devices
To freeze/unfreeze all device peripherals on halt, check/uncheck the “Freeze on Halt” 
checkbox. If this does not halt your desired peripheral, be aware that some peripherals 
have no freeze on halt capability and cannot be controlled by the emulator.

dsPIC, PIC24 and PIC32 Devices
For peripherals in the list “Peripherals to Freeze on Halt”, check to freeze that periph-
eral on a halt. Uncheck the peripheral to let it run while the program is halted. If you do 
not see a peripheral on the list, check “All Other Peripherals”. If this does not halt your 
desired peripheral, be aware that some peripherals have no freeze on halt capability 
and cannot be controlled by the emulator.
To select all peripherals, including “All Other Peripherals”, click Check All. To deselect 
all peripherals, including “All Other Peripherals”, click Uncheck All.

12.3.5 Trace and Profiling
Depending on the device you have selected for your project, you may be able to use 
trace, PC sampling/profiling or other data collection features when debugging. Enable 
and set up these features as specified in the following sections.

TABLE 12-4: PROGRAM OPTIONS OPTION CATEGORY
Erase All Before Program Check to erase all memory before programming begins.

Unless programming new or already erased devices, it is 
important to have this box checked. If it is not checked, 
the device is not erased and program code will be 
merged with the code already in the device.

Enable Low Voltage Programming For Programmer Settings only, PIC12F/16F1xxx devices:
• For the LVP configuration bit set to “Low-voltage pro-

gramming enabled”, you may program in either 
high-voltage (default) or low-voltage (enabled here.)

• For the LVP configuration bit set to “High-voltage on 
MCLR/Vpp must be used for programming”, you may 
only program in high-voltage.

Do not erase auxiliary memory For devices that support auxiliary memory:
Check to not erase aux memory when programming.
Uncheck to erase aux memory when programming.

TABLE 12-5: FREEZE PERIPHERALS OPTION CATEGORY
Freeze Peripherals Freeze all peripherals on halt.

This options applies to PIC12/16/18 MCUs.

Peripheral Freeze this peripheral on halt.
This options applies to 16- and 32-bit MCUs.
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8-Bit and 16-Bit Devices
Options available on this page depend on the trace/profiling features of the project device. For more on trace 
and profiling, see Chapter 6. “Specific Debug Functions: 8- and 16-Bit Devices”.

TABLE 12-6: TRACE/PROFILING OPTION CATEGORY
Data Collection Selection Enable/Disable data collection.

• Off - Do not collect target data.
• User Instrumented Trace - see Section 5.5 “Instrumented Trace”.
• PC Sampling - see Section 6.5 “PC Sampling”.
• Function Level Profiling - see Section 6.6 “Function Level Profiling”.
• Jump Trace - see Section 6.4 “Jump Trace”.
• Power Module (Target Power Sampling) - see Chapter 20. “MPLAB REAL ICE 

Power Monitor”
Data File Path and Name Enter or change the path and/or name of the file used to store data.

Data File Maximum Size 
(bytes)

Set the maximum size of the data file.
Target power sampling will take 12 bytes or 18 bytes (with PC data) per sample.
The file size may be adjusted down to be a multiple of one of those byte sizes depend-
ing upon the trace type selected. Other trace data types may use record byte sizes 
that are different from those described above.

Data Buffer Maximum Size 
(bytes)

Set the size of the data buffer, up to 54600 bytes (on board the emulator unit.)
For trace/sampling data that is buffered in memory while the target is running, individ-
ual trace or sample entry sizes vary depending upon the trace/sample type and the 
device and tool being used. It is normally good to make this buffer as large as possi-
ble.
For example, the enhanced PIC16 with instruction trace uses 1 to 3 bytes for each 
in-memory entry. Each of those will generate a 13-byte REAL ICE instruction trace 
entry as well. Each such in-memory record will normally be converted to a trace data 
file entry line, as detailed in the data file size description (refer to the data file size 
description for trace/sampling file entry sizes).

Stall CPU When Trace Buffer 
is Full

Stop execution when the trace buffer is full. Set the buffer size in the option described 
above.

User Instrumented Trace Items
Disable Trace Macros Check to temporarily disable trace macros or uncheck to enable trace macros.

To disable trace, remove all macros and select “Off” under “Data Collection Selection”.

Communications Medium Select the trace medium, if available, from the following (device-dependent): Native, 
I/O Port, SPI.

I/O Port Selection Specify the device port to be used for I/O port trace. 
The available combinations for the selected device will be listed.

SPI Selection Specify the device SPI pins to be used for SPI trace. The available pins for the 
selected device will be listed.

PC Sample Items - Only on Some 16-bit Devices
Timer Selection (Not Used by 
Application Code)

Select a device timer to use to count PC samples.
Note: You will no longer be able to use this timer in your application, it will be 
dedicated to PC sampling.
Note: You may select only one timer; you cannot combine two timers to get a 32-bit 
timer. Using one timer of a 32-bit-timer pair will prohibit that pair from operating as a 
32-bit timer.

Timer Interrupt Priority Select an interrupt priority for the timer.
Note: Select a priority that is higher than other priorities you have set in your applica-
tion. If you do not, the other priorities will preempt the sampling priority and you will 
not capture these samples.
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Timer Interval Enter a sampling interval.
This must be integer values (1, 2, 3, and so forth).
If you are not capturing data, you may be missing samples (given your current inter-
val). Try adjusting the unit selection and interval, for example, if you had 1 millisecond, 
try 990 microseconds.

Timer Interval Units Select a sampling interval unit:
• microseconds
• milliseconds
• seconds
• instruction cycles

Function Level Profiling - Only on Some 16-bit Devices
Include Time Stamp Include time stamp information. Exclusive of “Summary Profile Data”.

Summary Profile Data Only Include summary profile data. Exclusive of “Include Time Stamp”.

TABLE 12-6: TRACE/PROFILING OPTION CATEGORY (CONTINUED)
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32-Bit Devices
Options available on this page depend on the trace/profiling features of the project device. For more on trace 
and profiling, see Chapter 7. “Specific Debug Functions: 32-Bit Devices”.

TABLE 12-7: TRACE/PROFILING OPTION CATEGORY
Data Collection Selection Enable/Disable data collection.

• Off - Do not collect target data.
• Instruction Trace/Profiling - see Section 7.3 “PIC32 Instruction Trace” 

and Section 7.5 “PC Profiling”.
• User Instrumented Trace - see Section 5.5 “Instrumented Trace”.
• Power Module (Target Power Sampling) - see Chapter 20. “MPLAB 

REAL ICE Power Monitor”
Data File Path and Name Enter or change the path and/or name of the file used to store data.

Data File Maximum Size (bytes) Set the maximum size of the data file.
Each line of instruction trace data in a trace data file requires 13 bytes when 
using the emulator.
Target power sampling will take 12 bytes or 18 bytes (with PC data) per 
sample.
The file size may be adjusted down to be a multiple of one of those byte 
sizes depending upon the trace type selected. Other trace data types may 
use record byte sizes different from those described above.

Data Buffer Maximum Size (bytes) Set the size of the data buffer, up to 54600 bytes (on board the emulator 
unit.)
For trace/sampling data that is buffered in memory while the target is run-
ning, individual trace or sample entry sizes vary depending on the 
trace/sample type and the device and tool being used. It is normally good to 
make this buffer as large as possible.
For example, PIC32 instruction trace takes 8 bytes per “frame” which can 
produce over 50 13-byte REAL ICE instruction trace entries in a trace file.

User Instrumented Trace Items
Disable Trace Macros Check to temporarily disable trace macros or uncheck to enable trace 

macros.
To disable trace, remove all macros and select “Off” under “Data Collection 
Selection”.

Communications Medium Select the trace medium, if available (device dependent): Native.
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12.3.6 Clock
Enter the runtime clock (instruction) speed under this option category. This does not set 
the speed, but informs the emulator of its value for runtime watch, data capture and 
trace.

12.3.7 Firmware
Select and load emulator firmware. MPLAB X IDE automatically downloads the correct 
firmware for your project. Only change this setting if you are having issues.

12.3.8 External Triggers
Select external triggers for Triggers 0 through 7. For more on triggers, see 
Section 5.6 “External Triggers (Logic Probes)”.

Note: Clock switching is available for data capture and trace, but you must set the 
clock correctly or you may see issues. Enter the fastest instruction speed 
you will be using.

TABLE 12-8: CLOCK OPTION CATEGORY
 Use FRC in debug mode
(dsPIC33E/F and PIC24E/F/H devices 
only)

When debugging, use the device fast internal RC 
(FRC) for clocking instead of the oscillator specified 
for the application. This is useful when the applica-
tion clock is slow.
Checking this checkbox will let the application run at 
the slow speed but debug at the faster FRC speed.
Reprogram after changing this setting.
Note: Peripherals that are not frozen will operate at 
the FRC speed while debugging.

Target run-time instruction speed Enter a value for the “Speed unit” selected.
Example 1: For a PIC24 MCU and a target clock 
oscillator at 32 MHz (HS), instruction speed = 32 
MHz/2 = 16 MIPS.
Example 2: For a PIC18F8722 MCU and a target 
clock oscillator at 10 MHz (HS) making use of the 
PLL (x4 = 40 MHz), instruction speed = 40 MHz/4 = 
10 MIPS.

Instruction speed units Select either:
KIPS – Thousands (103) of instructions per second
MIPS – Millions (106) of instructions per second

TABLE 12-9: FIRMWARE OPTION CATEGORY
Use Latest Firmware Check to use the latest firmware. Uncheck to select 

the firmware version below.

Firmware File Click in the right-hand text box to search for a firm-
ware file to associate with the emulator. For details, 
see Section 4.3 “Firmware Upgrades”.
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12.4 EMULATOR WINDOWS & DIALOGS
The following windows and dialogs are used specifically for the emulator and/or other 
debug tools.
• Trace Window and Related Dialogs
• Application In/Out Window and Related Dialogs
• PC Sampling Window and Related Dialogs

12.4.1 Trace Window and Related Dialogs
The trace window displays the results of a trace. This window is available for the 
emulator and the simulator.

FIGURE 12-1: TRACE WINDOW

Right clicking in a column of the window shown above will pop up a menu with a list of 
functions. For more on these functions, see the MPLAB X IDE User’s Guide 
(DS52027), “MPLAB X IDE Windows and Dialogs”, “Trace Window”.
For more on using trace, see:
• Section 5.5 “Instrumented Trace”
• Section 7.3 “PIC32 Instruction Trace” for 32-bit Devices
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12.4.2 Application In/Out Window and Related Dialogs
The Application In/Out window supports the App IO function in which runtime control 
information can be sent to an application through MPLAB IDE (APPIN) and status 
information can be sent by the application to MPLAB IDE (APPOUT).

FIGURE 12-2: APP IN/OUT WINDOW

Other actions are available from the buttons. Right clicking in the Output text box will 
pop-up a menu with the same functions.

For more on using this window and its related dialogs, see:
• Section 6.7 “Application In/Out” for 8- and 16-bit Devices
• Section 7.6 “Application In/Out” for 32-bit Devices

12.4.3 PC Sampling Window and Related Dialogs
Program Counter (PC) sampling is a method of determining the amount of time spent 
in each application function for use in code optimization. The PC Sampling window will 
show the function name, sample count for that function, percentage sample count is of 
the total samples, and a bar graph of the count.
For more on PC Sampling and Profiling, see:
• Section 6.5 “PC Sampling” for 8- and 16-bit Devices
• Section 7.5 “PC Profiling” for 32-bit Devices

TABLE 12-10: APP IN/OUT WINDOW BUTTONS
Button Description

Properties Open the Set App IO Properties dialog.
Set the format of the input and output: Text, 8-bit Hex, 16-bit Hex, 
or 32-bit Hex.
Enable/disable data capture. Browse to a location to save the 
output to a file.

Clear App IO Output Clear the output content from the Output text box.

Copy App IO Output to 
Output View

Copy the Output text box content to the Output window.
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Chapter 13.  Hardware Specification
13.1 INTRODUCTION
The hardware and electrical specifications of the basic MPLAB REAL ICE in-circuit 
emulator system are detailed.

13.2 HIGHLIGHTS
This chapter discusses:
• USB Port/Power
• Emulator Pod
• Standard Communication Hardware
• Loop-Back Test Board
• Target Board Considerations

13.3 USB PORT/POWER
The MPLAB REAL ICE in-circuit emulator is connected to the host PC via a Universal 
Serial Bus (USB) port, version 2.0 compliant. The USB connector is located on the 
back of the pod.
The system is capable of reloading the firmware via the USB interface.
System power is derived from the USB interface. The emulator is classified as a high 
power system per the USB specification, and requires 300 mA of power from the USB 
to function in all operational modes (emulator/programmer).

Cable Length – The PC-to-emulator cable length for proper operation has been tested 
for each driver board and is shipped in the emulator kit.
Powered Hubs – If you are going to use a USB hub, make sure it is powered. Also, 
USB ports on PC keyboards do not have enough power for the emulator to operate.

Note: The MPLAB REAL ICE in-circuit emulator is powered through its USB 
connection. The target board is powered from its own supply. The emulator 
cannot provide power to the target board.
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13.4 EMULATOR POD
The emulator pod (DV244005) consists of a main board enclosed in the casing with a 
port for either of two driver boards (for standard or high-speed communication with a 
target). On the emulator enclosure are push buttons, indicator lights (LEDs) and a logic 
probe connector interface.

13.4.1 Main Board
This component has an interface processor (dsPIC DSC), a USB 2.0 interface capable 
of USB speeds of 480 Mb/sec, a Field Programmable Gate Array (FPGA) for general 
system control and increased communication throughput, an SRAM for holding the pro-
gram code image for programming into the emulation device on-board Flash, the 
external trigger logic, user interface push buttons and LED indicators.
The MPLAB REAL ICE in-circuit emulator system supports two types of interfaces to 
the target processor. They consist of the standard driver board and an optional 
high-speed driver board. These boards are inserted into the emulator pod via a card 
guide.
Durability/insertion life cycle of the card guide: 10,000 cycles

13.4.2 Push Buttons
The push buttons have the following significance.

13.4.3 Indicator Lights (LEDs)
The indicator lights have the following significance.

TABLE 13-1: LED INDICATORS

13.4.4 Logic Probe/External Trigger Interface
Probes can be connected to the 14-pin header on the side of the unit for processing 
external signals that are used for triggering external equipment. This header contains 
8 input/output connections that are user selectable as inputs or outputs with logic levels 
that are proportional to the target operating voltage.
The outputs can be used for triggering an external logic analyzer or oscilloscope to 
allow the developer to capture events of interest based on trigger criteria set within 
MPLAB IDE. The external trigger is a pulse of approximately 1.5 s. This value is not 
deterministic and the external tool should be triggered on a pulse edge.
The inputs are part of a trigger bus.

Push Button Related 
LED Description

Reset Status Push to Reset the device.
Function Status Halt – When running, push to put the emulator in the Break or 

halted condition.

Type Color Condition Description

Active Blue Lit Power has been applied or target has been connected.
Status Green Lit The emulator is operating normally – standby.

Red Lit An operation has failed.
Blinking USB Comm error or driver not installed.

Orange Lit The emulator is busy.
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FIGURE 13-1: LOGIC PROBE PINOUT ON EMULATOR

Logic probes may be attached to this connector to give the functionality described in 
Table 13-2. The probes are color coded and labeled for easy identification.

The electrical specifications for logic probes are listed in Table 13-3.

TABLE 13-2: LOGIC PROBE PINOUT DESCRIPTION
Pin I/O Name Function Color

1 O VDD(1) VDD reference Red

2 O NC No connection Gray

3 O NC No connection Gray

4 I TCLK External synchronous clock Gray

5 I/O EXT7(2) External input/output bit 7 White

6 I/O EXT6 External input/output bit 6 White

7 I/O EXT5 External input/output bit 5 White

8 I/O EXT4 External input/output bit 4 White

9 I/O EXT3 External input/output bit 3 White

10 I/O EXT2 External input/output bit 2 White

11 I/O EXT1 External input/output bit 1 White

12 I/O EXT0(2) External input/output bit 0 White

13 Gnd GND System Ground Black

14 Gnd GND System Ground Black

Note 1: Do not connect VDD to the target.
 2: EXT0 and EXT7 are temporarily used during loop-back test. Ensure that they are 

not connected together.

TABLE 13-3: LOGIC PROBE ELECTRICAL SPECIFICATIONS
Logic Inputs VIH = VDD x 0.7V (min)

VIL = VDD x 0.3V (max)

Logic Outputs VDD = 5V VDD = 3V VDD = 2.3V VDD = 1.65V

VOH = 3.8V min VOH = 2.4V min VOH = 1.9V min VOH = 1.2V min

VOL = 0.55V max VOL = 0.55V max VOL = 0.3V max VOL = 0.45V max

1*
2

13
14
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13.5 STANDARD COMMUNICATION HARDWARE
For standard emulator communication with a target (Section 3.4.1 “Standard 
Communication”), use the standard driver board.
To use this type of communication with a debug header, you may need a 
device-specific Extension Pak, which includes an 8-pin connector debug header that 
contains the desired -ICE/-ICD device and a standard adapter board (8-pin to 6-pin 
connection).

For more on available debug headers, see the “Debug Header Specification” in 
“Recommended Reading”.

13.5.1 Standard Driver Board
The standard driver board is the main interface to the target processor. It contains the 
connections to the high voltage (VPP), VDD sense lines, and clock and data connections 
required for programming and connecting with the target devices.
The VPP high-voltage lines can produce a variable voltage that can swing from 14 to 0 
volts to satisfy the voltage requirements for the specific emulation processor. 
The VDD sense connection draws very little current from the target processor. The 
actual power comes from the MPLAB REAL ICE in-circuit emulation system as the VDD 
sense line is used as a reference only to track the target voltage. The VDD connection 
is isolated with an optical switch.
The clock and data connections are interfaces with the following characteristics:
• Clock and data signals are in high-impedance mode (even when no power is 

applied to the MPLAB REAL ICE in-circuit emulator system)
• Clock and data signals are protected from high voltages caused by faulty targets 

systems, or improper connections
• Clock and data signals are protected from high current caused from electrical 

shorts in faulty target systems

FIGURE 13-2: MODULAR CONNECTOR PINOUT OF STANDARD DRIVER 
BOARD

Note: Older debug headers used a 6-pin (RJ-11) connector instead of an 8-pin 
connector, so these headers may be connected directly to the emulator.

Note: When using the standard driver board, the rate for real-time streaming data 
and tracing is limited to 15 MIPS.

1

6

Bottom view of Modular Connector 
Pinout on Std Driver Board

1 6

Front view of Modular Connector 
on Std Driver Board

3 5

2 4

Modular 
Connector Pin

Microcontroller 
Pin

1 Not Used

2 RB6

3 RB7

4 Ground

5 VDD Target

6 VPP
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13.5.2 Modular Cable and Connector
For standard communications, a modular (ICSP) cable connects the emulator and the 
target application. The specifications for this cable and its connectors are listed below.

13.5.2.1 MODULAR CABLE SPECIFICATION

• Manufacturer, Part Number – Microchip Technology, 07-00024
The length for this cable (L) is 6 inches. If you require a longer cable, consider purchas-
ing the Performance Pak. For details see Chapter 14. “High-Speed/LVDS Communi-
cation Hardware”. It is not recommended that you use a modular cable shorter than 
6 inches or you may experience communication problems.

FIGURE 13-3: MODULAR CABLE

13.5.2.2 MODULAR PLUG SPECIFICATION

• Manufacturer, Part Number – AMP Incorporated, 5-554710-3
• Distributor, Part Number – Digi-Key, A9117ND

13.5.2.3 MODULAR CONNECTOR SPECIFICATION

• Manufacturer, Part Number – AMP Incorporated, 555165-1
• Distributor, Part Number – Digi-Key, A9031ND
The following table shows how the modular connector pins on an application 
correspond to the microcontroller pins. This configuration provides full ICD 
functionality.

FIGURE 13-4: MODULAR CONNECTOR PINOUT OF TARGET BOARD

Pin 1

L

Pin 6

Modular 
Connector Pin

Microcontroller 
Pin

6 Not Used

5 RB6

4 RB7

3 Ground

2 VDD Target

1 VPP 1

6

Bottom view of Modular Connector 
Pinout on Target Board

1 6

Front view of Modular Connector 
on Target Board

3 5

42
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13.6 LOOP-BACK TEST BOARD
This board (included with DV244005) can be used to verify that the emulator is 
functioning properly. To use this board:
1. Disconnect the emulator from the target and the PC.
2. Insert the standard driver board if it is not already installed.
3. Plug the loopback test board into the pod’s logic probe connector.
4. Connect the loop-back test board to the standard driver board using the modular 

cable.
5. Reconnect the emulator to the computer.
6. Launch MPLAB X IDE. Ensure that all existing projects are closed.
7. Select Debug>Run Debugger/Programmer Self Test, then, select the specific 

“REAL ICE” you want to test and click OK.
8. Ensure the loopback test board and cable are connected and click Yes to 

continue.
9. View the self test results in the emulator’s Output window.
10. After the emulator passes the self test, disconnect the loopback test board from 

the emulator.
MPLAB IDE will detect and run the complete loop-back test and give you a status 
(PASS/FAIL). The loop-back test board detection works by applying a short pulse on 
EXT0 and detecting it on EXT7 on the logic probe connector (Section 13.4.4 “Logic 
Probe/External Trigger Interface”). Once the board is detected, the emulator applies 
stimulus to the clock/data and VPP lines and reads the sequence back from the logic 
probe connector interface, thus confirming proper signals levels and connectivity down 
to the connector interfaces.

FIGURE 13-5: LOOP-BACK TEST BOARD CONNECTIONS

13.7 TARGET BOARD CONSIDERATIONS
The target board should be powered according to the requirements of the selected 
device (1.6V-5.5V) and the application.

The emulator does sense target power. There is a 10 k load on VDD_TGT.
Depending on the type of emulator-to-target communications used, there will be some 
considerations for target board circuitry:
• Section 3.5.3 “Target Connection Circuitry”
• Section 3.5.4 “Circuits That Will Prevent the Emulator From Functioning”
Additional design considerations may be found in “Development Tools Design 
Advisory” (DS51764).

Emulator
Pod

Standard Driver Board

Loop-Back Test Board

Modular Cable

Logic Probe Connector

Driver Board Slot

Note: The emulator cannot power the target.
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Chapter 14.  High-Speed/LVDS Communication Hardware
14.1 INTRODUCTION
For high-speed/LVDS communication with a target (Section 3.4.2 “High-Speed/LVDS 
Communication (Performance Pak)”), use the Performance Pak (AC244002).
• High-Speed Driver Board
• High-Speed Receiver Board
• LVDS Cables and Target Pinout
To use this type of communication with a debug header, you will need a device-specific 
Extension Pak, which includes an 8-pin connector debug header containing the desired 
ICE/ICD device and a standard adapter board (8-pin to 6-pin connection.)

For more on available debug headers, see the “Processor Extension Pak and Header 
Specification” (DS51292) in “Recommended Reading”.

Note: You will not need the standard adapter board for high-speed communica-
tions. Instead, you will plug the 8-pin connector end of the high-speed 
receiver board directly into the 8-pin connector of the debug header.
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14.2 HIGH-SPEED DRIVER BOARD
The high-speed driver board consists of two separate multi-point LVDS (Low Voltage 
Differential Signaling) transmitters and receivers for clock and data. Multi-point LVDS 
requires 100 ohm terminations at each driver output and receiver input, per the stan-
dard, and multi-point configuration Type-2 receivers are used, as these are intended 
for control signals or where fail-safe provisions are needed. Even though the standard 
allows for any combination of drivers, receivers and/or transceivers of up to 32 on the 
line, only two will be used. The driver board has a port expansion which is controlled 
by an I2C™ interface for sending/receiving status information to/from the emulator. The 
high-speed driver board assembly is inserted into the emulator pod via the card guide.

FIGURE 14-1: MODULAR CONNECTORS PINOUT OF HIGH-SPEED DRIVER 
BOARD 

Note: The driver board can support data rates up to 100 Mbps. However, due to 
device speeds, the actual rate is up to 20 Mbps.
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* Optional - see Section 3.6.2 “SPI Trace Connections 
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Pin Name Function Pin Name Function
1 LVD+ LV Std Data + 5 GND Ground
2 LVD– LV Std Data – 6 LVC– LV Std Clock –
3 LVC+ LV Std Clock + 7 VDD_TGT VDD on target
4 LV_VDD Power 8 VPP_TGT VPP on target

Pin Name Function Pin Name Function
1 DATAEN+ Std Data Enable + 5 USPID– *Serial Data –
2 DATAEN– Std Data Enable – 6 CLKEN– Std Clock Enable –
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14.3 HIGH-SPEED RECEIVER BOARD
A high-speed receiver board assembly is also required when using LVDS connectivity. 
This board is a counterpart to the high-speed driver board assembly in the pod. When 
the driver is active on the pod, the receiver is active in the receiver board. Alternatively, 
when the driver is active on the receiver board, the corresponding receiver is active in 
the driver board, providing transmitting and receiving capability at both ends. The 
receiver board contains an 8-pin, 0.100 inch centers header, and is used to connect to 
the target board or a debug header. The receiver board circuitry may be implemented 
on the target system to avoid using the receiver board.

FIGURE 14-2: MODULAR CONNECTORS PINOUT OF HIGH-SPEED 
RECEIVER BOARD 

FIGURE 14-3: 8-PIN HEADER PINOUT OF HIGH-SPEED RECEIVER BOARD

J3 Pinout

* Optional - see Section 3.6.2 “SPI Trace Connections 
(High-Speed/LVDS Connection)”.
J2 Pinout

Pin Name Function Pin Name Function

1 DATAEN+ Std Data Enable + 5 USPID– *Serial Data –
2 DATAEN– Std Data Enable – 6 CLKEN– Std Clock Enable –
3 CLKEN+ Std Clock Enable + 7 USPIC+ *Serial Clock +
4 USPID+ *Serial Data + 8 USPIC– *Serial Clock –

Pin Name Function Pin Name Function

1 LVD+ LV Std Data + 5 GND Ground
2 LVD– LV Std Data – 6 LVC– LV Std Clock –
3 LVC+ LV Std Clock + 7 VDD_TGT VDD on target
4 LV_VDD Power 8 VPP_TGT VPP on target
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* Optional – see Section 3.6.2 “SPI Trace Connections 
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Pin Name Function Pin Name Function

1 VPP Power 5 ICSPCLK Standard Com Clock
2 VDD_TGT Power on target 6 AUX Auxiliary
3 GND Ground 7 DAT *Trace Data
4 ICSPDAT Standard Com Data 8 CLK *Trace Clock
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FIGURE 14-4: RECEIVER BOARD SCHEMATIC – ICSPDAT

FIGURE 14-5: RECEIVER BOARD SCHEMATIC – ICSPCLK
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FIGURE 14-6: RECEIVER BOARD SCHEMATIC – DAT & CLK

14.4 LVDS CABLES AND TARGET PINOUT
The emulator-to-target cable length for proper operation has been tested for this 
driver/receiver board combination and is shipped in the Performance Pak. The 
recommended length is 3 feet, while the maximum is 10 feet.

FIGURE 14-7: LVDS CABLE

The target board should have the following 8-pin connection pin-out to plug into the 
receiver board.

FIGURE 14-8: 8-PIN HEADER PINOUT AT TARGET
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* Optional – see Section 3.6.2 “SPI Trace Connections 
(High-Speed/LVDS Connection)”.

Pin Name Function Pin Name Function

1 VPP Power 5 ICSPCLK Standard Com Clock
2 VDD_TGT Power on target 6 AUX Auxiliary
3 GND Ground 7 DAT *Trace Data
4 ICSPDAT Standard Com Data 8 CLK *Trace Clock
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 2013-2014 Microchip Technology Inc. DS50002085B-page 121



Emulator User’s Guide for MPLAB X IDE
NOTES:
DS50002085B-page 122  2013-2014 Microchip Technology Inc.



MPLAB® REAL ICE™ IN-CIRCUIT
EMULATOR USER’S GUIDE FOR
MPLAB X IDE

Chapter 15.  Extension Paks and Headers
15.1 INTRODUCTION
Although some devices have on-board debug circuitry to allow you to debug your code, 
you often loose device resources to debugging, i.e., debugging requires the use of two 
I/O lines, plus Vdd, Vss and Vpp, to communicate with the device. Using a debug 
header can free up these resources for your application. Using an emulation header 
gives you the benefits of a debug header plus new and powerful debugging features.

15.2 PROCESSOR EXTENSION PAKS AND DEBUG HEADERS
A debug header is a circuit board that allows an emulator or debugger to debug code 
for a specific device. A special version of the device (-ICE/-ICD) with on-board debug 
circuitry is located on the header. Connectors on the side of the header allow it to con-
nect directly or through an adapter to the debug tool. Connectors on the bottom of the 
header allow it to connect directly or through a transition socket to a target board.
A processor extension pak contains a debug header, adapter board, and stand-offs.
For more on PEPs and Debug Headers, see the Processor Extension Pak and Debug 
Header Specification (DS51292) or the MPLAB X IDE Help Contents.

15.3 EMULATION EXTENSION PAKS AND EMULATION HEADERS
An emulation header is a circuit board that allows an emulator to debug code for a spe-
cific device. A special version of the device (-ME2) with on-board emulation circuitry is 
located on the header. Connectors on the side of the header allow it to connect directly 
or through an adapter to the emulator. Connectors on the bottom of the header allow it 
to connect directly or through a transition socket to a target board.
An Emulation Extension Pak (EEP) contains an emulation header, gold single in-line 
pins, and a trace cable and trace adapter board.
For more on EEPs and Emulation headers, see the MPLAB X IDE Help Contents.
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Chapter 16.  PIC32 PIMs with Trace
16.1 INTRODUCTION
PIC32 Plug-In Modules (PIMs) are small circuit boards that may be used with the var-
ious Microchip development boards to evaluate PIC32 MCU devices. Some PIC32 
PIMs support PIC32 Instruction Trace and have a trace port connector. Current PIMs 
with a trace port connector are shown in Table 16-1 (see the Microchip website for 
up-to-date information). A pin connection diagram is shown in Figure 16-2.

FIGURE 16-1: PIC32 PIM DIAGRAM

TABLE 16-1: PIM DIMENSIONS IN INCHES
PIM # PIM Name Device Length Width Height

MA320001 PIC32MX PIM PIC32MX360F512L 1.55 1.55 0.9

MA320002 PIC32MX USB PIM PIC32MX460F512L 1.55 1.55 0.9

MA320003 PIC32 CAN-USB PIM PIC32MX795F512L 1.55 1.55 0.9
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FIGURE 16-2: PIC32 PIM PIN CONNECTION DIAGRAM
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Chapter 17.  MPLAB REAL ICE Trace Interface Kit
17.1 INTRODUCTION
The MPLAB REAL ICE Trace Interface Kit (AC244006) may be used with selected 
PIC32 MCUs. The kit consists of an adapter board and trace cable. Kit component 
dimensions and a pin connection diagram for the adapter board are shown below.

FIGURE 17-1: ADAPTER BOARD DIAGRAM

FIGURE 17-2: ADAPTER BOARD PIN CONNECTION DIAGRAM

TABLE 17-1: KIT COMPONENT DIMENSIONS IN INCHES
Component Length Width Height

Adapter Board 0.900 0.600 0.6

Cable 12.0 0.5 0.0625
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FIGURE 17-3: TRACE CABLE DIAGRAM

FIGURE 17-4: TRACE INTERFACE CONNECTIONS WITH A PIM

To use the logic probes instead of the trace cable, see Section 3.6.4 “PIC32 
Instruction Trace Connections”.
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Chapter 18.  MPLAB REAL ICE Isolator Unit
18.1 INTRODUCTION
The MPLAB REAL ICE Isolator Unit (AC244005), also known as an optoisolator, is a 
useful accessory to the MPLAB REAL ICE in-circuit emulator system. The isolator 
enables connectivity for AC line and high voltage applications not referenced to ground. 
Typically, these are consumer applications such as light dimmers, vacuum cleaners, 
washing machines, and other types of motor-based systems where the MCU uses a 
non-isolated power supply.

The isolator connects on one end to the Performance Pak high-speed cables. The iso-
lator connects on the other end to the target using an 8-pin, single-line ICSP connector. 
See Figure 18-1.
To use this board:
1. Obtain a Performance Pak (AC244002). This board can only be used with the 

Performance Pak.
2. Use this board instead of the high-speed receiver board. 

See Chapter 14. “High-Speed/LVDS Communication Hardware” for pin-outs.
Because of the complexity and high dynamic voltage range, the isolator currently 
provides MCU technology support only for some devices. 
See online help, “Device and Feature Support” for details.

DANGER

Potential Electrical Hazard.
Do not remove the board enclosure. Depending on your applica-
tion, you could be exposing yourself to dangerous voltage levels.

Note: Isolation does not support trace.
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FIGURE 18-1: HIGH-SPEED EMULATOR SYSTEM USING ISOLATOR UNIT 

18.2 ISOLATOR UNIT DESIGN
The isolator is a bridge where electrically hot signals are passed through transparently 
to the emulator. The ICSP interface signals are magnetically or optically isolated pro-
viding up to 2.5KV equivalent isolation protection. The isolator is housed in its own 
enclosure providing an additional measure of safety.
This unit contains the same circuitry as the high-speed receiver board (see 
Chapter 14. “High-Speed/LVDS Communication Hardware”) plus isolation circuitry 
(see the following schematics).

FIGURE 18-2: ISOLATOR UNIT SCHEMATIC - ICSPDAT
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FIGURE 18-3: ISOLATOR UNIT SCHEMATIC - ICSPCLK

FIGURE 18-4: ISOLATOR UNIT SCHEMATIC - DAT & CLK
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FIGURE 18-5: ISOLATOR UNIT SCHEMATIC - POWER
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FIGURE 18-6: ISOLATOR UNIT SCHEMATIC - VDD, VPP, MCLR

18.3 THIRD PARTY ISOLATOR SUPPORT
If the MPLAB REAL ICE Isolator Unit does not fit your needs, there are several third 
parties which provide isolators that work with Microchip devices, such as Keterex®. See 
the Microchip web site (www.microchip.com) for more details.
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Chapter 19.  MPLAB REAL ICE JTAG Adapter (PIC32)
19.1 INTRODUCTION
The MPLAB REAL ICE JTAG Adapter (AC244007) may be used to provide JTAG com-
munication between the MPLAB REAL ICE in-circuit emulator and a target PIC32 
device. The kit contains a JTAG adapter board, ribbon cable, and an installation sheet.

19.2 JTAG SUPPORT
• The JTAG adapter board is supported on MPLAB X IDE 1.60 and above.
• The JTAG adapter board supports all PIC32 devices.
• Only basic debug features are available when using JTAG: Run, Halt, and Single 

Step. No advanced features are available, i.e., data capture, runtime watches, 
application in/out, DMA reads/writer, RTDM, and instrumented trace.

19.3 SWITCH FROM NON-JTAG TO JTAG HARDWARE
Non-JTAG communication hardware includes:
• Standard/ICSP communication hardware
• High-Speed/LVDS communication hardware (Performance Pak)
• The Performance Pak plus the Isolator Unit
To switch the hardware:
1. While connected to the target using Standard Communications, erase the target 

device. You may need to add “Erase Device Memory Main Project” to a toolbar 
using View>Toolbars>Customize. 

2. Power down the target board.
3. Disconnect the Standard Communications cable from the target, disconnect the 

USB cable from the emulator, and unplug the Standard Driver Board from the 
emulator.

4. Connect one end of the ribbon cable to the connector on the JTAG adapter board 
(it should plug in only one way) and insert the JTAG adapter board into the 
emulator driver board slot.

5. Connect the other end of the ribbon cable to the connector on a target board, 
such as the Microchip Explorer 16 development board. The plug is keyed to fit 
only one way.

6. Connect the USB cable to the emulator and power the target board.

Note: If the target device has been programmed for debug (during a Debug 
Run) using non-JTAG hardware, the target MUST BE ERASED before 
switching from non-JTAG to JTAG.
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To set up MPLAB X IDE for JTAG operation:
1. Select File>Project Properties. In the Project Properties dialog, click on your 

desired configuration, e.g., “Conf: [default]”.
2. Click on the down arrow on the “Supported Plugin Board” drop down box and 

select “JTAG Driver Board”. Click OK to accept the setup.

FIGURE 19-1: JTAG ADAPTER BOARD CONNECTIONS AND SET UP

19.4 SWITCH FROM JTAG TO NON-JTAG HARDWARE
Non-JTAG communication hardware includes:
• Standard/ICSP communication hardware
• High-Speed/LVDS communication hardware (Performance Pak)
• The Performance Pak plus the Isolator Unit
To switch the hardware:
1. Device memory does not need to be erased in this case.

2. Power down the target board.
3. Disconnect the JTAG ribbon cable from the target, disconnect the USB cable 

from the emulator, and unplug the JTAG adapter board from the emulator.
4. Connect one end of the Standard Communications cable to the connector on the 

Standard driver board and insert the board into the emulator driver board slot.
5. Connect the other end of the modular cable to the connector on a target board, 

such as the Microchip Explorer 16 development board.
6. Connect the USB cable to the emulator and power the target board.
To set up MPLAB X IDE for non-JTAG operation:
1. Select File>Project Properties. In the Project Properties dialog, click on your 

desired configuration, e.g., “Conf: [default]”.
2. Click on the down arrow on the “Supported Plugin Board” drop down box and 

select “None”. Click OK to accept the setup.
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Note: The target device DOES NOT NEED TO BE ERASED before switching 
from JTAG to non-JTAG.
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19.5 JTAG ADAPTER SCHEMATICS
The JTAG adapter board schematics are broken into 3 parts as follows.

FIGURE 19-2: JTAG ADAPTER BOARD SCHEMATICS - PART 1
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FIGURE 19-3: JTAG ADAPTER BOARD SCHEMATICS - PART 2
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FIGURE 19-4: JTAG ADAPTER BOARD SCHEMATICS - PART 3
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Chapter 20.  MPLAB REAL ICE Power Monitor
20.1 INTRODUCTION
The MPLAB REAL ICE Power Monitor (AC244008) allows the MPLAB REAL ICE 
In-Circuit Emulator to monitor current and voltage of the target board or device.

20.2 MONITOR AND DEBUG FEATURES
• Monitor current (approximately 1uA-1A with selectable ranges) and voltage 

(1.25V-5.0V)
• Power the target (up to 1A)
• Graph current, voltage and time vs. code execution (PC)
• Additional features planned

20.3 POWER MONITOR SUPPORT
A list of feature support is shown in the following table:

Only basic debugging features are available when using the Power Monitor, e.g., Run, 
Halt, and Single Step. No advanced features are available, e.g., Data Capture, Runtime 
Watches, Application In/Out, or Instrumented Trace.

TABLE 20-1: POWER MONITOR FEATURE SUPPORT
Feature(s)* Required Tool Support Device Support

Power Data Only MPLAB X IDE v1.80 (Firmware) All devices

Power Breakpoints

Power Data with Program 
Counter (PC)

MPLAB X IDE v1.90 (Firmware) 16-bit devices that 
support data captureMPLAB XC16 C Compiler v1.20

* See Section 20.8 “Power Monitor Usage”, for feature details.
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20.4 POWER MONITOR BOARD LAYOUT
The Power Monitor board is laid out as specified below. For details, see 
Section 20.12 “Hardware Specifications”.

FIGURE 20-1: POWER MONITOR BOARD CONNECTIONS

To
Power
Supply

To Logic Probe
Connector on
Emulator

Logic Probe
Pass-Through

To Emulator Card Slot

Modular
(RJ-11)

Connector

CHA CHB

To Target Board

VI VO VI VO

VI = Voltage In
VO = Voltage Out

or Device

CHA = Channel A
CHB = Channel B

D6

D3 D4
DS50002085B-page 142  2013-2014 Microchip Technology Inc.



MPLAB REAL ICE Power Monitor
20.5 HARDWARE SETUP
The Power Monitor kit (AC244008) consists of the power module and an external 
power supply.
1. Power down the target board and disconnect the USB cable from the emulator.
2. Unplug any plugged in driver board from the driver board slot and remove any 

logic probes in the logic probe connector.
3. Plug the Power Monitor board into the emulator driver board slot and logic probe 

connector simultaneously.
4. Plug the Power Monitor power adapter into a wall AC source and then plug the 

barrel end into the Power Monitor board.
5. Reconnect the USB cable to the emulator.
6. Connect to the target board in one of three ways:

a) Modular (ICSP) cable - Measure target board current. This connection is 
shown in Figure 21.

b) Channel A (CHA) wire connection - Measure target board current and/or 
voltage. For details, see Section 20.9 “Alternative Target Power (CHA) 
Hardware and Software Setup”.

c) Channel B (CHB) wire connection - Measure target device current and/or 
voltage. For details, see Section 20.10 “Device Power (CHB) Hardware 
and Software Setup”.

FIGURE 21: POWER MONITOR BOARD CONNECTIONS

FIGURE 22: INTERNAL CONNECTIONS
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20.6 SOFTWARE PLUGIN INSTALLATION
To use the Power Monitor, you must install the Power Monitor plugin. To install the 
plugin, perform steps 1-4 on this page and step 5 on the next.
1. In MPLAB X IDE, select Tools>Plugins and click on the Settings tab.
2. If “Microchip Plugins” is listed and checked under “Active”, proceed to step 5. 

Otherwise, continue to step 3.
3. Click on the Add button. In the “Update Center Customizer” dialog, under 

“Name” enter “Microchip Plugins” and under “URL” enter:
http://ww1.microchip.com/downloads/mplab/X/plugins/updates.xml

4. Click OK. You should now see the Microchip Plugins listed under “Configuration 
of Update Centers”.

FIGURE 23: PLUGIN SETTINGS
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5. Click on the Available Plugins tab, check “Power Monitor” and click Install. 
Follow the wizard dialogs to install the Power Monitor plugin.

FIGURE 24: AVAILABLE PLUGINS
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20.7 SOFTWARE SETUP
Set up basic functions in MPLAB X IDE for using the Power Monitor. Specific mode set 
up will be discussed in Section 20.8 “Power Monitor Usage”.

20.7.1 Power Monitor Selection as Plugin Board
To select the Power Monitor, perform the following actions:
1. Open an MPLAB X IDE project.
2. Select File>Project Properties.
3. Click the down arrow on the “Supported Plugin Board” drop down box and select 

“Power Monitor Board”. Click Apply.

FIGURE 25: PROJECT PROPERTIES - SUPPORTED PLUGIN BOARD

Note: If you receive a message stating that the Power Monitor cannot be 
detected, review your hardware connections.
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20.7.2 Target Board Power Selection
To power the target from Power Monitor, complete the following steps:
1. Click the “Real ICE” category and select the “Power” option category.
2. Check “Power target circuit from REAL ICE”.
3. Specify the target voltage under “Voltage Level”. The levels available are based 

on the project device operating range. The voltage is selectable in 125mV incre-
ments.

4. Click Apply.
During a Debug Run, this configuration (System Power) provides power to the target 
using the standard modular connection. There is a sense resistor in the path that feeds 
the VDD connection to the modular (RJ-11) plug and this is where voltage and current 
is measured. This configuration provides the widest range of current from mA to A to 
be monitored.
Another configuration is discussed under Section 20.10 “Device Power (CHB) 
Hardware and Software Setup”.

FIGURE 26: PROJECT PROPERTIES - REAL ICE POWER
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20.7.3 Power Monitor Selection for Data Collection
To set up the Power Monitor, complete the following steps:
1. Click the “Real ICE” category and select the “Trace and Profiling” option 

category.
2. Under “Data Collection Selection”, select “Power Module (Target Power 

Sampling).

3. Set up the data file to capture data collection information using “Data File Path 
and Name”. Click on the file size option to see more under the “Option 
Description”.

Depending on how you will use the Power Monitor, you will need to select other options. 
See Section 20.8 “Power Monitor Usage”.

FIGURE 27: PROJECT PROPERTIES - REAL ICE TRACE AND PROFILING

Note: When the Power Module is selected, other types of data collection will not 
be available. See Section 20.3 “Power Monitor Support”.

Note: You can increase the file size to collect data for a longer graph; but after 
halting, the display will take longer to render.
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20.8 POWER MONITOR USAGE
The Power Monitor may be used in more than one Power Sampling mode.

20.8.1 Power Data Only
The Power Data Only mode provides power samples consisting of a time stamp, 
voltage, and current.
To select Power Data Only mode, perform the following actions:
1. Click the “Real ICE” category and select the “Trace and Profiling” option 

category.
2. Under “Target Power Sampling Selection”, “Power Data Only” will be selected.
3. Under “Power Measurement”, select “Target Board (1mA - 1A)”. To measure the 

power consumption of only the microcontroller, see Section 20.10 “Device 
Power (CHB) Hardware and Software Setup”.

4. Under “Target Power Sampling Interval (in microseconds)”, enter a value.
5. Click OK.

FIGURE 20-1: POWER DATA ONLY
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20.8.2 Power Data with Program Counter (PC)
The Power Data with PC mode provides power samples on an update of the project’s 
functions, consisting of a time stamp, voltage, and current.
To select Power Data with PC mode:
1. Click the “Real ICE” category and select the “Trace and Profiling” option 

category.
2. Under “Target Power Sampling Selection”, select “Power Data on PC Update 

Only” from the list.
3. Under “Power Measurement”, select “Target Board (1mA - 1A)”. To measure the 

power consumption of only the microcontroller, see Section 20.10 “Device 
Power (CHB) Hardware and Software Setup”.

4. Under “Target Power Sampling Interval (in microseconds)”, enter a value.
5. Under “How/When PC is to be Provided”, select “At Function Entry and Exit”.
6. Click OK.

FIGURE 20-2: POWER DATA WITH PC
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20.8.3 Power Breakpoints
Independent of the Power Data mode, you can set power breakpoints. To set power 
breakpoints, complete the following steps:
1. Click the “Real ICE” category and select the “Trace and Profiling” option 

category.
2. Check “Break At or Above Specified Power Level”. 

Note: This item will look grayed out until you click the checkbox.
3. Enter a power level under “Break Power Level (in milliamps)”.

FIGURE 20-3: POWER BREAKPOINTS

20.8.4 Power Data Collection
To observe Power Data, perform the following actions:
1. Select Tools>Embedded>Power Monitor to open the Power Monitor window.

2. Debug Run your project (Debug>Debug Project).
3. Halt the project by either using Pause, a breakpoint or a power breakpoint (see 

Section 20.8.3 “Power Breakpoints”.)
4. View Power Data in the Power Monitor window. See Section 20.8.6 “Power 

Monitor Views”.

20.8.5 Troubleshooting Data Collection
If you encounter problems while using the power monitor, consider the following:

The power monitor must be plugged into two ports of the MPLAB REAL ICE in-cir-
cuit emulator: the driver board slot and the logic probe connector. Ensure that the 
power monitor is securely plugged into both these ports, even if the power light is 
on.

Note: The Power Monitor window must be open before a debug session. You 
cannot begin debug and then open the Power Monitor window.
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20.8.6 Power Monitor Views
Depending on the type of power data you wish to capture, you will see different views.

FIGURE 20-4: POWER MONITOR WINDOW - POWER DATA ONLY

FIGURE 21: POWER MONITOR WINDOW - POWER DATA WITH PC
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20.9 ALTERNATIVE TARGET POWER (CHA) HARDWARE AND SOFTWARE 
SETUP

This Target Power configuration may be used to measure voltage as well as current on 
the target board.

20.9.1 Hardware Setup
Connecting the Channel A (CHA), Voltage Out (VO) terminal, to the target board pro-
vides the same current information as the modular connection. The modular cable still 
needs to be connected to provide communication to the emulator.
The VO connection is simply the VDD connection after the sense resistor. It must con-
nect to the device VDD connection to complete the circuit and allow measurements to 
be made. In this configuration, the modular cable VDD connection must not be con-
nected on the target, i.e., the device or target section must be isolated from rest of the 
target board.
Connecting the Channel A (CHA), Voltage In (VI) terminal, to the target power supply 
section allows voltage measurements to be made.

FIGURE 22: POWER MONITOR BOARD CHA CONNECTIONS

FIGURE 23: CHA INTERNAL CONNECTIONS
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20.9.2 Software Setup - Power
In this configuration, you can continue powering the target from the emulator or you can 
power the target board independently.
To set the target power source:
1. Click on the “Real ICE” category and select the “Power” option category.
2. Locate the checkbox “Power target circuit from REAL ICE”. Check to power the 

target from the emulator. Uncheck to power the target with its own power supply.
3. Click Apply.

20.10 DEVICE POWER (CHB) HARDWARE AND SOFTWARE SETUP
The Device Power configuration is used in cases where only the microcontroller or a 
section of the target application is desired to be monitored.

20.10.1 Hardware Setup
Connecting the Channel B (CHB), Voltage Out (VO) terminal, to the device or target 
section allows small current measurements can be made, typically in the uA to a few 
mA range. The modular cable still needs to be connected to provide communication to 
the emulator.
Connecting the Channel B (CHB), Voltage In (VI) terminal, to the target power supply 
section allows voltage measurements to be made.

FIGURE 24: POWER MONITOR BOARD CHB CONNECTIONS
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FIGURE 25: CHB INTERNAL CONNECTIONS

20.10.2 Software Setup - Power
In this configuration, you can continue powering the target from the emulator or you can 
power the target board independently.
To set the target power source:
1. Click on the “Real ICE” category and select the “Power” option category.
2. Locate the checkbox “Power target circuit from REAL ICE”. Check to power the 

target from the emulator. Uncheck to power the target with its own power supply.
3. Click Apply.

20.10.3 Power Monitor Usage
Independent of what power data mode you are using, you will need to change the type 
of power measurement:
1. Click on the “Real ICE” category and select the “Trace and Profiling” option 

category.
2. Under “Power Measurement”, select “Processor Only (1uA - 9mA)”.
3. Click OK.

FIGURE 20-1: PROCESSOR ONLY
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20.11 POWER MONITOR WINDOW CONTROLS
The graphical data can be viewed in the Power Monitor window and is tabulated based 
on the open project. Select Tools>Embedded>Power Monitor to open the Power 
Monitor window.

20.11.1 Window Usage
To use the Power Monitor window:
• Control whether current and/or voltage is displayed by using the “A” and “V” but-

tons to the left of the graph. Display the data in logarithmic form by using the “log” 
button.

• Enable zoom by clicking the magnifying glass button or selecting “Turn on Zoom 
Mode” from the context menu. 
Zoom in on a section of graph by clicking-and-dragging from the top left to the 
bottom right of a region.

• Alternately, you can zoom by placing the mouse pointer over a point on the graph 
and using the mouse wheel to zoom into this location. (You do not need to have 
zoom enabled to do this.)

• Double click on a point in the graph to see the vertical green cursor and move to 
the row in the table below that corresponds to that point on the graph.

• For zoom-disabled (toggle the magnifying glass button or “Turn on Zoom Mode” 
from the context menu). 
You may select a range of values by clicking-and-dragging from the top left to the 
bottom right of a region on the graph.

• Move to either maximum or minimum current values by selecting these under “Go 
to” in the context menu.

• See the next two sections for additional controls.

20.11.2 Window Controls
Control the contents of the tab by using the buttons to the left of the graph or controls 
on the bottom of the window. To view data, you will at least need the display on (“on” 
button recessed) and voltage (“V” button recessed) and/or current (“A” button 
recessed) selected. 
TABLE 20-2: POWER MONITOR WINDOW - BUTTONS

Button Description

Click to display the Project Properties window for the active project tab in the 
window.

Click to turn power monitoring capture on (“on” button recessed).
Click again to turn power monitoring capture off (“off” button flat).

Click to display current values in the graph (“A” button recessed).
Click again to hide current values (“A” button flat).

Click to display voltage values in the graph (“V” button recessed).
Click again to hide voltage values (“V” button flat).

Click to view the current on a logarithmic scale (“log” button recessed).
Click again to view current on a standard scale (“log” button flat”).

Click to clear the display of data.

Click to reset the time stamp on the next run (button is recessed).
After a Pause or Halt, the button will pop up (button is flat).

Click to enable zoom mode (“zoom” button is recessed).
Click again to disabled zoom mode (“zoom” button is flat).
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20.11.3 Window Menu
From the graph, right click to see the context menu for further options.

TABLE 20-3: POWER MONITOR WINDOW - OTHER CONTROLS
Control Description

Pan Graph If all the data is not displayed on the visible graph, you can pan through the data 
using this slider. You may need to zoom to pan.

Reset 
Zoom

Click to reset the zoom to the default.

TABLE 20-4: POWER MONITOR WINDOW MENU
Item Description

Turn On 
Zoom Mode

Click to enable zoom mode.
Click again to disabled zoom mode.

Export CSV 
File

Save data as comma-delimited (comma separated values).

Save Graph 
Image

Save as an image file the current view of the graph.

Print Print the current view of the graph.

Zoom In Zoom in on the X axis, the Y axis or both axis.
To zoom in a region of the graph, drag the mouse from top left corner to the bot-
tom right corner and release the mouse. Any other directions will have no effect.

Zoom Out Zoom out on the X axis, the Y axis or both axis.

Reset 
Zoom

Reset zoom level to the default.

Go to Select to go to the maximum current value or minimum current value.
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20.12 HARDWARE SPECIFICATIONS

20.12.1 External Power Supply
The Power Monitor external supply (AC002014) is 9V nominal DC, Universal wall 
mount.
The external power supply provides power to the power monitor internal logic and other 
functional blocks. The power monitor includes two fixed regulators 5V and 3.3V for its 
internal logic.
The power delivered to the target application comes directly from the external supply. 
The voltage gets regulated and set to a programmable range from about 1.25V to 5V 
with the MPLAB X IDE Tool Options for configuration the REAL ICE emulator. The volt-
age is selectable in 125mv increments.

20.12.2 Terminal Blocks
There are two terminal blocks that can be used for either the Alternate Target Power or 
Device Power configuration: CHA and CHB. One side of the block is for Voltage In (VI) 
and other side is for Voltage Out (VO).

20.12.3 Power Monitor Indicators
The Power Monitor board has three indicator lights

TABLE 20-5: POWER MONITOR INDICATOR LIGHTS

20.12.4 Logic Probe/External Trigger Interface 
The logic port on the Power Monitor is a pass-through of the logic port on the emulator.
Probes can be connected to the 14-pin header on the side of the unit for processing 
external signals that are used for triggering external equipment. This header contains 
8 input/output connections that are user selectable as inputs or outputs with logic levels 
that are proportional to the target operating voltage. 
The outputs can be used for triggering an external logic analyzer or oscilloscope to 
allow the developer to capture events of interest based on trigger criteria set within 
MPLAB IDE. The external trigger is a pulse of approximately 1.5s. This value is not 
deterministic and the external tool should be triggered on a pulse edge. 
The inputs are part of a trigger bus.

FIGURE 21: LOGIC PROBE PINOUT ON EMULATOR

Light Color Description

Active (D6) Blue Power monitor system ready/active
Idle (D3) Yellow System on standby - no power applied to target
Ready (D4) Green Power enabled to target

1*
2

13
14
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Logic probes may be attached to this connector to give the functionality described in 
Table 20-6. The probes are color coded and labeled for easy identification.

The electrical specifications for logic probes are listed in Table 20-7.

TABLE 20-6: LOGIC PROBE PINOUT DESCRIPTION
Pin I/O Name Function Color

1 O VDD(1) VDD reference Red

2 O NC No connection Gray

3 O NC No connection Gray

4 I TCLK External synchronous clock Gray

5 I/O EXT7(2) External input/output bit 7 White

6 I/O EXT6 External input/output bit 6 White

7 I/O EXT5 External input/output bit 5 White

8 I/O EXT4 External input/output bit 4 White

9 I/O EXT3 External input/output bit 3 White

10 I/O EXT2 External input/output bit 2 White

11 I/O EXT1 External input/output bit 1 White

12 I/O EXT0(2) External input/output bit 0 White

13 Gnd GND System Ground Black

14 Gnd GND System Ground Black

Note 1: Do not connect VDD to the target.
 2: EXT0 and EXT7 are temporarily used during loop-back test. Ensure that they are 

not connected together.

TABLE 20-7: LOGIC PROBE ELECTRICAL SPECIFICATIONS
Logic Inputs VIH = VDD x 0.7V (min)

VIL = VDD x 0.3V (max)

Logic Outputs VDD = 5V VDD = 3V VDD = 2.3V VDD = 1.65V

VOH = 3.8V min VOH = 2.4V min VOH = 1.9V min VOH = 1.2V min

VOL = 0.55V max VOL = 0.55V max VOL = 0.3V max VOL = 0.45V max
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20.12.5 Communication with the Target
The Power Monitor board contains the connections to the high voltage (Vpp), Vdd 
sense lines, and clock and data connections required for programming and connecting 
with the target devices.
The Vpp high-voltage lines from MPLAB REAL ICE in-circuit emulator can produce a 
variable voltage that can swing from 14 to 0 volts to satisfy the voltage requirements for 
the specific emulation processor.
The Vdd sense line on MPLAB REAL ICE in-circuit emulator is used as a reference only 
to track the target or external voltage. The Vdd connection on the emulator is isolated 
with an optical switch. 
The clock and data connections are interfaces with the following characteristics: 
• Clock and data signals are in high-impedance mode (even when no power is 

applied to the emulator system).
• Clock and data signals are protected from high voltages caused by faulty targets 

systems or improper connections.
• Clock and data signals are protected from high current caused from electrical 

shorts in faulty target systems.
The Power Monitor uses the streaming capabilities of emulator; therefore no other data 
streaming is possible when the power monitor is configured.

FIGURE 22: MODULAR CONNECTOR PINOUT ON BOARD

FIGURE 23: MODULAR CONNECTOR PINOUT OF TARGET BOARD

1

6

Bottom view of Modular 
Connector Pinout on Power 
Monitor Board

1 6

Front view of Modular 
Connector on Power Mon-
itor Board

3 5

2 4

Modular 
Connector Pin

Microcontroller 
Pin

1 Not Used
2 RB6
3 RB7
4 Ground
5 VDD Target
6 VPP

Modular 
Connector Pin

Microcontroller 
Pin

6 Not Used
5 RB6
4 RB7
3 Ground
2 VDD Target
1 VPP

1

6

Bottom view of Modular 
Connector Pinout on Target 
Board

1 6

Front view of Modular 
Connector on Target 
Board

3 5
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Appendix A. Revision History
Revision A (January 2013)
• Initial release of this document.
Revision B (May 2014)
• Any MPLAB IDE v8 links or references fixed or removed.
• Warning boxes updated throughout to match updated standards.
• Preface “Recommended Reading” split into two parts, Emulator and Accessory, 

and updated for new documents.
• Chapter 2. “Device and Feature Support” - Table data can be ported to DTS.
• Section 3.2 “Tools Comparison” - Comparison table updated.
• Section 3.3 “Operational Overview” - Tables updated to clarify speed.
• Section 3.5.3 “Target Connection Circuitry” - Pull-up value changed.
• Section 3.6.3 “I/O Port Trace Connections” - Added allowable PORTx configu-

rations.
• Section 4.3 “Firmware Upgrades” - Section added.
• Section 4.4 “Emulator Functions” - Replaces previous sections 4.3 and 4.4.
• Section 5.4.2 “Hardware or Software Breakpoint Selection” - Table updated.
• Section 5.5 “Instrumented Trace” - Instrumented trace supported for all families 

for many devices. Place holders still left in Specific Debug Functions chapters.
• Section 6.2 “Data Capture and Runtime Watches” and Section 7.2 “Data 

Capture and Runtime Watches”- Data capture and runtime watches defined. 
Watch variables need to be native sized.

• Remove clock requirement from runtime watches: Section 6.2.2 “Runtime 
Watches and the Watches Window” and Section 7.2 “Data Capture and 
Runtime Watches”.

• Section 6.4 “Jump Trace” and Section 6.6 “Function Level Profiling” added.
• Chapter 7. “Specific Debug Functions: 32-Bit Devices” - Updated PIC32MX to 

PIC32 to include all 32-bit devices.
• Section 7.3.3 “Setting Up and Using Trace” - Diagrams added.
• Chapter 8. “Troubleshooting First Steps” and Chapter 9. “Frequently Asked 

Questions (FAQ)” updated.
• Part 4 – “Software & Hardware Reference” - “Reference” section name 

changed to “Software & Hardware Reference”.
• Part 5 – “Emulator Accessories” - “Emulator Accessories” chapter removed 

from “Reference” section to create chapter in this part. Accessory chapters added 
for available emulator accessories.
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Support
INTRODUCTION
Please refer to the items discussed here for support issues.
• Warranty Registration
• myMicrochip Personalized Notification Service
• The Microchip Web Site
• Microchip Forums
• Customer Support
• About Microchip Technology

WARRANTY REGISTRATION
Registering your development tool entitles you to receive new product updates. Interim 
software releases are available at the Microchip web site:
http://www.microchipdirect.com

myMICROCHIP PERSONALIZED NOTIFICATION SERVICE
Microchip's personal notification service helps keep customers current on their Micro-
chip products of interest. Subscribers will receive e-mail notification whenever there are 
changes, updates, revisions or errata related to a specified product family or develop-
ment tool.
Please visit http://www.microchip.com/pcn to begin the registration process and select 
your preferences to receive personalized notifications. A FAQ and registration details 
are available on the page, which can be opened by selecting the link above.
When you are selecting your preferences, choosing “Development Systems” will pop-
ulate the list with available development tools. The main categories of tools are listed 
below:
• Compilers – The latest information on Microchip C compilers, assemblers, linkers 

and other language tools. These include all MPLAB C compilers; all MPLAB 
assemblers (including MPASM™ assembler); all MPLAB linkers (including 
MPLINK™ object linker); and all MPLAB librarians (including MPLIB™ object 
librarian).

• Emulators – The latest information on Microchip in-circuit emulators.This 
includes the MPLAB REAL ICE™ in-circuit emulator.

• In-Circuit Debuggers – The latest information on Microchip in-circuit debuggers. 
These include the PICkit™ 2, PICkit 3 and MPLAB ICD 3 in-circuit debuggers.

• MPLAB® IDE – The latest information on Microchip MPLAB IDE, the Windows® 
Integrated Development Environment for development systems tools. This list is 
focused on the MPLAB IDE, MPLAB IDE Project Manager, MPLAB Editor and 
MPLAB SIM simulator, as well as general editing and debugging features.
 2013-2014 Microchip Technology Inc. DS50002085B-page 163

http://www.microchipdirect.com/


Emulator User’s Guide for MPLAB X IDE
• Programmers – The latest information on Microchip programmers. These include 
the device (production) programmers MPLAB REAL ICE In-Circuit Emulator, 
MPLAB ICD 3 In-Circuit Debugger, MPLAB PM3 and development (non-produc-
tion) programmers PICkit 2 and 3.

• Starter/Demo Boards – These include MPLAB Starter Kit boards, PICDEM demo 
boards, and various other evaluation boards.

THE MICROCHIP WEB SITE
Microchip provides online support via our web site at http://www.microchip.com. This 
web site is used as a means to make files and information easily available to 
customers. Accessible by using your favorite Internet browser, the web site contains 
the following information:
• Product Support – Data sheets and errata, application notes and sample 

programs, design resources, user’s guides and hardware support documents, 
latest software releases and archived software

• General Technical Support – Frequently Asked Questions (FAQs), technical 
support requests, online discussion groups, Microchip consultant program 
member listing

• Business of Microchip – Product selector and ordering guides, latest Microchip 
press releases, listing of seminars and events, listings of Microchip sales offices, 
distributors and factory representatives

MICROCHIP FORUMS
Microchip provides additional online support by way of our web forums at 
http://www.microchip.com/forums. Forums that are currently available include the 
following subjects:
• Development Tools
• 8-bit PIC MCUs
• 16-bit PIC MCUs
• 32-bit PIC MCUs

CUSTOMER SUPPORT
Users of Microchip products can receive assistance through several channels:
• Distributor or Representative
• Local Sales Office
• Field Application Engineer (FAE)
• Technical Support
Customers should contact their distributor, representative or field application engineer 
(FAE) for support. Local sales offices are also available to help customers. A listing of 
sales offices and locations is included in the back of this document. See our web site 
for a complete, up-to-date listing of sales offices.
Technical support is available through the web site at http://support.microchip.com.
Documentation errors or comments may be emailed to docerrors@microchip.com.
DS50002085B-page 164  2013-2014 Microchip Technology Inc.



Support
ABOUT MICROCHIP TECHNOLOGY
Microchip Technology Inc. is a leading provider of microcontroller and analog semicon-
ductors, providing low-risk product development, lower total system cost and faster 
time to market for thousands of diverse customer applications worldwide. Headquar-
tered in Chandler, Arizona, Microchip offers outstanding technical support along with 
dependable delivery and quality.
Voice: (480) 792-7200
Fax: (480) 792-7277
myMicrochip: http://www.microchip.com/pcn
Web site: http://www.microchip.com
Forums: http://www.microchip.com/forums
Support: http://support.microchip.com
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Glossary
A
Absolute Section
A GCC compiler section with a fixed (absolute) address that cannot be changed by the 
linker.
Absolute Variable/Function
A variable or function placed at an absolute address using the OCG compiler’s @ 
address syntax.
Access Memory
PIC18 Only – Special registers on PIC18 devices that allow access regardless of the 
setting of the Bank Select Register (BSR).
Access Entry Points
Access entry points provide a way to transfer control across segments to a function 
which may not be defined at link time. They support the separate linking of boot and 
secure application segments.
Address
Value that identifies a location in memory.
Alphabetic Character
Alphabetic characters are those characters that are letters of the Roman alphabet 
(a, b, …, z, A, B, …, Z).
Alphanumeric
Alphanumeric characters are comprised of alphabetic characters and decimal digits 
(0,1, …, 9).
ANDed Breakpoints
Set up an ANDed condition for breaking, i.e., breakpoint 1 AND breakpoint 2 must 
occur at the same time before a program halt. This can only be accomplished if a data 
breakpoint and a program memory breakpoint occur at the same time.
Anonymous Structure
16-bit C Compiler – An unnamed structure.
PIC18 C Compiler – An unnamed structure that is a member of a C union. The 
members of an anonymous structure may be accessed as if they were members of the 
enclosing union. For example, in the following code, hi and lo are members of an 
anonymous structure inside the union caster.
union castaway
 int intval;
 struct {
  char lo; //accessible as caster.lo
  char hi; //accessible as caster.hi
 };
} caster;
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ANSI
American National Standards Institute is an organization responsible for formulating 
and approving standards in the United States.
Application
A set of software and hardware that may be controlled by a PIC® microcontroller.
Archive/Archiver
An archive/library is a collection of relocatable object modules. It is created by 
assembling multiple source files to object files, and then using the archiver/librarian to 
combine the object files into one archive/library file. An archive/library can be linked 
with object modules and other archives/libraries to create executable code.
ASCII
American Standard Code for Information Interchange is a character set encoding that 
uses 7 binary digits to represent each character. It includes upper and lower case 
letters, digits, symbols and control characters.
Assembly/Assembler
Assembly is a programming language that describes binary machine code in a 
symbolic form. An assembler is a language tool that translates assembly language 
source code into machine code.
Assigned Section
A GCC compiler section which has been assigned to a target memory block in the linker 
command file.
Asynchronously
Multiple events that do not occur at the same time. This is generally used to refer to 
interrupts that may occur at any time during processor execution.
Asynchronous Stimulus 
Data generated to simulate external inputs to a simulator device.
Attribute
GCC Characteristics of variables or functions in a C program which are used to 
describe machine-specific properties.
Attribute, Section
GCC Characteristics of sections, such as “executable”, “readonly”, or “data” that can 
be specified as flags in the assembler .section directive.

B
Binary
The base two numbering system that uses the digits 0-1. The rightmost digit counts 
ones, the next counts multiples of 2, then 22 = 4, etc.
Bookmarks
Use bookmarks to easily locate specific lines in a file.
Select Toggle Bookmarks on the Editor toolbar to add/remove bookmarks. Click other 
icons on this toolbar to move to the next or previous bookmark.
Breakpoint
Hardware Breakpoint: An event whose execution will cause a halt.
Software Breakpoint: An address where execution of the firmware will halt. Usually 
achieved by a special break instruction.
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Build
Compile and link all the source files for an application.

C
C\C++
C is a general-purpose programming language which features economy of expression, 
modern control flow and data structures, and a rich set of operators. C++ is the 
object-oriented version of C.
Calibration Memory
A special function register or registers used to hold values for calibration of a PIC 
microcontroller on-board RC oscillator or other device peripherals.
Central Processing Unit
The part of a device that is responsible for fetching the correct instruction for execution, 
decoding that instruction, and then executing that instruction. When necessary, it works 
in conjunction with the arithmetic logic unit (ALU) to complete the execution of the 
instruction. It controls the program memory address bus, the data memory address 
bus, and accesses to the stack.
Clean
Clean removes all intermediary project files, such as object, hex and debug files, for 
the active project. These files are recreated from other files when a project is built.
COFF
Common Object File Format. An object file of this format contains machine code, 
debugging and other information.
Command Line Interface
A means of communication between a program and its user based solely on textual 
input and output.
Compiled Stack
A region of memory managed by the compiler in which variables are statically allocated 
space. It replaces a software or hardware stack when such mechanisms cannot be 
efficiently implemented on the target device.
Compiler
A program that translates a source file written in a high-level language into machine 
code.
Conditional Assembly
Assembly language code that is included or omitted based on the assembly-time value 
of a specified expression.
Conditional Compilation
The act of compiling a program fragment only if a certain constant expression, specified 
by a preprocessor directive, is true.
Configuration Bits
Special-purpose bits programmed to set PIC microcontroller modes of operation. A 
Configuration bit may or may not be preprogrammed.
Control Directives
Directives in assembly language code that cause code to be included or omitted based 
on the assembly-time value of a specified expression.
CPU
See Central Processing Unit.
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Cross Reference File
A file that references a table of symbols and a list of files that references the symbol. If 
the symbol is defined, the first file listed is the location of the definition. The remaining 
files contain references to the symbol.

D
Data Directives
Data directives are those that control the assembler’s allocation of program or data 
memory and provide a way to refer to data items symbolically; that is, by meaningful 
names.
Data Memory
On Microchip MCU and DSC devices, data memory (RAM) is comprised of General 
Purpose Registers (GPRs) and Special Function Registers (SFRs). Some devices also 
have EEPROM data memory.
Data Monitor and Control Interface (DMCI)
The Data Monitor and Control Interface, or DMCI, is a tool in MPLAB X IDE. The 
interface provides dynamic input control of application variables in projects. 
Application-generated data can be viewed graphically using any of 4 
dynamically-assignable graph windows.
Debug/Debugger
See ICE/ICD.
Debugging Information
Compiler and assembler options that, when selected, provide varying degrees of 
information used to debug application code. See compiler or assembler documentation 
for details on selecting debug options.
Deprecated Features
Features that are still supported for legacy reasons, but will eventually be phased out 
and no longer used.
Device Programmer
A tool used to program electrically programmable semiconductor devices such as 
microcontrollers.
Digital Signal Controller
A A digital signal controller (DSC) is a microcontroller device with digital signal 
processing capability, i.e., Microchip dsPIC DSC devices.
Digital Signal Processing\Digital Signal Processor
Digital signal processing (DSP) is the computer manipulation of digital signals, 
commonly analog signals (sound or image) which have been converted to digital form 
(sampled). A digital signal processor is a microprocessor that is designed for use in 
digital signal processing.
Directives
Statements in source code that provide control of the language tool’s operation.
Download
Download is the process of sending data from a host to another device, such as an 
emulator, programmer or target board.
DWARF
Debug With Arbitrary Record Format. DWARF is a debug information format for ELF 
files.
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E
EEPROM
Electrically Erasable Programmable Read Only Memory. A special type of PROM that 
can be erased electrically. Data is written or erased one byte at a time. EEPROM 
retains its contents even when power is turned off.
ELF
Executable and Linking Format. An object file of this format contains machine code. 
Debugging and other information is specified in with DWARF. ELF/DWARF provide 
better debugging of optimized code than COFF.
Emulation/Emulator
See ICE/ICD.
Endianness
The ordering of bytes in a multi-byte object.
Environment
MPLAB PM3 – A folder containing files on how to program a device. This folder can be 
transferred to a SD/MMC card.
Epilogue
A portion of compiler-generated code that is responsible for deallocating stack space, 
restoring registers and performing any other machine-specific requirement specified in 
the runtime model. This code executes after any user code for a given function, 
immediately prior to the function return.
EPROM
Erasable Programmable Read Only Memory. A programmable read-only memory that 
can be erased usually by exposure to ultraviolet radiation.
Error/Error File
An error reports a problem that makes it impossible to continue processing your 
program. When possible, an error identifies the source file name and line number 
where the problem is apparent. An error file contains error messages and diagnostics 
generated by a language tool.
Event
A description of a bus cycle which may include address, data, pass count, external 
input, cycle type (fetch, R/W), and time stamp. Events are used to describe triggers, 
breakpoints and interrupts.
Executable Code
Software that is ready to be loaded for execution.
Export
Send data out of the MPLAB IDE/MPLAB X IDE in a standardized format.
Expressions
Combinations of constants and/or symbols separated by arithmetic or logical 
operators.
Extended Microcontroller Mode
In extended microcontroller mode, on-chip program memory as well as external 
memory is available. Execution automatically switches to external if the program 
memory address is greater than the internal memory space of the PIC18 device.
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Extended Mode (PIC18 MCUs)
In Extended mode, the compiler will utilize the extended instructions (i.e., ADDFSR, 
ADDULNK, CALLW, MOVSF, MOVSS, PUSHL, SUBFSR and SUBULNK) and the indexed 
with literal offset addressing.
External Label
A label that has external linkage.
External Linkage
A function or variable has external linkage if it can be referenced from outside the 
module in which it is defined.
External Symbol
A symbol for an identifier which has external linkage. This may be a reference or a 
definition.
External Symbol Resolution
A process performed by the linker in which external symbol definitions from all input 
modules are collected in an attempt to resolve all external symbol references. Any 
external symbol references which do not have a corresponding definition cause a linker 
error to be reported.
External Input Line
An external input signal logic probe line (TRIGIN) for setting an event based upon 
external signals.
External RAM
Off-chip Read/Write memory.

F
Fatal Error
An error that will halt compilation immediately. No further messages will be produced.
File Registers
On-chip data memory, including General Purpose Registers (GPRs) and Special 
Function Registers (SFRs).
Filter
Determine by selection what data is included/excluded in a trace display or data file.
Fixup
The process of replacing object file symbolic references with absolute addresses after 
relocation by the linker.
Flash
A type of EEPROM where data is written or erased in blocks instead of bytes.
FNOP
Forced No Operation. A forced NOP cycle is the second cycle of a two-cycle 
instruction. Since the PIC microcontroller architecture is pipelined, it prefetches the 
next instruction in the physical address space while it is executing the current 
instruction. However, if the current instruction changes the program counter, this 
prefetched instruction is explicitly ignored, causing a forced NOP cycle.
Frame Pointer
A pointer that references the location on the stack that separates the stack-based 
arguments from the stack-based local variables. Provides a convenient base from 
which to access local variables and other values for the current function.
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Free-Standing
An implementation that accepts any strictly conforming program that does not use 
complex types and in which the use of the features specified in the library clause (ANSI 
‘89 standard clause 7) is confined to the contents of the standard headers <float.h>, 
<iso646.h>, <limits.h>, <stdarg.h>, <stdbool.h>, <stddef.h> and 
<stdint.h>.

G
GPR
General Purpose Register. The portion of device data memory (RAM) available for 
general use.

H
Halt
A stop of program execution. Executing Halt is the same as stopping at a breakpoint.
Heap
An area of memory used for dynamic memory allocation where blocks of memory are 
allocated and freed in an arbitrary order determined at runtime.
Hex Code\Hex File
Hex code is executable instructions stored in a hexadecimal format code. Hex code is 
contained in a hex file.
Hexadecimal
The base 16 numbering system that uses the digits 0-9 plus the letters A-F (or a-f). The 
digits A-F represent hexadecimal digits with values of (decimal) 10 to 15. The rightmost 
digit counts ones, the next counts multiples of 16, then 162 = 256, etc.
High Level Language
A language for writing programs that is further removed from the processor than 
assembly.

I
ICE/ICD
In-Circuit Emulator/In-Circuit Debugger: A hardware tool that debugs and programs a 
target device. An emulator has more features than an debugger, such as trace.
In-Circuit Emulation/In-Circuit Debug: The act of emulating or debugging with an 
in-circuit emulator or debugger.
-ICE/-ICD: A device (MCU or DSC) with on-board in-circuit emulation or debug circuitry. 
This device is always mounted on a header board and used to debug with an in-circuit 
emulator or debugger.
ICSP
In-Circuit Serial Programming. A method of programming Microchip embedded 
devices using serial communication and a minimum number of device pins.
IDE
Integrated Development Environment, as in MPLAB IDE/MPLAB X IDE.
Identifier
A function or variable name.
IEEE
Institute of Electrical and Electronics Engineers.
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Import
Bring data into the MPLAB IDE/MPLAB X IDE from an outside source, such as from a 
hex file.
Initialized Data
Data which is defined with an initial value. In C,
int myVar=5;

defines a variable which will reside in an initialized data section.
Instruction Set
The collection of machine language instructions that a particular processor 
understands.
Instructions
A sequence of bits that tells a central processing unit to perform a particular operation 
and can contain data to be used in the operation.
Internal Linkage
A function or variable has internal linkage if it can not be accessed from outside the 
module in which it is defined.
International Organization for Standardization
An organization that sets standards in many businesses and technologies, including 
computing and communications. Also known as ISO.
Interrupt
A signal to the CPU that suspends the execution of a running application and transfers 
control to an Interrupt Service Routine (ISR) so that the event may be processed. Upon 
completion of the ISR, normal execution of the application resumes.
Interrupt Handler
A routine that processes special code when an interrupt occurs.
Interrupt Service Request (IRQ)
An event which causes the processor to temporarily suspend normal instruction 
execution and to start executing an interrupt handler routine. Some processors have 
several interrupt request events allowing different priority interrupts.
Interrupt Service Routine (ISR)
Language tools – A function that handles an interrupt.
MPLAB IDE/MPLAB X IDE – User-generated code that is entered when an interrupt 
occurs. The location of the code in program memory will usually depend on the type of 
interrupt that has occurred.
Interrupt Vector
Address of an interrupt service routine or interrupt handler.

L
L-value
An expression that refers to an object that can be examined and/or modified. An l-value 
expression is used on the left-hand side of an assignment.
Latency
The time between an event and its response.
Library/Librarian
See Archive/Archiver.
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Linker
A language tool that combines object files and libraries to create executable code, 
resolving references from one module to another.
Linker Script Files
Linker script files are the command files of a linker. They define linker options and 
describe available memory on the target platform.
Listing Directives
Listing directives are those directives that control the assembler listing file format. They 
allow the specification of titles, pagination and other listing control.
Listing File
A listing file is an ASCII text file that shows the machine code generated for each C 
source statement, assembly instruction, assembler directive, or macro encountered in 
a source file.
Little Endian
A data ordering scheme for multibyte data whereby the least significant byte is stored 
at the lower addresses.
Local Label
A local label is one that is defined inside a macro with the LOCAL directive. These 
labels are particular to a given instance of a macro’s instantiation. In other words, the 
symbols and labels that are declared as local are no longer accessible after the ENDM 
macro is encountered.
Logic Probes
Up to 14 logic probes can be connected to some Microchip emulators. The logic probes 
provide external trace inputs, trigger output signal, +5V, and a common ground.
Loop-Back Test Board
Used to test the functionality of the MPLAB REAL ICE in-circuit emulator.
LVDS
Low Voltage Differential Signaling. A low noise, low-power, low amplitude method for 
high-speed (gigabits per second) data transmission over copper wire. 
With standard I/0 signaling, data storage is contingent upon the actual voltage level. 
Voltage level can be affected by wire length (longer wires increase resistance, which 
lowers voltage). But with LVDS, data storage is distinguished only by positive and 
negative voltage values, not the voltage level. Therefore, data can travel over greater 
lengths of wire while maintaining a clear and consistent data stream.
Source: http://www.webopedia.com/TERM/L/LVDS.html

M
Machine Code
The representation of a computer program that is actually read and interpreted by the 
processor. A program in binary machine code consists of a sequence of machine 
instructions (possibly interspersed with data). The collection of all possible instructions 
for a particular processor is known as its “instruction set”.
Machine Language
A set of instructions for a specific central processing unit, designed to be usable by a 
processor without being translated.
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Macro
Macro instruction. An instruction that represents a sequence of instructions in 
abbreviated form.
Macro Directives
Directives that control the execution and data allocation within macro body definitions.
Makefile
Export to a file the instructions to Make the project. Use this file to Make your project 
outside of MPLAB IDE/MPLAB X IDE, i.e., with a make.
Make Project
A command that rebuilds an application, recompiling only those source files that have 
changed since the last complete compilation.
MCU
Microcontroller Unit. An abbreviation for microcontroller. Also uC.
Memory Model
For C compilers, a representation of the memory available to the application. For the 
PIC18 C compiler, a description that specifies the size of pointers that point to program 
memory.
Message
Text displayed to alert you to potential problems in language tool operation. A message 
will not stop operation.
Microcontroller
A highly integrated chip that contains a CPU, RAM, program memory, I/O ports and 
timers.
Microcontroller Mode
One of the possible program memory configurations of PIC18 microcontrollers. In 
microcontroller mode, only internal execution is allowed. Thus, only the on-chip 
program memory is available in microcontroller mode.
Microprocessor Mode
One of the possible program memory configurations of PIC18 microcontrollers. In 
microprocessor mode, the on-chip program memory is not used. The entire program 
memory is mapped externally.
Mnemonics
Text instructions that can be translated directly into machine code. Also referred to as 
opcodes.
Module
The preprocessed output of a source file after preprocessor directives have been 
executed. Also known as a translation unit.
MPASM™ Assembler
Microchip Technology’s relocatable macro assembler for PIC microcontroller devices, 
KeeLoq® devices and Microchip memory devices.
MPLAB Language Tool for Device
Microchip’s C compilers, assemblers and linkers for specified devices. Select the type 
of language tool based on the device you will be using for your application, e.g., if you 
will be creating C code on a PIC18 MCU, select the MPLAB C Compiler for PIC18 
MCUs.
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MPLAB ICD
Microchip in-circuit debugger that works with MPLAB IDE/MPLAB X IDE. See ICE/ICD.
MPLAB IDE/MPLAB X IDE
Microchip’s Integrated Development Environment. MPLAB IDE/MPLAB X IDE comes 
with an editor, project manager and simulator.
MPLAB PM3
A device programmer from Microchip. Programs PIC18 microcontrollers and dsPIC 
digital signal controllers. Can be used with MPLAB IDE/MPLAB X IDE or stand-alone. 
Replaces PRO MATE II.
MPLAB REAL ICE™ In-Circuit Emulator
Microchip’s next-generation in-circuit emulator that works with MPLAB IDE/MPLAB X 
IDE. See ICE/ICD.
MPLAB SIM
Microchip’s simulator that works with MPLAB IDE/MPLAB X IDE in support of PIC MCU 
and dsPIC DSC devices.
MPLIB™ Object Librarian
Microchip’s librarian that can work with MPLAB IDE/MPLAB X IDE. MPLIB librarian is 
an object librarian for use with COFF object modules created using either MPASM 
assembler (mpasm or mpasmwin v2.0) or MPLAB C18 C Compiler.
MPLINK™ Object Linker
MPLINK linker is an object linker for the Microchip MPASM assembler and the 
Microchip C18 C compiler. MPLINK linker also may be used with the Microchip MPLIB 
librarian. MPLINK linker is designed to be used with MPLAB IDE/MPLAB X IDE, though 
it does not have to be.
MRU
Most Recently Used. Refers to files and windows available to be selected from MPLAB 
IDE/MPLAB X IDE main pull down menus.

N
Native Data Size
For Native trace, the size of the variable used in a Watch window must be of the same 
size as the selected device’s data memory: bytes for PIC18 devices and words for 
16-bit devices.
Nesting Depth
The maximum level to which macros can include other macros.
Node
MPLAB IDE/MPLAB X IDE project component.
Non-Extended Mode (PIC18 MCUs)
In Non-Extended mode, the compiler will not utilize the extended instructions nor the 
indexed with literal offset addressing.
Non Real Time
Refers to the processor at a breakpoint or executing single-step instructions or MPLAB 
IDE/MPLAB X IDE being run in simulator mode.
Non-Volatile Storage
A storage device whose contents are preserved when its power is off.
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NOP
No Operation. An instruction that has no effect when executed except to advance the 
program counter.

O
Object Code/Object File
Object code is the machine code generated by an assembler or compiler. An object file 
is a file containing machine code and possibly debug information. It may be 
immediately executable or it may be relocatable, requiring linking with other object files, 
e.g., libraries, to produce a complete executable program.
Object File Directives
Directives that are used only when creating an object file.
Octal
The base 8 number system that only uses the digits 0-7. The rightmost digit counts 
ones, the next digit counts multiples of 8, then 82 = 64, etc.
Off-Chip Memory
Off-chip memory refers to the memory selection option for the PIC18 device where 
memory may reside on the target board, or where all program memory may be supplied 
by the emulator. The Memory tab accessed from Options>Development Mode 
provides the Off-Chip Memory selection dialog box.
Opcodes
Operational Codes. See Mnemonics.
Operators
Symbols, like the plus sign ‘+’ and the minus sign ‘-’, that are used when forming 
well-defined expressions. Each operator has an assigned precedence that is used to 
determine order of evaluation.
OTP
One Time Programmable. EPROM devices that are not in windowed packages. Since 
EPROM needs ultraviolet light to erase its memory, only windowed devices are 
erasable.

P
Pass Counter
A counter that decrements each time an event (such as the execution of an instruction 
at a particular address) occurs. When the pass count value reaches zero, the event is 
satisfied. You can assign the Pass Counter to break and trace logic, and to any 
sequential event in the complex trigger dialog.
PC
Personal Computer or Program Counter.
PC Host
Any PC running a supported Windows operating system.
Persistent Data
Data that is never cleared or initialized. Its intended use is so that an application can 
preserve data across a device Reset.
Phantom Byte
An unimplemented byte in the dsPIC architecture that is used when treating the 24-bit 
instruction word as if it were a 32-bit instruction word. Phantom bytes appear in dsPIC 
hex files.
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PIC MCUs
PIC microcontrollers (MCUs) refers to all Microchip microcontroller families.
PICkit 2 and 3
Microchip’s developmental device programmers with debug capability through Debug 
Express. See the Readme files for each tool to see which devices are supported.
Plug-ins
The MPLAB IDE/MPLAB X IDE has both built-in components and plug-in modules to 
configure the system for a variety of software and hardware tools. Several plug-in tools 
may be found under the Tools menu.
Pod
The enclosure for an in-circuit emulator or debugger. Other names are “Puck”, if the 
enclosure is round, and “Probe”, not be confused with logic probes.
Power-on-Reset Emulation
A software randomization process that writes random values in data RAM areas to 
simulate uninitialized values in RAM upon initial power application.
Pragma
A directive that has meaning to a specific compiler. Often a pragma is used to convey 
implementation-defined information to the compiler.
Precedence
Rules that define the order of evaluation in expressions.
Production Programmer
A production programmer is a programming tool that has resources designed in to 
program devices rapidly. It has the capability to program at various voltage levels and 
completely adheres to the programming specification. Programming a device as fast 
as possible is of prime importance in a production environment where time is of the 
essence as the application circuit moves through the assembly line.
Profile
For MPLAB SIM simulator, a summary listing of executed stimulus by register.
Program Counter
The location that contains the address of the instruction that is currently executing.
Program Counter Unit
16-bit assembler – A conceptual representation of the layout of program memory. The 
program counter increments by 2 for each instruction word. In an executable section, 
2 program counter units are equivalent to 3 bytes. In a read-only section, 2 program 
counter units are equivalent to 2 bytes.
Program Memory
MPLAB IDE/MPLAB X IDE – The memory area in a device where instructions are 
stored. Also, the memory in the emulator or simulator containing the downloaded target 
application firmware.
16-bit assembler/compiler – The memory area in a device where instructions are 
stored.
Project
A project contains the files needed to build an application (source code, linker script 
files, etc.) along with their associations to various build tools and build options.
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Prologue
A portion of compiler-generated code that is responsible for allocating stack space, 
preserving registers and performing any other machine-specific requirement specified 
in the runtime model. This code executes before any user code for a given function.
Prototype System
A term referring to a user's target application, or target board.
Psect
The OCG equivalent of a GCC section, short for program section. A block of code or 
data which is treated as a whole by the linker.
PWM Signals
Pulse Width Modulation Signals. Certain PIC MCU devices have a PWM peripheral.

Q
Qualifier
An address or an address range used by the Pass Counter or as an event before 
another operation in a complex trigger.

R
Radix
The number base, hex, or decimal, used in specifying an address.
RAM
Random Access Memory (Data Memory). Memory in which information can be 
accessed in any order.
Raw Data
The binary representation of code or data associated with a section.
Read Only Memory
Memory hardware that allows fast access to permanently stored data but prevents 
addition to or modification of the data.
Real Time
When an in-circuit emulator or debugger is released from the halt state, the processor 
runs in Real Time mode and behaves exactly as the normal chip would behave. In Real 
Time mode, the real time trace buffer of an emulator is enabled and constantly captures 
all selected cycles, and all break logic is enabled. In an in-circuit emulator or debugger, 
the processor executes in real time until a valid breakpoint causes a halt, or until the 
user halts the execution.
In the simulator, real time simply means execution of the microcontroller instructions as 
fast as they can be simulated by the host CPU.
Recursive Calls
A function that calls itself, either directly or indirectly.
Recursion
The concept that a function or macro, having been defined, can call itself. Great care 
should be taken when writing recursive macros; it is easy to get caught in an infinite 
loop where there will be no exit from the recursion.
Reentrant
A function that may have multiple, simultaneously active instances. This may happen 
due to either direct or indirect recursion or through execution during interrupt 
processing.
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Relaxation
The process of converting an instruction to an identical, but smaller instruction. This is 
useful for saving on code size. MPLAB XC16 currently knows how to relax a CALL 
instruction into an RCALL instruction. This is done when the symbol that is being called 
is within +/- 32k instruction words from the current instruction.
Relocatable
An object whose address has not been assigned to a fixed location in memory.
Relocatable Section
16-bit assembler – A section whose address is not fixed (absolute). The linker assigns 
addresses to relocatable sections through a process called relocation.
Relocation
A process performed by the linker in which absolute addresses are assigned to 
relocatable sections and all symbols in the relocatable sections are updated to their 
new addresses.
ROM
Read Only Memory (Program Memory). Memory that cannot be modified.
Run
The command that releases the emulator from halt, allowing it to run the application 
code and change or respond to I/O in real time.
Run-time Model
Describes the use of target architecture resources.
Runtime Watch
A Watch window where the variables change in as the application is run. See individual 
tool documentation to determine how to set up a runtime watch. Not all tools support 
runtime watches.

S
Scenario
For MPLAB SIM simulator, a particular setup for stimulus control.
Section
The GCC equivalent of an OCG psect. A block of code or data which is treated as a 
whole by the linker.
Section Attribute
A GCC characteristic ascribed to a section (e.g., an access section).
Sequenced Breakpoints
Breakpoints that occur in a sequence. Sequence execution of breakpoints is 
bottom-up; the last breakpoint in the sequence occurs first.
Serialized Quick Turn Programming
Serialization allows you to program a serial number into each microcontroller device 
that the Device Programmer programs. This number can be used as an entry code, 
password or ID number.
Shell
The MPASM assembler shell is a prompted input interface to the macro assembler. 
There are two MPASM assembler shells: one for the DOS version and one for the 
Windows operating system version.
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Simulator
A software program that models the operation of devices.
Single Step
This command steps though code, one instruction at a time. After each instruction, 
MPLAB IDE/MPLAB X IDE updates register windows, watch variables, and status 
displays so you can analyze and debug instruction execution. You can also single step 
C compiler source code, but instead of executing single instructions, MPLAB 
IDE/MPLAB X IDE will execute all assembly level instructions generated by the line of 
the high level C statement.
Skew
The information associated with the execution of an instruction appears on the 
processor bus at different times. For example, the executed opcodes appears on the 
bus as a fetch during the execution of the previous instruction, the source data address 
and value and the destination data address appear when the opcodes is actually 
executed, and the destination data value appears when the next instruction is 
executed. The trace buffer captures the information that is on the bus at one instance. 
Therefore, one trace buffer entry will contain execution information for three 
instructions. The number of captured cycles from one piece of information to another 
for a single instruction execution is referred to as the skew.
Skid
When a hardware breakpoint is used to halt the processor, one or more additional 
instructions may be executed before the processor halts. The number of extra 
instructions executed after the intended breakpoint is referred to as the skid.
Source Code
The form in which a computer program is written by the programmer. Source code is 
written in a formal programming language which can be translated into machine code 
or executed by an interpreter.
Source File
An ASCII text file containing source code.
Special Function Registers (SFRs)
The portion of data memory (RAM) dedicated to registers that control I/O processor 
functions, I/O status, timers or other modes or peripherals.
SQTP
See Serialized Quick Turn Programming.
Stack, Hardware
Locations in PIC microcontroller where the return address is stored when a function call 
is made.
Stack, Software
Memory used by an application for storing return addresses, function parameters, and 
local variables. This memory is dynamically allocated at runtime by instructions in the 
program. It allows for reentrant function calls.
Stack, Compiled
A region of memory managed and allocated by the compiler in which variables are 
statically assigned space. It replaces a software stack when such mechanisms cannot 
be efficiently implemented on the target device. It precludes reentrancy.
MPLAB Starter Kit for Device
Microchip’s starter kits contains everything needed to begin exploring the specified 
device. View a working application and then debug and program you own changes.
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Static RAM or SRAM
Static Random Access Memory. Program memory you can read/write on the target 
board that does not need refreshing frequently.
Status Bar
The Status Bar is located on the bottom of the MPLAB IDE/MPLAB X IDE window and 
indicates such current information as cursor position, development mode and device, 
and active tool bar.
Step Into
This command is the same as Single Step. Step Into (as opposed to Step Over) follows 
a CALL instruction into a subroutine.
Step Over
Step Over allows you to debug code without stepping into subroutines. When stepping 
over a CALL instruction, the next breakpoint will be set at the instruction after the CALL. 
If for some reason the subroutine gets into an endless loop or does not return properly, 
the next breakpoint will never be reached. The Step Over command is the same as 
Single Step except for its handling of CALL instructions.
Step Out
Step Out allows you to step out of a subroutine which you are currently stepping 
through. This command executes the rest of the code in the subroutine and then stops 
execution at the return address to the subroutine.
Stimulus
Input to the simulator, i.e., data generated to exercise the response of simulation to 
external signals. Often the data is put into the form of a list of actions in a text file. 
Stimulus may be asynchronous, synchronous (pin), clocked and register.
Stopwatch
A counter for measuring execution cycles.
Storage Class
Determines the lifetime of the memory associated with the identified object.
Storage Qualifier
Indicates special properties of the objects being declared (e.g., const).
Symbol
A symbol is a general purpose mechanism for describing the various pieces which 
comprise a program. These pieces include function names, variable names, section 
names, file names, struct/enum/union tag names, etc. Symbols in MPLAB IDE/MPLAB 
X IDE refer mainly to variable names, function names and assembly labels. The value 
of a symbol after linking is its value in memory.
Symbol, Absolute
Represents an immediate value such as a definition through the assembly .equ 
directive.
System Window Control
The system window control is located in the upper left corner of windows and some 
dialogs. Clicking on this control usually pops up a menu that has the items “Minimize,” 
“Maximize,” and “Close.”
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T
Target
Refers to user hardware.
Target Application
Software residing on the target board.
Target Board
The circuitry and programmable device that makes up the target application.
Target Processor
The microcontroller device on the target application board.
Template
Lines of text that you build for inserting into your files at a later time. The MPLAB Editor 
stores templates in template files.
Tool Bar
A row or column of icons that you can click on to execute MPLAB IDE/MPLAB X IDE 
functions.
Trace
An emulator or simulator function that logs program execution. The emulator logs 
program execution into its trace buffer which is uploaded to the MPLAB IDE/MPLAB X 
IDE trace window.
Trace Memory
Trace memory contained within the emulator. Trace memory is sometimes called the 
trace buffer.
Trace Macro
A macro that will provide trace information from emulator data. Since this is a software 
trace, the macro must be added to code, the code must be recompiled or reassembled, 
and the target device must be programmed with this code before trace will work.
Trigger Output
Trigger output refers to an emulator output signal that can be generated at any address 
or address range, and is independent of the trace and breakpoint settings. Any number 
of trigger output points can be set.
Trigraphs
Three-character sequences, all starting with ??, that are defined by ISO C as 
replacements for single characters.

U
Unassigned Section
A section which has not been assigned to a specific target memory block in the linker 
command file. The linker must find a target memory block in which to allocate an 
unassigned section.
Uninitialized Data
Data which is defined without an initial value. In C,
int myVar; 
defines a variable which will reside in an uninitialized data section.
Upload
The Upload function transfers data from a tool, such as an emulator or programmer, to 
the host PC or from the target board to the emulator.
DS50002085B-page 184  2013-2014 Microchip Technology Inc.



Glossary
USB
Universal Serial Bus. An external peripheral interface standard for communication 
between a computer and external peripherals over a cable using bi-serial transmission. 
USB 1.0/1.1 supports data transfer rates of 12 Mbps. Also referred to as high-speed 
USB, USB 2.0 supports data rates up to 480 Mbps.

V
Vector
The memory locations that an application will jump to when either a Reset or interrupt 
occurs.
Volatile
A variable qualifier which prevents the compiler applying optimizations that affect how 
the variable is accessed in memory.

W
Warning
MPLAB IDE/MPLAB X IDE – An alert that is provided to warn you of a situation that 
would cause physical damage to a device, software file, or equipment.
16-bit assembler/compiler – Warnings report conditions that may indicate a problem, 
but do not halt processing. 
Watch Variable
A variable that you may monitor during a debugging session in a Watch window.
Watch Window
Watch windows contain a list of watch variables that are updated at each breakpoint.
Watchdog Timer (WDT)
A timer on a PIC microcontroller that resets the processor after a selectable length of 
time. The WDT is enabled or disabled and set up using Configuration bits.
Workbook
For MPLAB SIM stimulator, a setup for generation of SCL stimulus.
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